ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/pyrex.spec
Revision: 1.1
Committed: Tue Apr 18 21:27:47 2006 UTC (19 years ago) by eulisse
Branch: MAIN
Log Message:
Renamed from Pyrex.spec to pyrex.spec.
Using --prefix option, rather than fiddling with the python installation.
Correctly set PYTHONPATH.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external pyrex 0.9.3.1
2     %define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2)
3     ## INITENV +PATH PYTHONPATH %{i}/lib/python%{pythonv}
4    
5     Summary: A language for writing Python extension modules.
6     Group: Development/Libraries
7     Vendor: Greg Ewing <greg@cosc.canterbury.ac.nz>
8     Url: http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/
9     Packager: Conrad Steenberg <conrad@hep.caltech.edu>
10     Source: http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/Pyrex-%{v}.tar.gz
11     Requires: python
12     %prep
13     %setup -n Pyrex-%{v}
14     %build
15     python setup.py build
16     %install
17     python setup.py install --prefix=%i