ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python-ldap.spec
Revision: 1.8
Committed: Tue Aug 10 15:25:07 2010 UTC (14 years, 8 months ago) by muzaffar
Branch: MAIN
CVS Tags: pe20100827a-for39Xrb, sm100826a, pe20100826a-for39Xrb, pe20100825b-for39Xrb, pe20100825a-for39Xrb, pe20100824c-for39Xrb, pe20100824b-for39Xrb, sm100824a, pe20100824a-for39Xrb, sm100811b, sm100811a, sm20100810a
Changes since 1.7: +0 -21 lines
Log Message:
cleanup for toolfiles which are now in separate spec files to avoid re-build of the external in case tool definition needs update

File Contents

# Content
1 ### RPM external python-ldap 2.3.5
2 ## INITENV +PATH PYTHONPATH %i/lib/python`echo $PYTHON_VERSION | cut -f1,2 -d.`/site-packages
3
4 Source: http://voxel.dl.sourceforge.net/sourceforge/python-ldap/python-ldap-%{realversion}.tar.gz
5 Patch0: python-ldap-2.3.5-gcc44
6 Requires: python openssl openldap
7
8 %prep
9 %setup -q -n %n-%{realversion}
10 %patch0 -p1
11
12 %build
13 mkdir -p sasl2lib
14 ln -s /usr/lib/libsasl2.so.2.0.19 sasl2lib/libsasl2.so
15
16 perl -p -i -e 's|/usr/local/openldap-2.3/|$ENV{OPENLDAP_ROOT}/|; s|(library_dirs = .*)|$1 /usr/lib/sasl2 %{_builddir}/%n-%{realversion}/sasl2lib $ENV{OPENSSL_ROOT}/lib|;' setup.cfg
17 python setup.py build
18 %install
19 python setup.py install --prefix=%i
20
21 # Dependencies environment
22 rm -rf %i/etc/profile.d
23 mkdir -p %i/etc/profile.d
24 for x in %pkgreqs; do
25 case $x in /* ) continue ;; esac
26 p=%{instroot}/%{cmsplatf}/$(echo $x | sed 's/\([^+]*\)+\(.*\)+\([A-Z0-9].*\)/\1 \2 \3/' | tr ' ' '/')
27 echo ". $p/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
28 echo "source $p/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
29 done
30
31
32 %post
33 %{relocateConfig}etc/profile.d/dependencies-setup.sh
34 %{relocateConfig}etc/profile.d/dependencies-setup.csh
35