ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python-tdb.spec
Revision: 1.3
Committed: Fri Apr 21 16:45:19 2006 UTC (19 years ago) by steen
Branch: MAIN
CVS Tags: V00-00-00
Changes since 1.2: +2 -10 lines
Log Message:
Change dependency from Pyrex to pyrex.

Conrad Steenberg <conrad@hep.caltech.edu>
California Institute of Technology | http://conradsteenberg.info

File Contents

# User Rev Content
1 steen 1.1 ### RPM external python-tdb 0.0.6
2     %define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2)
3 steen 1.3 ## INITENV +PATH PYTHONPATH %{i}/lib/python%{pythonv}
4 steen 1.1
5     Summary: Python binding for the Samba Trivial Database
6     Packager:Conrad Steenberg <conrad@hep.caltech.edu>
7     Vendor: Conrad Steenberg <conrad@hep.caltech.edu>
8    
9     Source: http://julian.ultralight.org/clarens/devel/%n-%v.tar.gz
10 steen 1.3 Requires: python tdb pyrex
11 steen 1.1
12    
13     %description
14    
15     A Python binding for TDB. TDB is a Trivial Database. In concept, it is very
16     much like GDBM, and BSD's DB except that it allows multiple simultaneous
17     writers and uses locking internally to keep writers from trampling on each
18     other. TDB is also extremely small.
19    
20     This binding exposes a low-level TDB interface class, as well as a dictionary
21     (mapping) class.
22    
23     %prep
24     %setup -n %n-%v
25    
26     %build
27     mkdir build
28    
29     %install
30 steen 1.2 export CFLAGS="-I$TDB_ROOT/include -I$LIBJIO_ROOT/include -D_FILE_OFFSET_BITS=64"
31     export LDFLAGS="-L$TDB_ROOT/lib -L$LIBJIO_ROOT/lib"
32 steen 1.1 python setup.py --build --prefix=%{i} --install --root=/
33    
34     %files
35     %i