1 |
ratnik |
1.35 |
### RPM external python 2.4.2-CMS9
|
2 |
eulisse |
1.3 |
## INITENV +PATH PATH %i/bin
|
3 |
|
|
## INITENV +PATH LD_LIBRARY_PATH %i/lib
|
4 |
argiro |
1.1 |
# OS X patches and build fudging stolen from fink
|
5 |
ratnik |
1.34 |
|
6 |
|
|
Requires: expat bz2lib db4 gdbm
|
7 |
|
|
|
8 |
|
|
%if "%{?online_release:set}" != "set"
|
9 |
|
|
Requires: zlib openssl
|
10 |
|
|
%endif
|
11 |
|
|
|
12 |
eulisse |
1.8 |
# FIXME: readline, crypt
|
13 |
argiro |
1.1 |
# FIXME: gmp, panel, tk/tcl, x11
|
14 |
|
|
|
15 |
elmer |
1.24 |
Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
|
16 |
elmer |
1.13 |
Patch0: python-Include-pyport.h
|
17 |
|
|
Patch1: python-Lib-plat-mac-applesingle.py
|
18 |
|
|
Patch2: python-Lib-site.py
|
19 |
|
|
Patch3: python-Mac-OSX-Makefile
|
20 |
|
|
Patch4: python-Makefile.pre.in
|
21 |
|
|
Patch5: python-configure
|
22 |
|
|
Patch6: python-setup.py
|
23 |
argiro |
1.1 |
|
24 |
steen |
1.19 |
|
25 |
argiro |
1.1 |
%prep
|
26 |
elmer |
1.24 |
%setup -n Python-%realversion
|
27 |
elmer |
1.13 |
#%patch0
|
28 |
|
|
#%patch1
|
29 |
|
|
#%patch2
|
30 |
|
|
#%patch3
|
31 |
|
|
#%patch4
|
32 |
|
|
#%patch5
|
33 |
|
|
#%patch6
|
34 |
eulisse |
1.5 |
perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" Lib/cgi.py
|
35 |
|
|
|
36 |
argiro |
1.1 |
%ifos darwin
|
37 |
|
|
sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
|
38 |
|
|
%endif
|
39 |
|
|
|
40 |
|
|
%build
|
41 |
|
|
# Python is awkward about passing other include or library directories
|
42 |
|
|
# to it. Basically there is no way to pass anything from configure to
|
43 |
|
|
# make, or down to python itself. To get python detect the extensions
|
44 |
|
|
# we want to enable, we simply have to link the contents into python's
|
45 |
|
|
# own include/lib directories. Ugh.
|
46 |
|
|
#
|
47 |
|
|
# NB: It would sort-of make sense to link more stuff from /sw on OS X,
|
48 |
|
|
# but we simply cannot link the whole world. If you need something,
|
49 |
|
|
# see above for the commented-out list of packages that could be
|
50 |
|
|
# linked specifically, or could be built by ourselves, depending on
|
51 |
|
|
# whether we like to pick up system libraries or want total control.
|
52 |
|
|
mkdir -p %i/include %i/lib
|
53 |
ratnik |
1.34 |
|
54 |
|
|
%if "%{?online_release:set}" != "set"
|
55 |
|
|
%define extradirs $ZLIB_ROOT $OPENSSL_ROOT
|
56 |
|
|
%else
|
57 |
|
|
%define extradirs %{nil}
|
58 |
|
|
%endif
|
59 |
|
|
|
60 |
|
|
dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
|
61 |
|
|
|
62 |
eulisse |
1.16 |
echo $dirs
|
63 |
argiro |
1.1 |
for d in $dirs; do
|
64 |
|
|
for f in $d/include/*; do
|
65 |
eulisse |
1.29 |
[ -e $f ] || continue
|
66 |
argiro |
1.1 |
rm -f %i/include/$(basename $f)
|
67 |
|
|
ln -s $f %i/include
|
68 |
|
|
done
|
69 |
|
|
for f in $d/lib/*; do
|
70 |
eulisse |
1.29 |
[ -e $f ] || continue
|
71 |
argiro |
1.1 |
rm -f %i/lib/$(basename $f)
|
72 |
|
|
ln -s $f %i/lib
|
73 |
|
|
done
|
74 |
|
|
done
|
75 |
|
|
|
76 |
ratnik |
1.34 |
./configure --prefix=%i --enable-shared --without-tkinter --disable-tkinter --without-readline
|
77 |
eulisse |
1.3 |
make %makeprocesses
|
78 |
argiro |
1.1 |
|
79 |
|
|
%install
|
80 |
|
|
make install
|
81 |
elmer |
1.24 |
%define pythonv %(echo %realversion | cut -d. -f 1,2)
|
82 |
eulisse |
1.8 |
|
83 |
elmer |
1.13 |
#if [ $(uname) = Darwin ]; then
|
84 |
argiro |
1.1 |
# make install prefix=%i
|
85 |
|
|
# (cd Misc; /bin/rm -rf RPM)
|
86 |
|
|
# mkdir -p %i/share/doc/%n
|
87 |
|
|
# cp -R Demo Doc %i/share/doc/%n
|
88 |
eulisse |
1.8 |
# cp -R Misc Tools %i/lib/python%{pythonv}
|
89 |
elmer |
1.13 |
# gcc -dynamiclib -all_load -single_module \
|
90 |
|
|
# -framework System -framework CoreServices -framework Foundation \
|
91 |
|
|
# %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
|
92 |
|
|
# -undefined dynamic_lookup \
|
93 |
|
|
# -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
|
94 |
|
|
# -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
|
95 |
|
|
# -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
|
96 |
|
|
# ln -s libpython%{pythonv}.dylib %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib # for boost
|
97 |
eulisse |
1.8 |
# (cd %i/lib/python%{pythonv}/config; mv Makefile Makefile.orig;
|
98 |
argiro |
1.1 |
# sed 's|-fno-common||g' < Makefile.orig > Makefile; /bin/rm -f Makefile.orig)
|
99 |
elmer |
1.13 |
#fi
|
100 |
eulisse |
1.9 |
|
101 |
|
|
perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
|
102 |
|
|
%{i}/bin/pydoc \
|
103 |
|
|
%{i}/bin/smtpd.py \
|
104 |
|
|
%{i}/lib/python2.4/bsddb/dbshelve.py \
|
105 |
|
|
%{i}/lib/python2.4/test/test_bz2.py \
|
106 |
|
|
%{i}/lib/python2.4/test/test_largefile.py \
|
107 |
|
|
%{i}/lib/python2.4/test/test_optparse.py
|
108 |
eulisse |
1.14 |
# boost.spec rfio.spec
|
109 |
eulisse |
1.15 |
#
|
110 |
|
|
#
|
111 |
eulisse |
1.17 |
rm `find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*'`
|
112 |
eulisse |
1.18 |
rm `find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*'`
|
113 |
muzaffar |
1.28 |
|
114 |
|
|
# SCRAM ToolBox toolfile
|
115 |
|
|
mkdir -p %i/etc/scram.d
|
116 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
|
117 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
118 |
|
|
<Tool name=%n version=%v>
|
119 |
|
|
<lib name=python2.4>
|
120 |
|
|
<Client>
|
121 |
|
|
<Environment name=PYTHON_BASE default="%i"></Environment>
|
122 |
|
|
<Environment name=LIBDIR default="$PYTHON_BASE/lib"></Environment>
|
123 |
|
|
<Environment name=INCLUDE default="$PYTHON_BASE/include/python2.4"></Environment>
|
124 |
|
|
<Environment name=PYTHON_COMPILE default="$PYTHON_BASE/lib/python2.4/compileall.py"></Environment>
|
125 |
|
|
</Client>
|
126 |
|
|
<use name=sockets>
|
127 |
|
|
<Runtime name=PATH value="$PYTHON_BASE/bin" type=path>
|
128 |
|
|
</Tool>
|
129 |
|
|
EOF_TOOLFILE
|
130 |
|
|
|
131 |
eulisse |
1.16 |
%post
|
132 |
|
|
find $RPM_INSTALL_PREFIX/%pkgrel/lib -type l | xargs ls -la | sed -e "s|.*[ ]\(/.*\) -> \(.*\)| \2 \1|;s|[ ]/[^ ]*/external| $RPM_INSTALL_PREFIX/%cmsplatf/external|g" | xargs -n2 ln -sf
|
133 |
muzaffar |
1.28 |
%{relocateConfig}etc/scram.d/%n
|