ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.41
Committed: Tue May 13 17:29:46 2008 UTC (16 years, 11 months ago) by ratnik
Branch: MAIN
CVS Tags: CMSSW_2_0_8_ONLINE1, SiteDB_030608_1, SiteDB_300508_1, nr080529_onl_cmsBuild, nr080528_onl_cmsBuild, SiteDB_280508_1
Changes since 1.40: +2 -2 lines
Log Message:
Changes for building online releases with cmsBuild:
 * Checking online_release flag is replaced by check if cmsplatf is
   "slc4onl_ia32_gcc346".

File Contents

# User Rev Content
1 elmer 1.40 ### RPM external python 2.4.2-CMS19
2 eulisse 1.3 ## INITENV +PATH PATH %i/bin
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 argiro 1.1 # OS X patches and build fudging stolen from fink
5 ratnik 1.34
6     Requires: expat bz2lib db4 gdbm
7    
8 ratnik 1.41 %if "%cmsplatf" != "slc4onl_ia32_gcc346"
9 ratnik 1.34 Requires: zlib openssl
10     %endif
11    
12 eulisse 1.8 # FIXME: readline, crypt
13 argiro 1.1 # FIXME: gmp, panel, tk/tcl, x11
14    
15 elmer 1.24 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
16 elmer 1.13 Patch0: python-Include-pyport.h
17     Patch1: python-Lib-plat-mac-applesingle.py
18     Patch2: python-Lib-site.py
19     Patch3: python-Mac-OSX-Makefile
20     Patch4: python-Makefile.pre.in
21     Patch5: python-configure
22     Patch6: python-setup.py
23 argiro 1.1
24 steen 1.19
25 argiro 1.1 %prep
26 elmer 1.24 %setup -n Python-%realversion
27 elmer 1.13 #%patch0
28     #%patch1
29     #%patch2
30     #%patch3
31     #%patch4
32     #%patch5
33     #%patch6
34 eulisse 1.5 perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" Lib/cgi.py
35    
36 argiro 1.1 %ifos darwin
37     sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
38     %endif
39    
40     %build
41     # Python is awkward about passing other include or library directories
42     # to it. Basically there is no way to pass anything from configure to
43     # make, or down to python itself. To get python detect the extensions
44     # we want to enable, we simply have to link the contents into python's
45     # own include/lib directories. Ugh.
46     #
47     # NB: It would sort-of make sense to link more stuff from /sw on OS X,
48     # but we simply cannot link the whole world. If you need something,
49     # see above for the commented-out list of packages that could be
50     # linked specifically, or could be built by ourselves, depending on
51     # whether we like to pick up system libraries or want total control.
52     mkdir -p %i/include %i/lib
53 ratnik 1.34
54 ratnik 1.41 %if "%cmsplatf" != "slc4onl_ia32_gcc346"
55 ratnik 1.34 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT
56     %else
57     %define extradirs %{nil}
58     %endif
59    
60     dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
61    
62 eulisse 1.16 echo $dirs
63 argiro 1.1 for d in $dirs; do
64     for f in $d/include/*; do
65 eulisse 1.29 [ -e $f ] || continue
66 argiro 1.1 rm -f %i/include/$(basename $f)
67     ln -s $f %i/include
68     done
69     for f in $d/lib/*; do
70 eulisse 1.29 [ -e $f ] || continue
71 argiro 1.1 rm -f %i/lib/$(basename $f)
72     ln -s $f %i/lib
73     done
74     done
75    
76 eulisse 1.39 additionalConfigureOptions=""
77     case %cmsplatf in
78     osx105* )
79     additionalConfigureOptions="--disable-readline"
80     ;;
81     esac
82    
83     ./configure --prefix=%i $additionalConfigureOptions --enable-shared \
84     --without-tkinter --disable-tkinter
85    
86 ratnik 1.38 # The following is a kludge around the fact that the /usr/lib/libreadline.so
87     # symlink (for 32-bit lib) is missing on the 64bit machines
88     %if "%cmsplatf" == "slc4_ia32_gcc345"
89     mkdir -p %{i}/lib
90     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
91     %endif
92     %if "%cmsplatf" == "slc4_ia32_gcc412"
93     mkdir -p %{i}/lib
94     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
95     %endif
96     make %makeprocesses
97 ratnik 1.37
98 argiro 1.1 %install
99     make install
100 elmer 1.24 %define pythonv %(echo %realversion | cut -d. -f 1,2)
101 eulisse 1.8
102 elmer 1.13 #if [ $(uname) = Darwin ]; then
103 argiro 1.1 # make install prefix=%i
104     # (cd Misc; /bin/rm -rf RPM)
105     # mkdir -p %i/share/doc/%n
106     # cp -R Demo Doc %i/share/doc/%n
107 eulisse 1.8 # cp -R Misc Tools %i/lib/python%{pythonv}
108 elmer 1.13 # gcc -dynamiclib -all_load -single_module \
109     # -framework System -framework CoreServices -framework Foundation \
110     # %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
111     # -undefined dynamic_lookup \
112     # -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
113     # -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
114     # -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
115     # ln -s libpython%{pythonv}.dylib %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib # for boost
116 eulisse 1.8 # (cd %i/lib/python%{pythonv}/config; mv Makefile Makefile.orig;
117 argiro 1.1 # sed 's|-fno-common||g' < Makefile.orig > Makefile; /bin/rm -f Makefile.orig)
118 elmer 1.13 #fi
119 eulisse 1.9
120     perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
121     %{i}/bin/pydoc \
122     %{i}/bin/smtpd.py \
123     %{i}/lib/python2.4/bsddb/dbshelve.py \
124     %{i}/lib/python2.4/test/test_bz2.py \
125     %{i}/lib/python2.4/test/test_largefile.py \
126     %{i}/lib/python2.4/test/test_optparse.py
127 eulisse 1.14 # boost.spec rfio.spec
128 eulisse 1.15 #
129     #
130 eulisse 1.17 rm `find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*'`
131 eulisse 1.18 rm `find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*'`
132 muzaffar 1.28
133     # SCRAM ToolBox toolfile
134     mkdir -p %i/etc/scram.d
135     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
136     <doc type=BuildSystem::ToolDoc version=1.0>
137     <Tool name=%n version=%v>
138     <lib name=python2.4>
139     <Client>
140     <Environment name=PYTHON_BASE default="%i"></Environment>
141     <Environment name=LIBDIR default="$PYTHON_BASE/lib"></Environment>
142     <Environment name=INCLUDE default="$PYTHON_BASE/include/python2.4"></Environment>
143     <Environment name=PYTHON_COMPILE default="$PYTHON_BASE/lib/python2.4/compileall.py"></Environment>
144     </Client>
145     <use name=sockets>
146     <Runtime name=PATH value="$PYTHON_BASE/bin" type=path>
147     </Tool>
148     EOF_TOOLFILE
149    
150 eulisse 1.16 %post
151     find $RPM_INSTALL_PREFIX/%pkgrel/lib -type l | xargs ls -la | sed -e "s|.*[ ]\(/.*\) -> \(.*\)| \2 \1|;s|[ ]/[^ ]*/external| $RPM_INSTALL_PREFIX/%cmsplatf/external|g" | xargs -n2 ln -sf
152 muzaffar 1.28 %{relocateConfig}etc/scram.d/%n