ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.44
Committed: Thu Feb 26 11:21:46 2009 UTC (16 years, 2 months ago) by eulisse
Branch: MAIN
CVS Tags: DAS_20090514_1, DAS_20090319, DAS_20090316, DAS_20090313
Changes since 1.43: +7 -1 lines
Log Message:
Working python2.5 for macosx.

File Contents

# User Rev Content
1 eulisse 1.44 ### RPM external python 2.5.4
2 eulisse 1.3 ## INITENV +PATH PATH %i/bin
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 argiro 1.1 # OS X patches and build fudging stolen from fink
5 ratnik 1.34
6     Requires: expat bz2lib db4 gdbm
7    
8 ratnik 1.41 %if "%cmsplatf" != "slc4onl_ia32_gcc346"
9 ratnik 1.34 Requires: zlib openssl
10     %endif
11    
12 eulisse 1.8 # FIXME: readline, crypt
13 argiro 1.1 # FIXME: gmp, panel, tk/tcl, x11
14    
15 elmer 1.24 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
16 elmer 1.13 Patch0: python-Include-pyport.h
17     Patch1: python-Lib-plat-mac-applesingle.py
18     Patch2: python-Lib-site.py
19     Patch3: python-Mac-OSX-Makefile
20     Patch4: python-Makefile.pre.in
21     Patch5: python-configure
22     Patch6: python-setup.py
23 argiro 1.1
24 steen 1.19
25 argiro 1.1 %prep
26 elmer 1.24 %setup -n Python-%realversion
27 elmer 1.13 #%patch0
28     #%patch1
29     #%patch2
30     #%patch3
31     #%patch4
32     #%patch5
33     #%patch6
34 eulisse 1.5 perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" Lib/cgi.py
35    
36 argiro 1.1 %ifos darwin
37     sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
38     %endif
39    
40     %build
41     # Python is awkward about passing other include or library directories
42     # to it. Basically there is no way to pass anything from configure to
43     # make, or down to python itself. To get python detect the extensions
44     # we want to enable, we simply have to link the contents into python's
45     # own include/lib directories. Ugh.
46     #
47     # NB: It would sort-of make sense to link more stuff from /sw on OS X,
48     # but we simply cannot link the whole world. If you need something,
49     # see above for the commented-out list of packages that could be
50     # linked specifically, or could be built by ourselves, depending on
51     # whether we like to pick up system libraries or want total control.
52     mkdir -p %i/include %i/lib
53 ratnik 1.34
54 ratnik 1.41 %if "%cmsplatf" != "slc4onl_ia32_gcc346"
55 ratnik 1.34 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT
56     %else
57     %define extradirs %{nil}
58     %endif
59    
60     dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
61    
62 eulisse 1.16 echo $dirs
63 argiro 1.1 for d in $dirs; do
64     for f in $d/include/*; do
65 eulisse 1.29 [ -e $f ] || continue
66 argiro 1.1 rm -f %i/include/$(basename $f)
67     ln -s $f %i/include
68     done
69     for f in $d/lib/*; do
70 eulisse 1.29 [ -e $f ] || continue
71 argiro 1.1 rm -f %i/lib/$(basename $f)
72     ln -s $f %i/lib
73     done
74     done
75    
76 eulisse 1.39 additionalConfigureOptions=""
77     case %cmsplatf in
78     osx105* )
79     additionalConfigureOptions="--disable-readline"
80     ;;
81     esac
82    
83     ./configure --prefix=%i $additionalConfigureOptions --enable-shared \
84     --without-tkinter --disable-tkinter
85    
86 ratnik 1.38 # The following is a kludge around the fact that the /usr/lib/libreadline.so
87     # symlink (for 32-bit lib) is missing on the 64bit machines
88 eulisse 1.43 case %cmsplatf in
89     slc4_ia32* )
90     mkdir -p %{i}/lib
91     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
92     ;;
93     esac
94 ratnik 1.38 make %makeprocesses
95 ratnik 1.37
96 argiro 1.1 %install
97     make install
98 elmer 1.24 %define pythonv %(echo %realversion | cut -d. -f 1,2)
99 eulisse 1.8
100 eulisse 1.43 case %cmsplatf in
101     osx*)
102     make install prefix=%i
103     (cd Misc; /bin/rm -rf RPM)
104     mkdir -p %i/share/doc/%n
105     cp -R Demo Doc %i/share/doc/%n
106     cp -R Misc Tools %i/lib/python%{pythonv}
107     gcc -dynamiclib -all_load -single_module \
108     -framework System -framework CoreServices -framework Foundation \
109     %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
110     -undefined dynamic_lookup \
111     -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
112     -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
113     -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
114     (cd %i/lib/python%{pythonv}/config
115     perl -p -i -e 's|-fno-common||g' Makefile)
116    
117     find %i/lib/python%{pythonv}/config -name 'libpython*' -exec mv {} %i/lib \;
118     ;;
119     esac
120 eulisse 1.9
121     perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
122     %{i}/bin/pydoc \
123     %{i}/bin/smtpd.py \
124     %{i}/lib/python2.4/bsddb/dbshelve.py \
125     %{i}/lib/python2.4/test/test_bz2.py \
126     %{i}/lib/python2.4/test/test_largefile.py \
127     %{i}/lib/python2.4/test/test_optparse.py
128 eulisse 1.17 rm `find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*'`
129 eulisse 1.18 rm `find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*'`
130 muzaffar 1.28
131 ratnik 1.42 # remove tkinter that brings dependency on libtk:
132     #
133    
134     rm `find %{i}/lib -type f -name "_tkinter.so"`
135    
136 muzaffar 1.28 # SCRAM ToolBox toolfile
137     mkdir -p %i/etc/scram.d
138     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
139     <doc type=BuildSystem::ToolDoc version=1.0>
140     <Tool name=%n version=%v>
141     <lib name=python2.4>
142     <Client>
143     <Environment name=PYTHON_BASE default="%i"></Environment>
144     <Environment name=LIBDIR default="$PYTHON_BASE/lib"></Environment>
145     <Environment name=INCLUDE default="$PYTHON_BASE/include/python2.4"></Environment>
146     <Environment name=PYTHON_COMPILE default="$PYTHON_BASE/lib/python2.4/compileall.py"></Environment>
147     </Client>
148     <use name=sockets>
149     <Runtime name=PATH value="$PYTHON_BASE/bin" type=path>
150     </Tool>
151     EOF_TOOLFILE
152    
153 eulisse 1.44 # Makes sure that executables start with /usr/bin/env perl and not with comments.
154     find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|^"""|#/usr/bin/env python\n"""|}' {} \;
155     find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|^\'\'\'|#/usr/bin/env python\n\'\'\'|}' {} \;
156     find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|/usr/local/bin/python|/usr/bin/env python|}' {} \;
157     rm -f %i/share/doc/python/Demo/rpc/test
158    
159 eulisse 1.16 %post
160     find $RPM_INSTALL_PREFIX/%pkgrel/lib -type l | xargs ls -la | sed -e "s|.*[ ]\(/.*\) -> \(.*\)| \2 \1|;s|[ ]/[^ ]*/external| $RPM_INSTALL_PREFIX/%cmsplatf/external|g" | xargs -n2 ln -sf
161 muzaffar 1.28 %{relocateConfig}etc/scram.d/%n