ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.56
Committed: Sat Nov 7 07:56:36 2009 UTC (15 years, 5 months ago) by andreasp
Branch: MAIN
CVS Tags: forPHEDEX331, forPHEDEX331pre2, forPHEDEX331pre1, forPHEDEX330, forPHEDEX3210, dg20091210-phedex, CMSSW_3_3_6_slc5-gcc434, apFor336v0-slc5-gcc434, CMSSW_3_3_5_patch4_slc5-gcc434, apFor335p4v0-slc5-gcc434, apFor335p4-slc5-gcc434, CMSSW_3_3_5_patch3_slc5-gcc434, apFor335p3v0-slc5-gcc434, CMSSW_3_3_5_patch2_slc5-gcc434, apFor335p2v0-slc5-gcc434, CMSSW_3_3_5_patch1_slc5-gcc434, apFor335pat1v2-slc5-gcc434, apFor335pat1v1-slc5-gcc434, apFor335pat1v0-slc5-gcc434, forPHEDEX329_slc501, CMSSW_3_3_5_slc5-gcc434, apFor335v0-sl5igcc4, pe20091126a-for33X-slc5-gcc434, CMSSW_3_3_4_slc5-gcc434, apFor334v0-sl5igcc4, pe20091113c-for33X-slc5-gcc434, pe20091113b-for33X-slc5-gcc434, pe20091113a-for33X-slc5-gcc434, CMSSW_3_3_2_ONLINE-slc5, sm091112c-slc5onl, sm091112b-slc5onl, ap20091107-slc5onl
Changes since 1.55: +40 -47 lines
Log Message:
updated removal of _tkinter.so such that it also works when there is no _tkinter.so (as in slc5onl) - based on rev. 1.52 (python 2.4)

File Contents

# User Rev Content
1 andreasp 1.56 ### RPM external python 2.4.2-CMS19
2 eulisse 1.3 ## INITENV +PATH PATH %i/bin
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 argiro 1.1 # OS X patches and build fudging stolen from fink
5 elmer 1.55 %define closingbrace )
6 andreasp 1.56 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo flase;; esac)
7 ratnik 1.34
8     Requires: expat bz2lib db4 gdbm
9    
10 elmer 1.55 %if "%online" != "true"
11 ratnik 1.34 Requires: zlib openssl
12     %endif
13    
14 eulisse 1.8 # FIXME: readline, crypt
15 argiro 1.1 # FIXME: gmp, panel, tk/tcl, x11
16    
17 elmer 1.24 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
18 elmer 1.13 Patch0: python-Include-pyport.h
19     Patch1: python-Lib-plat-mac-applesingle.py
20     Patch2: python-Lib-site.py
21     Patch3: python-Mac-OSX-Makefile
22     Patch4: python-Makefile.pre.in
23     Patch5: python-configure
24     Patch6: python-setup.py
25 argiro 1.1
26 steen 1.19
27 argiro 1.1 %prep
28 elmer 1.24 %setup -n Python-%realversion
29 elmer 1.13 #%patch0
30     #%patch1
31     #%patch2
32     #%patch3
33     #%patch4
34     #%patch5
35     #%patch6
36 eulisse 1.5 perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" Lib/cgi.py
37    
38 valya 1.48 %ifos darwin
39 argiro 1.1 sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
40     %endif
41    
42     %build
43     # Python is awkward about passing other include or library directories
44     # to it. Basically there is no way to pass anything from configure to
45     # make, or down to python itself. To get python detect the extensions
46     # we want to enable, we simply have to link the contents into python's
47     # own include/lib directories. Ugh.
48     #
49     # NB: It would sort-of make sense to link more stuff from /sw on OS X,
50     # but we simply cannot link the whole world. If you need something,
51     # see above for the commented-out list of packages that could be
52     # linked specifically, or could be built by ourselves, depending on
53     # whether we like to pick up system libraries or want total control.
54 andreasp 1.56 mkdir -p %i/include %i/lib
55 ratnik 1.34
56 elmer 1.55 %if "%online" != "true"
57 ratnik 1.34 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT
58     %else
59     %define extradirs %{nil}
60     %endif
61    
62     dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
63    
64 eulisse 1.16 echo $dirs
65 argiro 1.1 for d in $dirs; do
66     for f in $d/include/*; do
67 eulisse 1.29 [ -e $f ] || continue
68 argiro 1.1 rm -f %i/include/$(basename $f)
69     ln -s $f %i/include
70     done
71     for f in $d/lib/*; do
72 eulisse 1.29 [ -e $f ] || continue
73 argiro 1.1 rm -f %i/lib/$(basename $f)
74     ln -s $f %i/lib
75     done
76     done
77    
78 eulisse 1.39 additionalConfigureOptions=""
79     case %cmsplatf in
80     osx105* )
81     additionalConfigureOptions="--disable-readline"
82     ;;
83     esac
84    
85     ./configure --prefix=%i $additionalConfigureOptions --enable-shared \
86     --without-tkinter --disable-tkinter
87    
88 ratnik 1.38 # The following is a kludge around the fact that the /usr/lib/libreadline.so
89     # symlink (for 32-bit lib) is missing on the 64bit machines
90 andreasp 1.56 %if "%cmsplatf" == "slc4_ia32_gcc345"
91     mkdir -p %{i}/lib
92     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
93     %endif
94     %if "%cmsplatf" == "slc4_ia32_gcc412"
95     mkdir -p %{i}/lib
96     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
97     %endif
98 ratnik 1.38 make %makeprocesses
99 ratnik 1.37
100 argiro 1.1 %install
101     make install
102 elmer 1.24 %define pythonv %(echo %realversion | cut -d. -f 1,2)
103 eulisse 1.8
104 andreasp 1.56 #if [ $(uname) = Darwin ]; then
105     # make install prefix=%i
106     # (cd Misc; /bin/rm -rf RPM)
107     # mkdir -p %i/share/doc/%n
108     # cp -R Demo Doc %i/share/doc/%n
109     # cp -R Misc Tools %i/lib/python%{pythonv}
110     # gcc -dynamiclib -all_load -single_module \
111     # -framework System -framework CoreServices -framework Foundation \
112     # %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
113     # -undefined dynamic_lookup \
114     # -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
115     # -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
116     # -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
117     # ln -s libpython%{pythonv}.dylib %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib # for boost
118     # (cd %i/lib/python%{pythonv}/config; mv Makefile Makefile.orig;
119     # sed 's|-fno-common||g' < Makefile.orig > Makefile; /bin/rm -f Makefile.orig)
120     #fi
121 eulisse 1.9
122     perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
123     %{i}/bin/pydoc \
124     %{i}/bin/smtpd.py \
125 andreasp 1.56 %{i}/lib/python2.4/bsddb/dbshelve.py \
126     %{i}/lib/python2.4/test/test_bz2.py \
127     %{i}/lib/python2.4/test/test_largefile.py \
128     %{i}/lib/python2.4/test/test_optparse.py
129     # boost.spec rfio.spec
130     #
131     #
132 eulisse 1.17 rm `find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*'`
133 eulisse 1.18 rm `find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*'`
134 muzaffar 1.28
135 elmer 1.55 %if "%online" == "true"
136 valya 1.48 # remove tkinter that brings dependency on libtk:
137 andreasp 1.56 find %{i}/lib -type f -name "_tkinter.so" -exec rm {} \;
138 elmer 1.55 %endif
139 valya 1.48
140 muzaffar 1.28 # SCRAM ToolBox toolfile
141     mkdir -p %i/etc/scram.d
142     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
143     <doc type=BuildSystem::ToolDoc version=1.0>
144     <Tool name=%n version=%v>
145 andreasp 1.56 <lib name=python2.4>
146 muzaffar 1.28 <Client>
147     <Environment name=PYTHON_BASE default="%i"></Environment>
148     <Environment name=LIBDIR default="$PYTHON_BASE/lib"></Environment>
149 andreasp 1.56 <Environment name=INCLUDE default="$PYTHON_BASE/include/python2.4"></Environment>
150     <Environment name=PYTHON_COMPILE default="$PYTHON_BASE/lib/python2.4/compileall.py"></Environment>
151 muzaffar 1.28 </Client>
152     <use name=sockets>
153 andreasp 1.56 <Runtime name=PYTHONHOME value="$PYTHON_BASE">
154 muzaffar 1.28 <Runtime name=PATH value="$PYTHON_BASE/bin" type=path>
155     </Tool>
156     EOF_TOOLFILE
157    
158 eulisse 1.16 %post
159     find $RPM_INSTALL_PREFIX/%pkgrel/lib -type l | xargs ls -la | sed -e "s|.*[ ]\(/.*\) -> \(.*\)| \2 \1|;s|[ ]/[^ ]*/external| $RPM_INSTALL_PREFIX/%cmsplatf/external|g" | xargs -n2 ln -sf
160 muzaffar 1.28 %{relocateConfig}etc/scram.d/%n