ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.59
Committed: Mon Dec 7 18:09:04 2009 UTC (15 years, 4 months ago) by elmer
Branch: MAIN
CVS Tags: DQMGUI_5_2_1, DQMGUI_5_2_0, DQMGUI_5_1_8, DAS_20100302_slc5_amd64_gcc434, forPHEDEX-web-20100301, forPHEDEX-web-20100226, DBS_20100226_slc5_amd64_gcc434, forPHEDEX-web-20100225, dg-base-rev4, dg-base-rev3, dg-base-rev2, dg-base-rev1, sw_20100218, DBS_20100217_slc5_amd64_gcc434, FILEMOVER_20100217_slc5_amd64_gcc434, DAS_20100217_slc5_amd64_gcc434, DAS_20100216b_slc5_amd64_gcc434, DAS_20100216_slc5_amd64_gcc434, DQMGUI_5_1_7b, DQMGUI_5_1_7, dg20100201-dbs3, FILEMOVER_20100201_slc5_amd64_gcc434, FILEMOVER_20100128b_slc5_amd64_gcc434, dg20100129-dbs3, dg20100128-dbs3, FILEMOVER_20100128_slc5_amd64_gcc434, DAS_20100127_slc5_amd64_gcc434, DAS_20100126_slc5_amd64_gcc434, FILEMOVER_20100122_slc5_amd64_gcc434, DAS_20100119_slc5_amd64_gcc434, DAS_20100115_slc5_amd64_gcc434, dg20100115-security, DBS_20100115_slc5_amd64_gcc434, dg20100112-security, DBS_20100112_slc5_amd64_gcc434, DBS_20100111_slc5_amd64_gcc434, dg20100111-security, CS_SLC5_test_4, dg20100107b-wmcore, dg20100107-wmcore, DAS_20100105_slc5_amd64_gcc434, CRABSERVER_CS_SLC5_test_3, DAS_20091221_slc5_amd64_gcc434, DAS_20091214_slc5_amd64_gcc434, dg20091211-couchdb, dg20091203c-comp-base, DD_20091208_slc5_amd64_gcc434, DAS_20091208_slc5_amd64_gcc434, FILEMOVER_20091208_slc5_amd64_gcc434, DBS_20091208_slc5_amd64_gcc434
Changes since 1.58: +1 -0 lines
Log Message:
  Relocate "lib/python2.6/config/Makefile" properly in %post. I believe
this is what is preventing py2-pyxml from building.

File Contents

# User Rev Content
1 elmer 1.57 ### RPM external python 2.6.4
2 eulisse 1.3 ## INITENV +PATH PATH %i/bin
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 argiro 1.1 # OS X patches and build fudging stolen from fink
5 elmer 1.55 %define closingbrace )
6 elmer 1.57 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
7 ratnik 1.34
8     Requires: expat bz2lib db4 gdbm
9    
10 elmer 1.55 %if "%online" != "true"
11 elmer 1.57 Requires: zlib openssl sqlite
12 ratnik 1.34 %endif
13    
14 eulisse 1.8 # FIXME: readline, crypt
15 argiro 1.1 # FIXME: gmp, panel, tk/tcl, x11
16    
17 elmer 1.24 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
18 elmer 1.13 Patch0: python-Include-pyport.h
19     Patch1: python-Lib-plat-mac-applesingle.py
20     Patch2: python-Lib-site.py
21     Patch3: python-Mac-OSX-Makefile
22     Patch4: python-Makefile.pre.in
23     Patch5: python-configure
24     Patch6: python-setup.py
25 argiro 1.1
26 steen 1.19
27 argiro 1.1 %prep
28 elmer 1.24 %setup -n Python-%realversion
29 elmer 1.13 #%patch0
30     #%patch1
31     #%patch2
32     #%patch3
33     #%patch4
34     #%patch5
35     #%patch6
36 eulisse 1.5 perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" Lib/cgi.py
37    
38 valya 1.48 %ifos darwin
39 argiro 1.1 sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
40     %endif
41    
42     %build
43     # Python is awkward about passing other include or library directories
44     # to it. Basically there is no way to pass anything from configure to
45     # make, or down to python itself. To get python detect the extensions
46     # we want to enable, we simply have to link the contents into python's
47     # own include/lib directories. Ugh.
48     #
49     # NB: It would sort-of make sense to link more stuff from /sw on OS X,
50     # but we simply cannot link the whole world. If you need something,
51     # see above for the commented-out list of packages that could be
52     # linked specifically, or could be built by ourselves, depending on
53     # whether we like to pick up system libraries or want total control.
54 elmer 1.57 #mkdir -p %i/include %i/lib
55     mkdir -p %i/include %i/lib %i/bin
56 ratnik 1.34
57 elmer 1.55 %if "%online" != "true"
58 elmer 1.57 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT $SQLITE_ROOT
59 ratnik 1.34 %else
60     %define extradirs %{nil}
61     %endif
62    
63     dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
64    
65 eulisse 1.16 echo $dirs
66 argiro 1.1 for d in $dirs; do
67     for f in $d/include/*; do
68 eulisse 1.29 [ -e $f ] || continue
69 argiro 1.1 rm -f %i/include/$(basename $f)
70     ln -s $f %i/include
71     done
72     for f in $d/lib/*; do
73 eulisse 1.29 [ -e $f ] || continue
74 argiro 1.1 rm -f %i/lib/$(basename $f)
75     ln -s $f %i/lib
76     done
77     done
78    
79 eulisse 1.39 additionalConfigureOptions=""
80     case %cmsplatf in
81     osx105* )
82     additionalConfigureOptions="--disable-readline"
83     ;;
84     esac
85    
86     ./configure --prefix=%i $additionalConfigureOptions --enable-shared \
87     --without-tkinter --disable-tkinter
88    
89 ratnik 1.38 # The following is a kludge around the fact that the /usr/lib/libreadline.so
90     # symlink (for 32-bit lib) is missing on the 64bit machines
91 elmer 1.57 case %cmsplatf in
92     slc4_ia32* )
93     mkdir -p %{i}/lib
94     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
95     ;;
96     esac
97 ratnik 1.38 make %makeprocesses
98 ratnik 1.37
99 argiro 1.1 %install
100     make install
101 elmer 1.24 %define pythonv %(echo %realversion | cut -d. -f 1,2)
102 eulisse 1.8
103 elmer 1.57 case %cmsplatf in
104     osx*)
105     make install prefix=%i
106     (cd Misc; /bin/rm -rf RPM)
107     mkdir -p %i/share/doc/%n
108     cp -R Demo Doc %i/share/doc/%n
109     cp -R Misc Tools %i/lib/python%{pythonv}
110     gcc -dynamiclib -all_load -single_module \
111     -framework System -framework CoreServices -framework Foundation \
112     %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
113     -undefined dynamic_lookup \
114     -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
115     -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
116     -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
117     (cd %i/lib/python%{pythonv}/config
118     perl -p -i -e 's|-fno-common||g' Makefile)
119    
120     find %i/lib/python%{pythonv}/config -name 'libpython*' -exec mv {} %i/lib \;
121     ;;
122     esac
123 eulisse 1.9
124     perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
125     %{i}/bin/pydoc \
126 elmer 1.57 %{i}/bin/python-config \
127     %{i}/bin/2to3 \
128     %{i}/bin/python2.6-config \
129 eulisse 1.9 %{i}/bin/smtpd.py \
130 elmer 1.57 %{i}/lib/python2.6/bsddb/dbshelve.py \
131     %{i}/lib/python2.6/test/test_bz2.py \
132     %{i}/lib/python2.6/test/test_largefile.py \
133     %{i}/lib/python2.6/test/test_optparse.py
134 eulisse 1.17 rm `find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*'`
135 eulisse 1.18 rm `find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*'`
136 muzaffar 1.28
137 elmer 1.55 %if "%online" == "true"
138 valya 1.48 # remove tkinter that brings dependency on libtk:
139 elmer 1.58 find %{i}/lib -type f -name "_tkinter.so" -exec rm {} \;
140 elmer 1.55 %endif
141 valya 1.48
142 muzaffar 1.28 # SCRAM ToolBox toolfile
143     mkdir -p %i/etc/scram.d
144     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
145     <doc type=BuildSystem::ToolDoc version=1.0>
146     <Tool name=%n version=%v>
147 elmer 1.57 <lib name=python2.6>
148 muzaffar 1.28 <Client>
149     <Environment name=PYTHON_BASE default="%i"></Environment>
150     <Environment name=LIBDIR default="$PYTHON_BASE/lib"></Environment>
151 elmer 1.57 <Environment name=INCLUDE default="$PYTHON_BASE/include/python2.6"></Environment>
152     <Environment name=PYTHON_COMPILE default="$PYTHON_BASE/lib/python2.6/compileall.py"></Environment>
153 muzaffar 1.28 </Client>
154     <use name=sockets>
155     <Runtime name=PATH value="$PYTHON_BASE/bin" type=path>
156     </Tool>
157     EOF_TOOLFILE
158    
159 elmer 1.57 # Makes sure that executables start with /usr/bin/env perl and not with comments.
160     find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|^"""|#/usr/bin/env python\n"""|}' {} \;
161     find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|^\'\'\'|#/usr/bin/env python\n\'\'\'|}' {} \;
162     find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|/usr/local/bin/python|/usr/bin/env python|}' {} \;
163     rm -f %i/share/doc/python/Demo/rpc/test
164    
165 eulisse 1.16 %post
166     find $RPM_INSTALL_PREFIX/%pkgrel/lib -type l | xargs ls -la | sed -e "s|.*[ ]\(/.*\) -> \(.*\)| \2 \1|;s|[ ]/[^ ]*/external| $RPM_INSTALL_PREFIX/%cmsplatf/external|g" | xargs -n2 ln -sf
167 muzaffar 1.28 %{relocateConfig}etc/scram.d/%n
168 elmer 1.59 %{relocateConfig}lib/python2.6/config/Makefile