1 |
dsr |
1.62 |
### RPM external python 2.6.4
|
2 |
eulisse |
1.3 |
## INITENV +PATH PATH %i/bin
|
3 |
|
|
## INITENV +PATH LD_LIBRARY_PATH %i/lib
|
4 |
argiro |
1.1 |
# OS X patches and build fudging stolen from fink
|
5 |
elmer |
1.55 |
%define closingbrace )
|
6 |
dsr |
1.62 |
%define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
|
7 |
|
|
|
8 |
ratnik |
1.34 |
Requires: expat bz2lib db4 gdbm
|
9 |
|
|
|
10 |
elmer |
1.55 |
%if "%online" != "true"
|
11 |
dsr |
1.62 |
Requires: zlib openssl sqlite
|
12 |
ratnik |
1.34 |
%endif
|
13 |
|
|
|
14 |
eulisse |
1.8 |
# FIXME: readline, crypt
|
15 |
argiro |
1.1 |
# FIXME: gmp, panel, tk/tcl, x11
|
16 |
|
|
|
17 |
dsr |
1.62 |
Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
|
18 |
steen |
1.19 |
|
19 |
argiro |
1.1 |
%prep
|
20 |
dsr |
1.62 |
%setup -n Python-%realversion
|
21 |
eulisse |
1.5 |
perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" Lib/cgi.py
|
22 |
|
|
|
23 |
valya |
1.48 |
%ifos darwin
|
24 |
argiro |
1.1 |
sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
|
25 |
|
|
%endif
|
26 |
|
|
|
27 |
|
|
%build
|
28 |
|
|
# Python is awkward about passing other include or library directories
|
29 |
|
|
# to it. Basically there is no way to pass anything from configure to
|
30 |
|
|
# make, or down to python itself. To get python detect the extensions
|
31 |
|
|
# we want to enable, we simply have to link the contents into python's
|
32 |
|
|
# own include/lib directories. Ugh.
|
33 |
|
|
#
|
34 |
|
|
# NB: It would sort-of make sense to link more stuff from /sw on OS X,
|
35 |
|
|
# but we simply cannot link the whole world. If you need something,
|
36 |
|
|
# see above for the commented-out list of packages that could be
|
37 |
|
|
# linked specifically, or could be built by ourselves, depending on
|
38 |
|
|
# whether we like to pick up system libraries or want total control.
|
39 |
dsr |
1.62 |
#mkdir -p %i/include %i/lib
|
40 |
|
|
mkdir -p %i/include %i/lib %i/bin
|
41 |
ratnik |
1.34 |
|
42 |
elmer |
1.55 |
%if "%online" != "true"
|
43 |
dsr |
1.62 |
%define extradirs $ZLIB_ROOT $OPENSSL_ROOT $SQLITE_ROOT
|
44 |
ratnik |
1.34 |
%else
|
45 |
|
|
%define extradirs %{nil}
|
46 |
|
|
%endif
|
47 |
|
|
|
48 |
|
|
dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
|
49 |
|
|
|
50 |
eulisse |
1.16 |
echo $dirs
|
51 |
argiro |
1.1 |
for d in $dirs; do
|
52 |
|
|
for f in $d/include/*; do
|
53 |
eulisse |
1.29 |
[ -e $f ] || continue
|
54 |
argiro |
1.1 |
rm -f %i/include/$(basename $f)
|
55 |
|
|
ln -s $f %i/include
|
56 |
|
|
done
|
57 |
|
|
for f in $d/lib/*; do
|
58 |
eulisse |
1.29 |
[ -e $f ] || continue
|
59 |
argiro |
1.1 |
rm -f %i/lib/$(basename $f)
|
60 |
|
|
ln -s $f %i/lib
|
61 |
|
|
done
|
62 |
|
|
done
|
63 |
|
|
|
64 |
eulisse |
1.39 |
additionalConfigureOptions=""
|
65 |
|
|
case %cmsplatf in
|
66 |
|
|
osx105* )
|
67 |
|
|
additionalConfigureOptions="--disable-readline"
|
68 |
|
|
;;
|
69 |
|
|
esac
|
70 |
|
|
|
71 |
|
|
./configure --prefix=%i $additionalConfigureOptions --enable-shared \
|
72 |
|
|
--without-tkinter --disable-tkinter
|
73 |
|
|
|
74 |
ratnik |
1.38 |
# The following is a kludge around the fact that the /usr/lib/libreadline.so
|
75 |
|
|
# symlink (for 32-bit lib) is missing on the 64bit machines
|
76 |
dsr |
1.62 |
case %cmsplatf in
|
77 |
|
|
slc4_ia32* )
|
78 |
|
|
mkdir -p %{i}/lib
|
79 |
|
|
ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
|
80 |
|
|
;;
|
81 |
|
|
esac
|
82 |
ratnik |
1.38 |
make %makeprocesses
|
83 |
ratnik |
1.37 |
|
84 |
argiro |
1.1 |
%install
|
85 |
|
|
make install
|
86 |
dsr |
1.62 |
%define pythonv %(echo %realversion | cut -d. -f 1,2)
|
87 |
eulisse |
1.8 |
|
88 |
dsr |
1.62 |
case %cmsplatf in
|
89 |
|
|
osx*)
|
90 |
|
|
make install prefix=%i
|
91 |
|
|
(cd Misc; /bin/rm -rf RPM)
|
92 |
|
|
mkdir -p %i/share/doc/%n
|
93 |
|
|
cp -R Demo Doc %i/share/doc/%n
|
94 |
|
|
cp -R Misc Tools %i/lib/python%{pythonv}
|
95 |
|
|
gcc -dynamiclib -all_load -single_module \
|
96 |
|
|
-framework System -framework CoreServices -framework Foundation \
|
97 |
|
|
%i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
|
98 |
|
|
-undefined dynamic_lookup \
|
99 |
|
|
-o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
|
100 |
|
|
-install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
|
101 |
|
|
-current_version %{pythonv} -compatibility_version %{pythonv} -ldl
|
102 |
|
|
(cd %i/lib/python%{pythonv}/config
|
103 |
|
|
perl -p -i -e 's|-fno-common||g' Makefile)
|
104 |
|
|
|
105 |
|
|
find %i/lib/python%{pythonv}/config -name 'libpython*' -exec mv -f {} %i/lib \;
|
106 |
|
|
;;
|
107 |
|
|
esac
|
108 |
eulisse |
1.9 |
|
109 |
|
|
perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
|
110 |
|
|
%{i}/bin/pydoc \
|
111 |
dsr |
1.62 |
%{i}/bin/python-config \
|
112 |
|
|
%{i}/bin/2to3 \
|
113 |
|
|
%{i}/bin/python2.6-config \
|
114 |
eulisse |
1.9 |
%{i}/bin/smtpd.py \
|
115 |
dsr |
1.62 |
%{i}/lib/python2.6/bsddb/dbshelve.py \
|
116 |
|
|
%{i}/lib/python2.6/test/test_bz2.py \
|
117 |
|
|
%{i}/lib/python2.6/test/test_largefile.py \
|
118 |
|
|
%{i}/lib/python2.6/test/test_optparse.py
|
119 |
eulisse |
1.67 |
|
120 |
|
|
find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
|
121 |
|
|
find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
|
122 |
muzaffar |
1.28 |
|
123 |
valya |
1.48 |
# remove tkinter that brings dependency on libtk:
|
124 |
elmer |
1.58 |
find %{i}/lib -type f -name "_tkinter.so" -exec rm {} \;
|
125 |
valya |
1.48 |
|
126 |
dsr |
1.62 |
# Makes sure that executables start with /usr/bin/env perl and not with comments.
|
127 |
|
|
find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|^"""|#/usr/bin/env python\n"""|}' {} \;
|
128 |
|
|
find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|^\'\'\'|#/usr/bin/env python\n\'\'\'|}' {} \;
|
129 |
|
|
find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|/usr/local/bin/python|/usr/bin/env python|}' {} \;
|
130 |
|
|
rm -f %i/share/doc/python/Demo/rpc/test
|
131 |
|
|
|
132 |
diego |
1.63 |
# Setups dependencies environment
|
133 |
|
|
rm -rf %i/etc/profile.d
|
134 |
|
|
mkdir -p %i/etc/profile.d
|
135 |
|
|
for x in %pkgreqs; do
|
136 |
|
|
case $x in /* ) continue ;; esac
|
137 |
|
|
p=%{instroot}/%{cmsplatf}/$(echo $x | sed 's/\([^+]*\)+\(.*\)+\([A-Z0-9].*\)/\1 \2 \3/' | tr ' ' '/')
|
138 |
|
|
echo ". $p/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
|
139 |
|
|
echo "source $p/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
|
140 |
|
|
done
|
141 |
|
|
|
142 |
eulisse |
1.16 |
%post
|
143 |
dsr |
1.62 |
%{relocateConfig}lib/python2.6/config/Makefile
|
144 |
diego |
1.63 |
%{relocateConfig}etc/profile.d/dependencies-setup.sh
|
145 |
|
|
%{relocateConfig}etc/profile.d/dependencies-setup.csh
|
146 |
|
|
|