ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.69
Committed: Thu Sep 16 09:22:00 2010 UTC (14 years, 7 months ago) by eulisse
Branch: MAIN
CVS Tags: pe20100924b-for39Xrb, pe20100924a-for39Xrb, pe20100923c-for39Xrb, pe20100923b-for39Xrb, pe20100923a-for39Xrb, pe20100922b-for39Xrb, pe20100922a-for39Xrb
Changes since 1.68: +7 -3 lines
Log Message:
Actually link vs our version of libdb4, not the system one.

File Contents

# User Rev Content
1 dsr 1.62 ### RPM external python 2.6.4
2 eulisse 1.3 ## INITENV +PATH PATH %i/bin
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 argiro 1.1 # OS X patches and build fudging stolen from fink
5 elmer 1.55 %define closingbrace )
6 dsr 1.62 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
7    
8 ratnik 1.34 Requires: expat bz2lib db4 gdbm
9    
10 elmer 1.55 %if "%online" != "true"
11 dsr 1.62 Requires: zlib openssl sqlite
12 ratnik 1.34 %endif
13    
14 eulisse 1.8 # FIXME: readline, crypt
15 argiro 1.1 # FIXME: gmp, panel, tk/tcl, x11
16    
17 dsr 1.62 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
18 eulisse 1.69 Patch0: python-2.6.4-dont-detect-dbm
19 steen 1.19
20 argiro 1.1 %prep
21 dsr 1.62 %setup -n Python-%realversion
22 eulisse 1.5 perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" Lib/cgi.py
23    
24 eulisse 1.69 case %cmsplatf in
25     osx*)
26     sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
27     ;;
28     esac
29     %patch0 -p1
30 argiro 1.1
31     %build
32     # Python is awkward about passing other include or library directories
33     # to it. Basically there is no way to pass anything from configure to
34     # make, or down to python itself. To get python detect the extensions
35     # we want to enable, we simply have to link the contents into python's
36     # own include/lib directories. Ugh.
37     #
38     # NB: It would sort-of make sense to link more stuff from /sw on OS X,
39     # but we simply cannot link the whole world. If you need something,
40     # see above for the commented-out list of packages that could be
41     # linked specifically, or could be built by ourselves, depending on
42     # whether we like to pick up system libraries or want total control.
43 dsr 1.62 #mkdir -p %i/include %i/lib
44     mkdir -p %i/include %i/lib %i/bin
45 ratnik 1.34
46 elmer 1.55 %if "%online" != "true"
47 dsr 1.62 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT $SQLITE_ROOT
48 ratnik 1.34 %else
49     %define extradirs %{nil}
50     %endif
51    
52     dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
53    
54 eulisse 1.16 echo $dirs
55 argiro 1.1 for d in $dirs; do
56     for f in $d/include/*; do
57 eulisse 1.29 [ -e $f ] || continue
58 argiro 1.1 rm -f %i/include/$(basename $f)
59     ln -s $f %i/include
60     done
61     for f in $d/lib/*; do
62 eulisse 1.29 [ -e $f ] || continue
63 argiro 1.1 rm -f %i/lib/$(basename $f)
64     ln -s $f %i/lib
65     done
66     done
67    
68 eulisse 1.39 additionalConfigureOptions=""
69     case %cmsplatf in
70     osx105* )
71     additionalConfigureOptions="--disable-readline"
72     ;;
73     esac
74    
75     ./configure --prefix=%i $additionalConfigureOptions --enable-shared \
76     --without-tkinter --disable-tkinter
77    
78 ratnik 1.38 # The following is a kludge around the fact that the /usr/lib/libreadline.so
79     # symlink (for 32-bit lib) is missing on the 64bit machines
80 dsr 1.62 case %cmsplatf in
81     slc4_ia32* )
82     mkdir -p %{i}/lib
83     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
84     ;;
85     esac
86 ratnik 1.38 make %makeprocesses
87 ratnik 1.37
88 argiro 1.1 %install
89     make install
90 dsr 1.62 %define pythonv %(echo %realversion | cut -d. -f 1,2)
91 eulisse 1.8
92 dsr 1.62 case %cmsplatf in
93     osx*)
94     make install prefix=%i
95     (cd Misc; /bin/rm -rf RPM)
96     mkdir -p %i/share/doc/%n
97     cp -R Demo Doc %i/share/doc/%n
98     cp -R Misc Tools %i/lib/python%{pythonv}
99     gcc -dynamiclib -all_load -single_module \
100     -framework System -framework CoreServices -framework Foundation \
101     %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
102     -undefined dynamic_lookup \
103     -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
104     -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
105     -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
106     (cd %i/lib/python%{pythonv}/config
107     perl -p -i -e 's|-fno-common||g' Makefile)
108    
109     find %i/lib/python%{pythonv}/config -name 'libpython*' -exec mv -f {} %i/lib \;
110     ;;
111     esac
112 eulisse 1.9
113     perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
114     %{i}/bin/pydoc \
115 dsr 1.62 %{i}/bin/python-config \
116     %{i}/bin/2to3 \
117     %{i}/bin/python2.6-config \
118 eulisse 1.9 %{i}/bin/smtpd.py \
119 dsr 1.62 %{i}/lib/python2.6/bsddb/dbshelve.py \
120     %{i}/lib/python2.6/test/test_bz2.py \
121     %{i}/lib/python2.6/test/test_largefile.py \
122     %{i}/lib/python2.6/test/test_optparse.py
123 eulisse 1.67
124     find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
125     find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
126 muzaffar 1.28
127 valya 1.48 # remove tkinter that brings dependency on libtk:
128 elmer 1.58 find %{i}/lib -type f -name "_tkinter.so" -exec rm {} \;
129 valya 1.48
130 dsr 1.62 # Makes sure that executables start with /usr/bin/env perl and not with comments.
131     find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|^"""|#/usr/bin/env python\n"""|}' {} \;
132     find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|^\'\'\'|#/usr/bin/env python\n\'\'\'|}' {} \;
133     find %i -type f -perm -555 -name '*.py' -exec perl -p -i -e 'if ($. == 1) {s|/usr/local/bin/python|/usr/bin/env python|}' {} \;
134     rm -f %i/share/doc/python/Demo/rpc/test
135    
136 lat 1.68 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
137 diego 1.63 mkdir -p %i/etc/profile.d
138 lat 1.68 : > %i/etc/profile.d/dependencies-setup.sh
139     : > %i/etc/profile.d/dependencies-setup.csh
140     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
141     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
142     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
143     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
144     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
145     fi
146 diego 1.63 done
147    
148 eulisse 1.16 %post
149 dsr 1.62 %{relocateConfig}lib/python2.6/config/Makefile
150 lat 1.68 %{relocateConfig}etc/profile.d/dependencies-setup.*sh