ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.73
Committed: Fri Jun 24 08:10:20 2011 UTC (13 years, 10 months ago) by lat
Branch: MAIN
CVS Tags: builder_2011-08-09_17-03-37_dbs-server, builder_2011-08-09_14-45-47_dbs-client, builder_2011-08-08_23-23-23_dbs-server, DBS_2_1_6-pre5, DBS_2_1_6-pre4, DBS_2_1_6-pre3, builder_2011-07-28_21-25-51_dbs-server, builder_2011-07-28_21-25-43_dbs-client, DBS_2_1_6-pre2, TW20110727a, TW20110726a, builder_2011-07-20_14-45-50_wmagent, builder_2011-07-18_15-32-58_wmagent, builder_2011-07-14_18-33-29_asyncstageout, builder_2011-07-13_17-03-17_stagemanager-agent, builder_2011-07-13_16-55-50_stagemanager-agent, builder_2011-07-13_16-52-30_wmagent, builder_2011-07-13_09-48-46_crab-server3, builder_2011-07-11_12-04-16_cmsweb, builder_2011-07-11_11-53-31_cmsweb, HG1107c, builder_2011-07-08_16-07-44_cmsweb, TW20110707b, TW20110707a, builder_2011-07-05_11-26-58_cmsweb, HG1107b, builder_2011-07-04_15-53-33_cmsweb, TW20110704b, builder_2011-07-04_12-54-16_stagemanager, TW20110704a, builder_2011-07-02_17-25-15_dbs3-client, TW20110701a, builder_2011-07-01_14-15-56_cmsweb, builder_2011-07-01_12-35-36_cmsweb, builder_2011-06-30_17-06-37_crab-server3, builder_2011-06-29_20-56-28_cmsweb, TW20110629a, TW20110628a, TW20110627b, builder_2011-06-24_21-18-43_cmsweb, builder_2011-06-24_15-28-33_workqueue, HG1107a, lat20110624a
Changes since 1.72: +3 -2 lines
Log Message:
Use $PYTHON_LIB_SITE_PACKAGES for python package directory.
Replace %closingbrace with balanced parentheses in "case".

File Contents

# User Rev Content
1 dsr 1.62 ### RPM external python 2.6.4
2 eulisse 1.3 ## INITENV +PATH PATH %i/bin
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 lat 1.73 ## INITENV SETV PYTHON_LIB_SITE_PACKAGES lib/python%{python_major_version}/site-packages
5 argiro 1.1 # OS X patches and build fudging stolen from fink
6 lat 1.73 %{expand:%%define python_major_version %(echo %realversion | cut -d. -f1,2)}
7     %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
8 dsr 1.62
9 ratnik 1.34 Requires: expat bz2lib db4 gdbm
10    
11 elmer 1.55 %if "%online" != "true"
12 dsr 1.62 Requires: zlib openssl sqlite
13 ratnik 1.34 %endif
14    
15 eulisse 1.8 # FIXME: readline, crypt
16 argiro 1.1 # FIXME: gmp, panel, tk/tcl, x11
17    
18 dsr 1.62 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
19 eulisse 1.69 Patch0: python-2.6.4-dont-detect-dbm
20 steen 1.19
21 argiro 1.1 %prep
22 dsr 1.62 %setup -n Python-%realversion
23 eulisse 1.5 perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" Lib/cgi.py
24    
25 eulisse 1.69 case %cmsplatf in
26     osx*)
27 eulisse 1.71 sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
28 eulisse 1.69 ;;
29     esac
30     %patch0 -p1
31 argiro 1.1
32     %build
33     # Python is awkward about passing other include or library directories
34     # to it. Basically there is no way to pass anything from configure to
35     # make, or down to python itself. To get python detect the extensions
36     # we want to enable, we simply have to link the contents into python's
37     # own include/lib directories. Ugh.
38     #
39     # NB: It would sort-of make sense to link more stuff from /sw on OS X,
40     # but we simply cannot link the whole world. If you need something,
41     # see above for the commented-out list of packages that could be
42     # linked specifically, or could be built by ourselves, depending on
43     # whether we like to pick up system libraries or want total control.
44 dsr 1.62 #mkdir -p %i/include %i/lib
45     mkdir -p %i/include %i/lib %i/bin
46 ratnik 1.34
47 elmer 1.55 %if "%online" != "true"
48 dsr 1.62 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT $SQLITE_ROOT
49 ratnik 1.34 %else
50     %define extradirs %{nil}
51     %endif
52    
53     dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
54    
55 eulisse 1.70 # We need to export it because setup.py now uses it to determine the actual
56     # location of DB4, this was needed to avoid having it picked up from the system.
57     export DB4_ROOT
58    
59 eulisse 1.16 echo $dirs
60 argiro 1.1 for d in $dirs; do
61     for f in $d/include/*; do
62 eulisse 1.29 [ -e $f ] || continue
63 argiro 1.1 rm -f %i/include/$(basename $f)
64     ln -s $f %i/include
65     done
66     for f in $d/lib/*; do
67 eulisse 1.29 [ -e $f ] || continue
68 argiro 1.1 rm -f %i/lib/$(basename $f)
69     ln -s $f %i/lib
70     done
71     done
72    
73 eulisse 1.39 additionalConfigureOptions=""
74     case %cmsplatf in
75     osx105* )
76     additionalConfigureOptions="--disable-readline"
77     ;;
78     esac
79    
80     ./configure --prefix=%i $additionalConfigureOptions --enable-shared \
81     --without-tkinter --disable-tkinter
82    
83 ratnik 1.38 # The following is a kludge around the fact that the /usr/lib/libreadline.so
84     # symlink (for 32-bit lib) is missing on the 64bit machines
85 dsr 1.62 case %cmsplatf in
86     slc4_ia32* )
87     mkdir -p %{i}/lib
88     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
89     ;;
90     esac
91 ratnik 1.38 make %makeprocesses
92 ratnik 1.37
93 argiro 1.1 %install
94 eulisse 1.71 # We need to export it because setup.py now uses it to determine the actual
95     # location of DB4, this was needed to avoid having it picked up from the system.
96     export DB4_ROOT
97 argiro 1.1 make install
98 dsr 1.62 %define pythonv %(echo %realversion | cut -d. -f 1,2)
99 eulisse 1.8
100 dsr 1.62 case %cmsplatf in
101     osx*)
102     make install prefix=%i
103     (cd Misc; /bin/rm -rf RPM)
104     mkdir -p %i/share/doc/%n
105     cp -R Demo Doc %i/share/doc/%n
106     cp -R Misc Tools %i/lib/python%{pythonv}
107     gcc -dynamiclib -all_load -single_module \
108     -framework System -framework CoreServices -framework Foundation \
109     %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
110     -undefined dynamic_lookup \
111     -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
112     -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
113     -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
114     (cd %i/lib/python%{pythonv}/config
115     perl -p -i -e 's|-fno-common||g' Makefile)
116    
117     find %i/lib/python%{pythonv}/config -name 'libpython*' -exec mv -f {} %i/lib \;
118     ;;
119     esac
120 eulisse 1.9
121     perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
122     %{i}/bin/pydoc \
123 dsr 1.62 %{i}/bin/python-config \
124     %{i}/bin/2to3 \
125     %{i}/bin/python2.6-config \
126 eulisse 1.9 %{i}/bin/smtpd.py \
127 dsr 1.62 %{i}/lib/python2.6/bsddb/dbshelve.py \
128     %{i}/lib/python2.6/test/test_bz2.py \
129     %{i}/lib/python2.6/test/test_largefile.py \
130     %{i}/lib/python2.6/test/test_optparse.py
131 eulisse 1.67
132     find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
133     find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
134 muzaffar 1.28
135 valya 1.48 # remove tkinter that brings dependency on libtk:
136 elmer 1.58 find %{i}/lib -type f -name "_tkinter.so" -exec rm {} \;
137 valya 1.48
138 dsr 1.62 # Makes sure that executables start with /usr/bin/env perl and not with comments.
139     rm -f %i/share/doc/python/Demo/rpc/test
140    
141 lat 1.68 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
142 diego 1.63 mkdir -p %i/etc/profile.d
143 lat 1.68 : > %i/etc/profile.d/dependencies-setup.sh
144     : > %i/etc/profile.d/dependencies-setup.csh
145     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
146     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
147     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
148     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
149     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
150     fi
151 diego 1.63 done
152    
153 eulisse 1.16 %post
154 dsr 1.62 %{relocateConfig}lib/python2.6/config/Makefile
155 lat 1.68 %{relocateConfig}etc/profile.d/dependencies-setup.*sh