ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.79
Committed: Wed Jan 25 15:59:16 2012 UTC (13 years, 3 months ago) by fwyzard
Branch: MAIN
CVS Tags: fw20120126gcc461cmssw500onl, fw20120125gcc461cmssw500onl
Changes since 1.78: +2 -2 lines
Log Message:
configure for installation under %installroot insetad of %instroot, and override during the installation itself

File Contents

# User Rev Content
1 dsr 1.62 ### RPM external python 2.6.4
2 eulisse 1.3 ## INITENV +PATH PATH %i/bin
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 lat 1.73 ## INITENV SETV PYTHON_LIB_SITE_PACKAGES lib/python%{python_major_version}/site-packages
5 argiro 1.1 # OS X patches and build fudging stolen from fink
6 lat 1.73 %{expand:%%define python_major_version %(echo %realversion | cut -d. -f1,2)}
7     %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
8 dsr 1.62
9 ratnik 1.34 Requires: expat bz2lib db4 gdbm
10    
11 elmer 1.55 %if "%online" != "true"
12 dsr 1.62 Requires: zlib openssl sqlite
13 ratnik 1.34 %endif
14    
15 eulisse 1.8 # FIXME: readline, crypt
16 argiro 1.1 # FIXME: gmp, panel, tk/tcl, x11
17    
18 dsr 1.62 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
19 eulisse 1.69 Patch0: python-2.6.4-dont-detect-dbm
20 eulisse 1.78 Patch1: python-2.6.4-fix-macosx-relocation
21 steen 1.19
22 argiro 1.1 %prep
23 dsr 1.62 %setup -n Python-%realversion
24 lat 1.74 find . -type f | while read f; do
25     if head -n1 $f | grep -q /usr/local; then
26     perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" $f
27     else :; fi
28     done
29 eulisse 1.5
30 eulisse 1.69 case %cmsplatf in
31     osx*)
32 eulisse 1.71 sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
33 eulisse 1.69 ;;
34     esac
35     %patch0 -p1
36 eulisse 1.78 %patch1 -p1
37 argiro 1.1
38     %build
39     # Python is awkward about passing other include or library directories
40     # to it. Basically there is no way to pass anything from configure to
41     # make, or down to python itself. To get python detect the extensions
42     # we want to enable, we simply have to link the contents into python's
43     # own include/lib directories. Ugh.
44     #
45     # NB: It would sort-of make sense to link more stuff from /sw on OS X,
46     # but we simply cannot link the whole world. If you need something,
47     # see above for the commented-out list of packages that could be
48     # linked specifically, or could be built by ourselves, depending on
49     # whether we like to pick up system libraries or want total control.
50 dsr 1.62 #mkdir -p %i/include %i/lib
51     mkdir -p %i/include %i/lib %i/bin
52 ratnik 1.34
53 elmer 1.55 %if "%online" != "true"
54 dsr 1.62 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT $SQLITE_ROOT
55 ratnik 1.34 %else
56     %define extradirs %{nil}
57     %endif
58    
59     dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
60    
61 eulisse 1.70 # We need to export it because setup.py now uses it to determine the actual
62     # location of DB4, this was needed to avoid having it picked up from the system.
63     export DB4_ROOT
64    
65 eulisse 1.16 echo $dirs
66 argiro 1.1 for d in $dirs; do
67     for f in $d/include/*; do
68 eulisse 1.29 [ -e $f ] || continue
69 argiro 1.1 rm -f %i/include/$(basename $f)
70     ln -s $f %i/include
71     done
72     for f in $d/lib/*; do
73 eulisse 1.29 [ -e $f ] || continue
74 argiro 1.1 rm -f %i/lib/$(basename $f)
75     ln -s $f %i/lib
76     done
77     done
78    
79 eulisse 1.39 additionalConfigureOptions=""
80     case %cmsplatf in
81     osx105* )
82     additionalConfigureOptions="--disable-readline"
83     ;;
84     esac
85    
86 fwyzard 1.79 ./configure --prefix=%{installroot}/%{pkgrel} $additionalConfigureOptions --enable-shared \
87 eulisse 1.39 --without-tkinter --disable-tkinter
88    
89 ratnik 1.38 # The following is a kludge around the fact that the /usr/lib/libreadline.so
90     # symlink (for 32-bit lib) is missing on the 64bit machines
91 dsr 1.62 case %cmsplatf in
92     slc4_ia32* )
93     mkdir -p %{i}/lib
94     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
95     ;;
96     esac
97 ratnik 1.38 make %makeprocesses
98 ratnik 1.37
99 argiro 1.1 %install
100 eulisse 1.71 # We need to export it because setup.py now uses it to determine the actual
101     # location of DB4, this was needed to avoid having it picked up from the system.
102     export DB4_ROOT
103 fwyzard 1.79 make install prefix=%i
104 dsr 1.62 %define pythonv %(echo %realversion | cut -d. -f 1,2)
105 eulisse 1.8
106 dsr 1.62 case %cmsplatf in
107     osx*)
108     make install prefix=%i
109     (cd Misc; /bin/rm -rf RPM)
110     mkdir -p %i/share/doc/%n
111     cp -R Demo Doc %i/share/doc/%n
112     cp -R Misc Tools %i/lib/python%{pythonv}
113     gcc -dynamiclib -all_load -single_module \
114     -framework System -framework CoreServices -framework Foundation \
115     %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
116     -undefined dynamic_lookup \
117     -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
118     -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
119     -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
120     (cd %i/lib/python%{pythonv}/config
121     perl -p -i -e 's|-fno-common||g' Makefile)
122    
123     find %i/lib/python%{pythonv}/config -name 'libpython*' -exec mv -f {} %i/lib \;
124     ;;
125     esac
126 eulisse 1.9
127     perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
128     %{i}/bin/pydoc \
129 dsr 1.62 %{i}/bin/python-config \
130     %{i}/bin/2to3 \
131     %{i}/bin/python2.6-config \
132 eulisse 1.9 %{i}/bin/smtpd.py \
133 dsr 1.62 %{i}/lib/python2.6/bsddb/dbshelve.py \
134     %{i}/lib/python2.6/test/test_bz2.py \
135     %{i}/lib/python2.6/test/test_largefile.py \
136     %{i}/lib/python2.6/test/test_optparse.py
137 eulisse 1.67
138     find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
139     find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
140 muzaffar 1.28
141 lat 1.74 # remove executable permission anything which is *.py script,
142     # is executable, but does not start with she-bang so not valid
143     # executable; this avoids problems with rpm 4.8+ find-requires
144     find %i -name '*.py' -perm +0111 | while read f; do
145     if head -n1 $f | grep -q '"'; then chmod -x $f; else :; fi
146     done
147    
148 valya 1.48 # remove tkinter that brings dependency on libtk:
149 elmer 1.58 find %{i}/lib -type f -name "_tkinter.so" -exec rm {} \;
150 valya 1.48
151 eulisse 1.77 # Remove documentation, examples and test files.
152     %define drop_files %i/share %{i}/lib/python%{pythonv}/test
153 diego 1.75
154     # Remove .pyo files
155     find %i -name '*.pyo' -exec rm {} \;
156    
157 lat 1.68 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
158 diego 1.63 mkdir -p %i/etc/profile.d
159 lat 1.68 : > %i/etc/profile.d/dependencies-setup.sh
160     : > %i/etc/profile.d/dependencies-setup.csh
161     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
162     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
163     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
164     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
165     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
166     fi
167 diego 1.63 done
168    
169 eulisse 1.16 %post
170 dsr 1.62 %{relocateConfig}lib/python2.6/config/Makefile
171 lat 1.68 %{relocateConfig}etc/profile.d/dependencies-setup.*sh