ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.83
Committed: Wed Mar 7 08:45:15 2012 UTC (13 years, 1 month ago) by davidlt
Branch: MAIN
Changes since 1.82: +7 -39 lines
Log Message:
Recover HEAD (rev1.81)

File Contents

# User Rev Content
1 dsr 1.62 ### RPM external python 2.6.4
2 eulisse 1.3 ## INITENV +PATH PATH %i/bin
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 lat 1.73 ## INITENV SETV PYTHON_LIB_SITE_PACKAGES lib/python%{python_major_version}/site-packages
5 argiro 1.1 # OS X patches and build fudging stolen from fink
6 lat 1.73 %{expand:%%define python_major_version %(echo %realversion | cut -d. -f1,2)}
7     %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
8 dsr 1.62
9 ratnik 1.34 Requires: expat bz2lib db4 gdbm
10    
11 elmer 1.55 %if "%online" != "true"
12 dsr 1.62 Requires: zlib openssl sqlite
13 ratnik 1.34 %endif
14    
15 eulisse 1.8 # FIXME: readline, crypt
16 argiro 1.1 # FIXME: gmp, panel, tk/tcl, x11
17    
18 dsr 1.62 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
19 eulisse 1.69 Patch0: python-2.6.4-dont-detect-dbm
20 eulisse 1.78 Patch1: python-2.6.4-fix-macosx-relocation
21 steen 1.19
22 argiro 1.1 %prep
23 dsr 1.62 %setup -n Python-%realversion
24 lat 1.74 find . -type f | while read f; do
25     if head -n1 $f | grep -q /usr/local; then
26     perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" $f
27     else :; fi
28     done
29 eulisse 1.5
30 eulisse 1.69 case %cmsplatf in
31     osx*)
32 eulisse 1.71 sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
33 eulisse 1.69 ;;
34     esac
35     %patch0 -p1
36 eulisse 1.78 %patch1 -p1
37 argiro 1.1
38     %build
39     # Python is awkward about passing other include or library directories
40     # to it. Basically there is no way to pass anything from configure to
41     # make, or down to python itself. To get python detect the extensions
42     # we want to enable, we simply have to link the contents into python's
43     # own include/lib directories. Ugh.
44     #
45     # NB: It would sort-of make sense to link more stuff from /sw on OS X,
46     # but we simply cannot link the whole world. If you need something,
47     # see above for the commented-out list of packages that could be
48     # linked specifically, or could be built by ourselves, depending on
49     # whether we like to pick up system libraries or want total control.
50 dsr 1.62 #mkdir -p %i/include %i/lib
51     mkdir -p %i/include %i/lib %i/bin
52 ratnik 1.34
53 elmer 1.55 %if "%online" != "true"
54 dsr 1.62 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT $SQLITE_ROOT
55 ratnik 1.34 %else
56     %define extradirs %{nil}
57     %endif
58    
59     dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
60    
61 eulisse 1.70 # We need to export it because setup.py now uses it to determine the actual
62     # location of DB4, this was needed to avoid having it picked up from the system.
63     export DB4_ROOT
64    
65 davidlt 1.83 # Python's configure parses LDFLAGS and CPPFLAGS to look for aditional library and include directories
66 eulisse 1.16 echo $dirs
67 davidlt 1.83 LDFLAGS=""
68     CPPFLAGS=""
69 argiro 1.1 for d in $dirs; do
70 davidlt 1.83 LDFLAGS="$LDFLAGS -L $d/lib"
71     CPPFLAGS="$CPPFLAGS -I $d/include"
72 argiro 1.1 done
73 davidlt 1.83 export LDFLAGS
74     export CPPFLAGS
75 argiro 1.1
76 eulisse 1.39 additionalConfigureOptions=""
77     case %cmsplatf in
78     osx105* )
79     additionalConfigureOptions="--disable-readline"
80     ;;
81     esac
82    
83 fwyzard 1.81 ./configure --prefix=%i $additionalConfigureOptions --enable-shared \
84 eulisse 1.39 --without-tkinter --disable-tkinter
85    
86 ratnik 1.38 # The following is a kludge around the fact that the /usr/lib/libreadline.so
87     # symlink (for 32-bit lib) is missing on the 64bit machines
88 dsr 1.62 case %cmsplatf in
89     slc4_ia32* )
90     mkdir -p %{i}/lib
91     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
92     ;;
93     esac
94 ratnik 1.38 make %makeprocesses
95 ratnik 1.37
96 argiro 1.1 %install
97 eulisse 1.71 # We need to export it because setup.py now uses it to determine the actual
98     # location of DB4, this was needed to avoid having it picked up from the system.
99     export DB4_ROOT
100 fwyzard 1.81 make install
101 dsr 1.62 %define pythonv %(echo %realversion | cut -d. -f 1,2)
102 eulisse 1.8
103 dsr 1.62 case %cmsplatf in
104     osx*)
105     make install prefix=%i
106     (cd Misc; /bin/rm -rf RPM)
107     mkdir -p %i/share/doc/%n
108     cp -R Demo Doc %i/share/doc/%n
109     cp -R Misc Tools %i/lib/python%{pythonv}
110     gcc -dynamiclib -all_load -single_module \
111     -framework System -framework CoreServices -framework Foundation \
112     %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
113     -undefined dynamic_lookup \
114     -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
115     -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
116     -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
117     (cd %i/lib/python%{pythonv}/config
118     perl -p -i -e 's|-fno-common||g' Makefile)
119    
120     find %i/lib/python%{pythonv}/config -name 'libpython*' -exec mv -f {} %i/lib \;
121     ;;
122     esac
123 eulisse 1.9
124     perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
125     %{i}/bin/pydoc \
126 dsr 1.62 %{i}/bin/python-config \
127     %{i}/bin/2to3 \
128     %{i}/bin/python2.6-config \
129 eulisse 1.9 %{i}/bin/smtpd.py \
130 dsr 1.62 %{i}/lib/python2.6/bsddb/dbshelve.py \
131     %{i}/lib/python2.6/test/test_bz2.py \
132     %{i}/lib/python2.6/test/test_largefile.py \
133     %{i}/lib/python2.6/test/test_optparse.py
134 eulisse 1.67
135     find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
136     find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
137 muzaffar 1.28
138 lat 1.74 # remove executable permission anything which is *.py script,
139     # is executable, but does not start with she-bang so not valid
140     # executable; this avoids problems with rpm 4.8+ find-requires
141     find %i -name '*.py' -perm +0111 | while read f; do
142     if head -n1 $f | grep -q '"'; then chmod -x $f; else :; fi
143     done
144    
145 valya 1.48 # remove tkinter that brings dependency on libtk:
146 elmer 1.58 find %{i}/lib -type f -name "_tkinter.so" -exec rm {} \;
147 valya 1.48
148 eulisse 1.77 # Remove documentation, examples and test files.
149     %define drop_files %i/share %{i}/lib/python%{pythonv}/test
150 diego 1.75
151     # Remove .pyo files
152     find %i -name '*.pyo' -exec rm {} \;
153    
154 lat 1.68 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
155 diego 1.63 mkdir -p %i/etc/profile.d
156 lat 1.68 : > %i/etc/profile.d/dependencies-setup.sh
157     : > %i/etc/profile.d/dependencies-setup.csh
158     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
159     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
160     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
161     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
162     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
163     fi
164 diego 1.63 done
165    
166 eulisse 1.16 %post
167 dsr 1.62 %{relocateConfig}lib/python2.6/config/Makefile
168 lat 1.68 %{relocateConfig}etc/profile.d/dependencies-setup.*sh