ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.74
Committed: Sat Jul 9 11:24:13 2011 UTC (13 years, 9 months ago) by lat
Branch: MAIN
CVS Tags: builder_2011-09-13_22-04-02_filemover, builder_2011-09-06_16-09-09_stagemanager-agent, builder_2011-09-06_15-53-16_stagemanager-agent, builder_2011-08-27_00-05-05_asyncstageout, builder_2011-08-26_19-05-27_crab-server3, builder_2011-08-16_12-09-37_cmsweb, HG1108b, builder_2011-08-12_22-56-45_cmsweb, TW20110808a, builder_2011-08-04_18-42-50_stagemanager-agent, builder_2011-08-04_17-25-36_das, builder_2011-08-04_13-25-47_cmsweb, builder_2011-08-02_16-19-02_wmagent, TW20110729a, TW20110728d, TW20110728c, TW20110728b, TW20110728a, builder_2011-07-28_00-46-23_cmsweb, DBS_2_1_6-pre1, builder_2011-07-27_18-04-14_reqmgr, HG1108a, HG1108a-osx
Changes since 1.73: +12 -1 lines
Log Message:
Fixes to make OS X / RPM 4.8.x find-requires happier: remove executable
bit on executable *.py scripts which don't have she-bang so aren't truly
executable, and eliminate /usr/local she-bang paths in more places.

File Contents

# Content
1 ### RPM external python 2.6.4
2 ## INITENV +PATH PATH %i/bin
3 ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 ## INITENV SETV PYTHON_LIB_SITE_PACKAGES lib/python%{python_major_version}/site-packages
5 # OS X patches and build fudging stolen from fink
6 %{expand:%%define python_major_version %(echo %realversion | cut -d. -f1,2)}
7 %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
8
9 Requires: expat bz2lib db4 gdbm
10
11 %if "%online" != "true"
12 Requires: zlib openssl sqlite
13 %endif
14
15 # FIXME: readline, crypt
16 # FIXME: gmp, panel, tk/tcl, x11
17
18 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
19 Patch0: python-2.6.4-dont-detect-dbm
20
21 %prep
22 %setup -n Python-%realversion
23 find . -type f | while read f; do
24 if head -n1 $f | grep -q /usr/local; then
25 perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" $f
26 else :; fi
27 done
28
29 case %cmsplatf in
30 osx*)
31 sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
32 ;;
33 esac
34 %patch0 -p1
35
36 %build
37 # Python is awkward about passing other include or library directories
38 # to it. Basically there is no way to pass anything from configure to
39 # make, or down to python itself. To get python detect the extensions
40 # we want to enable, we simply have to link the contents into python's
41 # own include/lib directories. Ugh.
42 #
43 # NB: It would sort-of make sense to link more stuff from /sw on OS X,
44 # but we simply cannot link the whole world. If you need something,
45 # see above for the commented-out list of packages that could be
46 # linked specifically, or could be built by ourselves, depending on
47 # whether we like to pick up system libraries or want total control.
48 #mkdir -p %i/include %i/lib
49 mkdir -p %i/include %i/lib %i/bin
50
51 %if "%online" != "true"
52 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT $SQLITE_ROOT
53 %else
54 %define extradirs %{nil}
55 %endif
56
57 dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
58
59 # We need to export it because setup.py now uses it to determine the actual
60 # location of DB4, this was needed to avoid having it picked up from the system.
61 export DB4_ROOT
62
63 echo $dirs
64 for d in $dirs; do
65 for f in $d/include/*; do
66 [ -e $f ] || continue
67 rm -f %i/include/$(basename $f)
68 ln -s $f %i/include
69 done
70 for f in $d/lib/*; do
71 [ -e $f ] || continue
72 rm -f %i/lib/$(basename $f)
73 ln -s $f %i/lib
74 done
75 done
76
77 additionalConfigureOptions=""
78 case %cmsplatf in
79 osx105* )
80 additionalConfigureOptions="--disable-readline"
81 ;;
82 esac
83
84 ./configure --prefix=%i $additionalConfigureOptions --enable-shared \
85 --without-tkinter --disable-tkinter
86
87 # The following is a kludge around the fact that the /usr/lib/libreadline.so
88 # symlink (for 32-bit lib) is missing on the 64bit machines
89 case %cmsplatf in
90 slc4_ia32* )
91 mkdir -p %{i}/lib
92 ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
93 ;;
94 esac
95 make %makeprocesses
96
97 %install
98 # We need to export it because setup.py now uses it to determine the actual
99 # location of DB4, this was needed to avoid having it picked up from the system.
100 export DB4_ROOT
101 make install
102 %define pythonv %(echo %realversion | cut -d. -f 1,2)
103
104 case %cmsplatf in
105 osx*)
106 make install prefix=%i
107 (cd Misc; /bin/rm -rf RPM)
108 mkdir -p %i/share/doc/%n
109 cp -R Demo Doc %i/share/doc/%n
110 cp -R Misc Tools %i/lib/python%{pythonv}
111 gcc -dynamiclib -all_load -single_module \
112 -framework System -framework CoreServices -framework Foundation \
113 %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
114 -undefined dynamic_lookup \
115 -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
116 -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
117 -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
118 (cd %i/lib/python%{pythonv}/config
119 perl -p -i -e 's|-fno-common||g' Makefile)
120
121 find %i/lib/python%{pythonv}/config -name 'libpython*' -exec mv -f {} %i/lib \;
122 ;;
123 esac
124
125 perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
126 %{i}/bin/pydoc \
127 %{i}/bin/python-config \
128 %{i}/bin/2to3 \
129 %{i}/bin/python2.6-config \
130 %{i}/bin/smtpd.py \
131 %{i}/lib/python2.6/bsddb/dbshelve.py \
132 %{i}/lib/python2.6/test/test_bz2.py \
133 %{i}/lib/python2.6/test/test_largefile.py \
134 %{i}/lib/python2.6/test/test_optparse.py
135
136 find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
137 find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
138
139 # remove executable permission anything which is *.py script,
140 # is executable, but does not start with she-bang so not valid
141 # executable; this avoids problems with rpm 4.8+ find-requires
142 find %i -name '*.py' -perm +0111 | while read f; do
143 if head -n1 $f | grep -q '"'; then chmod -x $f; else :; fi
144 done
145
146 # remove tkinter that brings dependency on libtk:
147 find %{i}/lib -type f -name "_tkinter.so" -exec rm {} \;
148
149 # Makes sure that executables start with /usr/bin/env perl and not with comments.
150 rm -f %i/share/doc/python/Demo/rpc/test
151
152 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
153 mkdir -p %i/etc/profile.d
154 : > %i/etc/profile.d/dependencies-setup.sh
155 : > %i/etc/profile.d/dependencies-setup.csh
156 for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
157 root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
158 if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
159 echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
160 echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
161 fi
162 done
163
164 %post
165 %{relocateConfig}lib/python2.6/config/Makefile
166 %{relocateConfig}etc/profile.d/dependencies-setup.*sh