ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/python.spec
Revision: 1.77
Committed: Wed Sep 21 13:21:29 2011 UTC (13 years, 7 months ago) by eulisse
Branch: MAIN
CVS Tags: bld_1364477047_CmsTC_slc5_amd64_gcc434, bld_1363597235_CmsTC_slc5_amd64_gcc434, bld_1361358843_CmsTC_slc5_amd64_gcc434, bld_1360935597_CmsTC_slc5_amd64_gcc434, bld_1358942699_CmsTC_slc5_amd64_gcc434, bld_1358853292_CmsTC_slc5_amd64_gcc434, bld_1321637643_reqmon_slc5_amd64_gcc461, HG1111e, bld_1321455789_happyface_slc5_amd64_gcc461, bld_1321454935_happyface_slc5_amd64_gcc461, TW20111103a, TW20111101e, TW20111101d, TW20111101c, TW20111101b, TW20111101a, az20111031c-50X-gcc461-ports, TW20111028a, az20111027c-50X-gcc461-ports, CMSSW_5_0_0_pre4-gcc461-ports, az20111027b-50X-gcc461-ports, az20111027-50X-gcc461-ports, sjgFor500pre4-gcc461-ports, az20111026-50X-gcc461-ports, az20111025-50X-gcc461-ports, bld_1319551575_PHEDEX-combined-agents_slc5_amd64_gcc461, sm20111025-50X-gcc461-ports, az20111024-50X-gcc461-ports, sjg111021c-50X-gcc461-ports, sjg111021b-50X-gcc461-ports, sjg111021-50X-gcc461-ports, az20111020-50X-gcc461-ports, CMSSW_5_0_0_pre3-gcc461-ports, HG1111d, sjgFor500pre3-gcc461-ports, TW20111017d, TW20111017c, TW20111017b, TW20111017a, sjgFor500pre2d-gcc461-ports, sjgFor500pre2c-gcc461-ports, sjgFor500pre2b-gcc461-ports, TW20111016a, TW20111015a, bld_1318622241_wmagent_slc5_amd64_gcc434, az20111014b-50X-gcc461-ports, TW20111014a, az20111014-50X-gcc461-ports, bld_1318524794_asyncstageout_slc5_amd64_gcc434, bld_1318523430_cmsweb_slc5_amd64_gcc434, HG1111c-gcc434, HG1111c, sjgFor500pre2-gcc461-ports, bld_1318424717_crab-server3_slc5_amd64_gcc434, bld_1318423430_asyncstageout_slc5_amd64_gcc434, LT20111012a, bld_1318410594_crab-server3_slc5_amd64_gcc434, az20111011c-50X-gcc461-ports, az20111011b-50X-gcc461-ports, az20111011a-50X-gcc461-ports, az20111010-50X-gcc461-ports, HG1111b, az20111007-50X-gcc461-ports, az20111005-50X-gcc461-ports, HG1111a-gcc434, HG1111a, az20111004a-50X-gcc461-ports, az20111004-50X-gcc461-ports, az20111003-50X-gcc461-ports, az20110930a-50X-gcc461-ports, az20110930-50X-gcc461-ports, ge20110930-gcc461-ports, az20110929a-50X-gcc461-ports, az20110929-50X-gcc461-ports, ge20110929-gcc461-ports, LT20110929b, LT20110928b, az20110928a-50X-gcc461-ports, az20110928-50X-gcc461-ports, az20110928-50X-461-ports, az20110926a-50X-gcc461-ports, az20110926-gcc461-ports, ge20110926-gcc461-ports, ge20110923-gcc461-ports, ge20110922b-gcc461-ports, ge20110922-gcc461-ports, ge20110921-gcc461-ports
Changes since 1.76: +2 -5 lines
Log Message:
Remove the old, by hand, cleanups and use the new macro based system.

File Contents

# User Rev Content
1 dsr 1.62 ### RPM external python 2.6.4
2 eulisse 1.3 ## INITENV +PATH PATH %i/bin
3     ## INITENV +PATH LD_LIBRARY_PATH %i/lib
4 lat 1.73 ## INITENV SETV PYTHON_LIB_SITE_PACKAGES lib/python%{python_major_version}/site-packages
5 argiro 1.1 # OS X patches and build fudging stolen from fink
6 lat 1.73 %{expand:%%define python_major_version %(echo %realversion | cut -d. -f1,2)}
7     %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
8 dsr 1.62
9 ratnik 1.34 Requires: expat bz2lib db4 gdbm
10    
11 elmer 1.55 %if "%online" != "true"
12 dsr 1.62 Requires: zlib openssl sqlite
13 ratnik 1.34 %endif
14    
15 eulisse 1.8 # FIXME: readline, crypt
16 argiro 1.1 # FIXME: gmp, panel, tk/tcl, x11
17    
18 dsr 1.62 Source0: http://www.python.org/ftp/%n/%realversion/Python-%realversion.tgz
19 eulisse 1.69 Patch0: python-2.6.4-dont-detect-dbm
20 steen 1.19
21 argiro 1.1 %prep
22 dsr 1.62 %setup -n Python-%realversion
23 lat 1.74 find . -type f | while read f; do
24     if head -n1 $f | grep -q /usr/local; then
25     perl -p -i -e "s|#!.*/usr/local/bin/python|#!/usr/bin/env python|" $f
26     else :; fi
27     done
28 eulisse 1.5
29 eulisse 1.69 case %cmsplatf in
30     osx*)
31 eulisse 1.71 sed 's|@PREFIX@|%i|g' < %_sourcedir/python-osx | patch -p1
32 eulisse 1.69 ;;
33     esac
34     %patch0 -p1
35 argiro 1.1
36     %build
37     # Python is awkward about passing other include or library directories
38     # to it. Basically there is no way to pass anything from configure to
39     # make, or down to python itself. To get python detect the extensions
40     # we want to enable, we simply have to link the contents into python's
41     # own include/lib directories. Ugh.
42     #
43     # NB: It would sort-of make sense to link more stuff from /sw on OS X,
44     # but we simply cannot link the whole world. If you need something,
45     # see above for the commented-out list of packages that could be
46     # linked specifically, or could be built by ourselves, depending on
47     # whether we like to pick up system libraries or want total control.
48 dsr 1.62 #mkdir -p %i/include %i/lib
49     mkdir -p %i/include %i/lib %i/bin
50 ratnik 1.34
51 elmer 1.55 %if "%online" != "true"
52 dsr 1.62 %define extradirs $ZLIB_ROOT $OPENSSL_ROOT $SQLITE_ROOT
53 ratnik 1.34 %else
54     %define extradirs %{nil}
55     %endif
56    
57     dirs="$EXPAT_ROOT $BZ2LIB_ROOT $NCURSES_ROOT $DB4_ROOT $GDBM_ROOT %{extradirs}"
58    
59 eulisse 1.70 # We need to export it because setup.py now uses it to determine the actual
60     # location of DB4, this was needed to avoid having it picked up from the system.
61     export DB4_ROOT
62    
63 eulisse 1.16 echo $dirs
64 argiro 1.1 for d in $dirs; do
65     for f in $d/include/*; do
66 eulisse 1.29 [ -e $f ] || continue
67 argiro 1.1 rm -f %i/include/$(basename $f)
68     ln -s $f %i/include
69     done
70     for f in $d/lib/*; do
71 eulisse 1.29 [ -e $f ] || continue
72 argiro 1.1 rm -f %i/lib/$(basename $f)
73     ln -s $f %i/lib
74     done
75     done
76    
77 eulisse 1.39 additionalConfigureOptions=""
78     case %cmsplatf in
79     osx105* )
80     additionalConfigureOptions="--disable-readline"
81     ;;
82     esac
83    
84     ./configure --prefix=%i $additionalConfigureOptions --enable-shared \
85     --without-tkinter --disable-tkinter
86    
87 ratnik 1.38 # The following is a kludge around the fact that the /usr/lib/libreadline.so
88     # symlink (for 32-bit lib) is missing on the 64bit machines
89 dsr 1.62 case %cmsplatf in
90     slc4_ia32* )
91     mkdir -p %{i}/lib
92     ln -s /usr/lib/libreadline.so.4.3 %{i}/lib/libreadline.so
93     ;;
94     esac
95 ratnik 1.38 make %makeprocesses
96 ratnik 1.37
97 argiro 1.1 %install
98 eulisse 1.71 # We need to export it because setup.py now uses it to determine the actual
99     # location of DB4, this was needed to avoid having it picked up from the system.
100     export DB4_ROOT
101 argiro 1.1 make install
102 dsr 1.62 %define pythonv %(echo %realversion | cut -d. -f 1,2)
103 eulisse 1.8
104 dsr 1.62 case %cmsplatf in
105     osx*)
106     make install prefix=%i
107     (cd Misc; /bin/rm -rf RPM)
108     mkdir -p %i/share/doc/%n
109     cp -R Demo Doc %i/share/doc/%n
110     cp -R Misc Tools %i/lib/python%{pythonv}
111     gcc -dynamiclib -all_load -single_module \
112     -framework System -framework CoreServices -framework Foundation \
113     %i/lib/python%{pythonv}/config/libpython%{pythonv}.a \
114     -undefined dynamic_lookup \
115     -o %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
116     -install_name %i/lib/python%{pythonv}/config/libpython%{pythonv}.dylib \
117     -current_version %{pythonv} -compatibility_version %{pythonv} -ldl
118     (cd %i/lib/python%{pythonv}/config
119     perl -p -i -e 's|-fno-common||g' Makefile)
120    
121     find %i/lib/python%{pythonv}/config -name 'libpython*' -exec mv -f {} %i/lib \;
122     ;;
123     esac
124 eulisse 1.9
125     perl -p -i -e "s|^#!.*python|#!/usr/bin/env python|" %{i}/bin/idle \
126     %{i}/bin/pydoc \
127 dsr 1.62 %{i}/bin/python-config \
128     %{i}/bin/2to3 \
129     %{i}/bin/python2.6-config \
130 eulisse 1.9 %{i}/bin/smtpd.py \
131 dsr 1.62 %{i}/lib/python2.6/bsddb/dbshelve.py \
132     %{i}/lib/python2.6/test/test_bz2.py \
133     %{i}/lib/python2.6/test/test_largefile.py \
134     %{i}/lib/python2.6/test/test_optparse.py
135 eulisse 1.67
136     find %{i}/lib -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
137     find %{i}/include -maxdepth 1 -mindepth 1 ! -name '*python*' -exec rm {} \;
138 muzaffar 1.28
139 lat 1.74 # remove executable permission anything which is *.py script,
140     # is executable, but does not start with she-bang so not valid
141     # executable; this avoids problems with rpm 4.8+ find-requires
142     find %i -name '*.py' -perm +0111 | while read f; do
143     if head -n1 $f | grep -q '"'; then chmod -x $f; else :; fi
144     done
145    
146 valya 1.48 # remove tkinter that brings dependency on libtk:
147 elmer 1.58 find %{i}/lib -type f -name "_tkinter.so" -exec rm {} \;
148 valya 1.48
149 eulisse 1.77 # Remove documentation, examples and test files.
150     %define drop_files %i/share %{i}/lib/python%{pythonv}/test
151 diego 1.75
152     # Remove .pyo files
153     find %i -name '*.pyo' -exec rm {} \;
154    
155 lat 1.68 # Generate dependencies-setup.{sh,csh} so init.{sh,csh} picks full environment.
156 diego 1.63 mkdir -p %i/etc/profile.d
157 lat 1.68 : > %i/etc/profile.d/dependencies-setup.sh
158     : > %i/etc/profile.d/dependencies-setup.csh
159     for tool in $(echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'); do
160     root=$(echo $tool | tr a-z- A-Z_)_ROOT; eval r=\$$root
161     if [ X"$r" != X ] && [ -r "$r/etc/profile.d/init.sh" ]; then
162     echo "test X\$$root != X || . $r/etc/profile.d/init.sh" >> %i/etc/profile.d/dependencies-setup.sh
163     echo "test X\$$root != X || source $r/etc/profile.d/init.csh" >> %i/etc/profile.d/dependencies-setup.csh
164     fi
165 diego 1.63 done
166    
167 eulisse 1.16 %post
168 dsr 1.62 %{relocateConfig}lib/python2.6/config/Makefile
169 lat 1.68 %{relocateConfig}etc/profile.d/dependencies-setup.*sh