ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/qt.spec
Revision: 1.1
Committed: Fri Feb 24 08:01:52 2006 UTC (19 years, 2 months ago) by eulisse
Branch: MAIN
Log Message:
First imported into repository.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM external qt 3.3.4
2     ## INITENV UNSET QMAKESPEC
3     ## INITENV SET QTDIR %i
4     %define qttype %(echo %v | sed 's/[-0-9.]*//')
5     %define qtversion %(echo %v | sed 's/-.*//')
6     %if "%qttype" == ""
7     %ifos darwin
8     %define type mac
9     %else
10     %define type x11
11     %endif
12     %else
13     %define type %{qttype}
14     %endif
15    
16     %if "%type" == "x11"
17     %define sourcepkg 1
18     %else
19     %define sourcepkg 0
20     %endif
21    
22     # Requires: zlib, ...
23     Source0: ftp://ftp.trolltech.com/qt/source/%n-mac-free-%{qtversion}.tar.bz2
24     Source1: ftp://ftp.trolltech.com/qt/source/%n-x11-free-%{qtversion}.tar.bz2
25    
26     %prep
27     %setup -T -b %sourcepkg -n %n-%type-free-%{qtversion}
28    
29     %build
30     unset QMAKESPEC || true
31     export QTDIR=$PWD
32     export PATH=$QTDIR/bin:$PATH
33     export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
34     export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH
35     echo yes | ./configure -prefix %i -thread -stl
36     # install_framework is hosed
37     perl -p -i -e 's/^install_framework:/install_framework:\ninstall_framework_no:/' src/Makefile
38     make