ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/qt.spec
Revision: 1.14
Committed: Tue May 1 10:57:27 2007 UTC (18 years ago) by elmer
Branch: MAIN
CVS Tags: pe20070522a-ports, pe20070519a-ports, pe20070512a-ports, pe20070508a-ports, pe20070507a-ports, pe20070501c-ports, pe20070501b-ports, pe20070501a-ports
Changes since 1.13: +0 -2 lines
Log Message:
Remove gcc-wrappers. scramv1-build.file still needs more work, will do in
a bit.

File Contents

# User Rev Content
1 eulisse 1.10 ### RPM external qt 3.3.6
2 eulisse 1.1 ## INITENV UNSET QMAKESPEC
3     ## INITENV SET QTDIR %i
4     %define qttype %(echo %v | sed 's/[-0-9.]*//')
5     %define qtversion %(echo %v | sed 's/-.*//')
6     %if "%qttype" == ""
7     %ifos darwin
8     %define type mac
9     %else
10     %define type x11
11     %endif
12     %else
13     %define type %{qttype}
14     %endif
15    
16     %if "%type" == "x11"
17     %define sourcepkg 1
18     %else
19     %define sourcepkg 0
20     %endif
21    
22     # Requires: zlib, ...
23     Source0: ftp://ftp.trolltech.com/qt/source/%n-mac-free-%{qtversion}.tar.bz2
24     Source1: ftp://ftp.trolltech.com/qt/source/%n-x11-free-%{qtversion}.tar.bz2
25 elmer 1.7 Patch0: qt-mkspecs-qmake.conf
26     Patch1: qt-mkspecs-qplatformdefs.h
27     Patch2: qt-src-kernel-qaccessible_mac.cpp
28     Patch3: qt-src-qt_install.pri
29 eulisse 1.1
30     %prep
31     %setup -T -b %sourcepkg -n %n-%type-free-%{qtversion}
32 elmer 1.12 #%ifos darwin
33     #%patch1 -p0
34     #%patch2 -p0
35     #%patch3 -p0
36     #%endif
37 eulisse 1.1
38     %build
39     unset QMAKESPEC || true
40     export QTDIR=$PWD
41     export PATH=$QTDIR/bin:$PATH
42     export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
43     export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH
44 eulisse 1.3
45     case $(uname -m) in
46     x86_64)
47     export CONFIG_ARGS="-platform linux-g++-64"
48     esac
49    
50     echo yes | ./configure -prefix %i -thread -stl $CONFIG_ARGS
51 eulisse 1.1 # install_framework is hosed
52     perl -p -i -e 's/^install_framework:/install_framework:\ninstall_framework_no:/' src/Makefile
53 eulisse 1.2 make %makeprocesses
54 eulisse 1.11 %post
55     %{relocateConfig}lib/libqt-mt.la
56