ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/qt.spec
Revision: 1.15
Committed: Wed May 23 16:27:25 2007 UTC (17 years, 11 months ago) by elmer
Branch: MAIN
CVS Tags: ge20070629, pe20070626c-ports, ge20070625, pe20070626b-ports, sm20070626a-ports, pe20070626a-ports, pe20070625b-ports, pe20070625a-ports, pe20070624a-ports, ge20070622, pe20070607a-ports
Changes since 1.14: +16 -3 lines
Log Message:
o Updates to use %realversion from rpm-preamble
o Versions all updated to -XXXX (we can choose the actual rebuild naming
  convention in a second pass)
o Ugly kludge to link properly libfontconfig when building 32-bit on
  64-bit machines, due to missing /usr/lib/libfontconfig.so soft link
  in OS installation

File Contents

# User Rev Content
1 elmer 1.15 ### RPM external qt 3.3.6-XXXX
2 eulisse 1.1 ## INITENV UNSET QMAKESPEC
3     ## INITENV SET QTDIR %i
4 elmer 1.15 %define qttype %(echo %realversion | sed 's/[-0-9.]*//')
5     %define qtversion %(echo %realversion | sed 's/-.*//')
6 eulisse 1.1 %if "%qttype" == ""
7     %ifos darwin
8     %define type mac
9     %else
10     %define type x11
11     %endif
12     %else
13     %define type %{qttype}
14     %endif
15    
16     %if "%type" == "x11"
17     %define sourcepkg 1
18     %else
19     %define sourcepkg 0
20     %endif
21    
22     # Requires: zlib, ...
23     Source0: ftp://ftp.trolltech.com/qt/source/%n-mac-free-%{qtversion}.tar.bz2
24     Source1: ftp://ftp.trolltech.com/qt/source/%n-x11-free-%{qtversion}.tar.bz2
25 elmer 1.7 Patch0: qt-mkspecs-qmake.conf
26     Patch1: qt-mkspecs-qplatformdefs.h
27     Patch2: qt-src-kernel-qaccessible_mac.cpp
28     Patch3: qt-src-qt_install.pri
29 elmer 1.15 Patch4: qt-mkspecs-qmake.conf_2
30 eulisse 1.1
31     %prep
32     %setup -T -b %sourcepkg -n %n-%type-free-%{qtversion}
33 elmer 1.12 #%ifos darwin
34     #%patch1 -p0
35     #%patch2 -p0
36     #%patch3 -p0
37     #%endif
38 elmer 1.15 # The kludge supports the libfontconfig kludge described below
39     %if "%cmsplatf" == "slc4_ia32_gcc345"
40     %patch4 -p1
41     %endif
42 eulisse 1.1
43     %build
44     unset QMAKESPEC || true
45     export QTDIR=$PWD
46     export PATH=$QTDIR/bin:$PATH
47     export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
48     export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH
49 eulisse 1.3
50     case $(uname -m) in
51     x86_64)
52     export CONFIG_ARGS="-platform linux-g++-64"
53     esac
54    
55     echo yes | ./configure -prefix %i -thread -stl $CONFIG_ARGS
56 eulisse 1.1 # install_framework is hosed
57     perl -p -i -e 's/^install_framework:/install_framework:\ninstall_framework_no:/' src/Makefile
58 elmer 1.15 # The following is a kludge around the fact that the fact that the
59     # /usr/lib/libfontconfig.so soft link (for 32-bit lib) is missing
60     # on the 64-bit machines
61     %if "%cmsplatf" == "slc4_ia32_gcc345"
62     mkdir -p %{_builddir}/lib
63     ln -s /usr/lib/libfontconfig.so.1 %{_builddir}/%n-%type-free-%{qtversion}/lib/libfontconfig.so
64     %endif
65    
66 eulisse 1.2 make %makeprocesses
67 eulisse 1.11 %post
68     %{relocateConfig}lib/libqt-mt.la
69