ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/qt.spec
Revision: 1.17
Committed: Mon Sep 3 15:28:45 2007 UTC (17 years, 8 months ago) by muzaffar
Branch: MAIN
CVS Tags: CMSSW_1_7_7, nr080314_181onl1, CMSSW_1_8_0_ONLINE1, nr080310_180onl1, nr080307onl180onl1, dl080227for176, CMSSW_1_7_5_ONLINE1, CMSSW_1_7_5, CMSSW_1_7_5_g491, CMSSW_1_7_5_ONLINE, nr080115onl175, dl080111, ge20080109-webconddb, ge20080109-sitedb, CMSSW_1_7_4, CMSSW_1_7_3_g490p1, dl071212t2, dl071212, CMSSW_1_7_3, CMSSW_1_7_2, CMSSW_1_7_1, nr071121onl170_xdaq5, nr071120_fwlite170_1, CMSSW_1_7_0_ONLINE, CMSSW_1_7_0, nr071116onlpre13, CMSSW_1_7_0_pre13, dl071114, ap20071113, CMSSW_1_7_0_pre12, CMSSW_1_7_0_pre10_ONLINE, CMSSW_1_7_0_pre11, nr071105a, pe20071102b-ports, pe20071102a-ports, CMSSW_1_7_0_pre10, CMSSW_1_7_0_pre9, CMSSW_1_7_0_pre8, CMSSW_1_7_0_pre7, dl071028, dl071024, nr071023_fwlite170p6, pe20071021-170p6-zlib, dl071021t2, dl071021, dl071020, nr071017_170p5onl2, CMSSW_1_7_0_pre6, nr071016_170p5onl1, nr071016onl170p5bs, nr071016onl170p5, pe20071015-xrootd, pe20071014-ports, dl071014, dl071010t2, dl071010, dl071009t2, dl071009, CMSSW_1_7_0_pre5, dl070926t2, dl070926, ap-20070926, CMSSW_1_7_0_pre4, dl070921t2, dl070921, dl070920, CMSSW_1_7_0_pre3, dl070916, dl070912, dl070812, sm070912b, sm070912a, sm070911a, dl070909p3, dl070909, CMSSW_1_7_0_pre2, dl070906, dl070905, sm030907a
Changes since 1.16: +26 -1 lines
Log Message:
new spec files for auto generation of toolfile i.e. no need of scramtoolbox

File Contents

# User Rev Content
1 muzaffar 1.17 ### RPM external qt 3.3.6-CMS8
2 eulisse 1.1 ## INITENV UNSET QMAKESPEC
3     ## INITENV SET QTDIR %i
4 elmer 1.15 %define qttype %(echo %realversion | sed 's/[-0-9.]*//')
5     %define qtversion %(echo %realversion | sed 's/-.*//')
6 eulisse 1.1 %if "%qttype" == ""
7     %ifos darwin
8     %define type mac
9     %else
10     %define type x11
11     %endif
12     %else
13     %define type %{qttype}
14     %endif
15    
16     %if "%type" == "x11"
17     %define sourcepkg 1
18     %else
19     %define sourcepkg 0
20     %endif
21    
22     # Requires: zlib, ...
23     Source0: ftp://ftp.trolltech.com/qt/source/%n-mac-free-%{qtversion}.tar.bz2
24     Source1: ftp://ftp.trolltech.com/qt/source/%n-x11-free-%{qtversion}.tar.bz2
25 elmer 1.7 Patch0: qt-mkspecs-qmake.conf
26     Patch1: qt-mkspecs-qplatformdefs.h
27     Patch2: qt-src-kernel-qaccessible_mac.cpp
28     Patch3: qt-src-qt_install.pri
29 elmer 1.15 Patch4: qt-mkspecs-qmake.conf_2
30 eulisse 1.1
31     %prep
32     %setup -T -b %sourcepkg -n %n-%type-free-%{qtversion}
33 elmer 1.12 #%ifos darwin
34     #%patch1 -p0
35     #%patch2 -p0
36     #%patch3 -p0
37     #%endif
38 elmer 1.15 # The kludge supports the libfontconfig kludge described below
39     %if "%cmsplatf" == "slc4_ia32_gcc345"
40     %patch4 -p1
41     %endif
42 eulisse 1.1
43     %build
44     unset QMAKESPEC || true
45     export QTDIR=$PWD
46     export PATH=$QTDIR/bin:$PATH
47     export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
48     export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH
49 eulisse 1.3
50     case $(uname -m) in
51     x86_64)
52     export CONFIG_ARGS="-platform linux-g++-64"
53     esac
54    
55     echo yes | ./configure -prefix %i -thread -stl $CONFIG_ARGS
56 eulisse 1.1 # install_framework is hosed
57     perl -p -i -e 's/^install_framework:/install_framework:\ninstall_framework_no:/' src/Makefile
58 elmer 1.15 # The following is a kludge around the fact that the fact that the
59     # /usr/lib/libfontconfig.so soft link (for 32-bit lib) is missing
60     # on the 64-bit machines
61     %if "%cmsplatf" == "slc4_ia32_gcc345"
62     mkdir -p %{_builddir}/lib
63     ln -s /usr/lib/libfontconfig.so.1 %{_builddir}/%n-%type-free-%{qtversion}/lib/libfontconfig.so
64     %endif
65    
66 eulisse 1.2 make %makeprocesses
67 muzaffar 1.17
68     %install
69     make install
70    
71     # SCRAM ToolBox toolfile
72     mkdir -p %i/etc/scram.d
73     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
74     <doc type=BuildSystem::ToolDoc version=1.0>
75     <Tool name=%n version=%v>
76     <info url="http://www.trolltech.com/products/qt.html"></info>
77     <LIB name=qt-mt>
78     <Client>
79     <Environment name=QT_BASE default="%i"></Environment>
80     <Environment name=LIBDIR default="$QT_BASE/lib"></Environment>
81     <Environment name=INCLUDE default="$QT_BASE/include"></Environment>
82     </Client>
83     <Flags CPPDEFINES="QT_ALTERNATE_QTSMANIP QT_CLEAN_NAMESPACE QT_THREAD_SUPPORT">
84     <Runtime name=PATH value="$QT_BASE/bin" type=path>
85     <use name=X11>
86     <use name=opengl>
87     <use name=zlib>
88     </Tool>
89     EOF_TOOLFILE
90    
91 eulisse 1.11 %post
92     %{relocateConfig}lib/libqt-mt.la
93 muzaffar 1.17 %{relocateConfig}etc/scram.d/%n
94 eulisse 1.11