ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/qt.spec
Revision: 1.20
Committed: Mon Nov 5 23:16:16 2007 UTC (17 years, 5 months ago) by elmer
Branch: MAIN
CVS Tags: CMSSW_1_8_4, pe20080405-for184, CMSSW_1_8_3, pe20080326-for183, pe20080325-for183, CMSSW_1_8_2, pe20080324-for182, nr080320a, CMSSW_1_8_1, pe20080314-for181, CMSSW_1_8_0, pe20080304a-for180, pe20080303a-for18X, CMSSW_1_8_0_pre10, pe20080226-for180p10, pe20080220a-for18X, CMSSW_1_8_0_pre9, nr080215g491p01dbg, CMSSW_2_0_0_pre1, CMSSW_1_8_0_pre8, dl080202, pe20080126-for180p8, CMSSW_1_8_0_pre7, pe20080122a-for180p7, dl080120, pe20080120a-for180p7, pe20080117b-for180p7, pe20080117-for180p7, dl080115, CMSSW_1_8_0_pre6, NR080108_geant491-dbg-global, sm20080101a-newscram, pe20071226c-for180p6, pe20071226b-for180p6, pe20071226a-for180p6, ge20071223, ge20071221, pe20071220b-for180p6, ge20071220, pe20071220-for180p6, ge20071217, CMSSW_1_8_0_pre5, pe20071216-for180p5, ge20071216, CMSSW_1_8_0_pre4-vg330, ge20071213, ge20071212-perfreport, ge20071212, ge20071211, ge20071210a, ge20071210, pe20071207-for180p4g491c3, NR071206_geant491cand3-global, ge20071207, pe20071206-for180test1, CMSSW_1_8_0_pre4-412, CMSSW_1_8_0_pre4, pe20071205b-for180p4-412, pe20071205b-for180p4, pe20071205-for180p4, ge20071205, CMSSW_1_8_0_pre3a-412, ge20071203, pe20071202-for180p3a-gcc412, CMSSW_1_8_0_pre3a, pe20071201b-for180p3a, pe20071201-for180p3a, V00-06-08, ge20071128, pe20071130-for180p3, pe20071129-for180p3, ge20071127a-leopard, ge20071127-leopard, pe20071127a-ports-412, ge20071126-new-bootstrap, CMSSW_1_8_0_pre2, CMSSW_1_8_0_pre0-amd64, CMSSW_1_8_0_pre0, pe20071123e-ports-412, pe20071123d-ports-412, pe20071123c-ports-422, pe20071123c-ports-412, pe20071123c-ports, pe20071123b-ports-422, pe20071123b-ports-412, pe20071123b-ports, pe20071123a-ports-422, pe20071123a-ports-412, pe20071123a-ports, ge20071122-new-bootstrap, pe20071121a-ports-422, pe20071121a-ports-412, pe20071121a-ports, pe20071112c-ports-422, pe20071112c-ports-412, pe20071112c-ports, pe20071112b-ports-412, pe20071112b-ports, pe20071112a-ports
Changes since 1.19: +2 -9 lines
Log Message:
Apply (32bit-on-64bit) libfontconfig kludge also for slc4_ia32_gcc422

File Contents

# User Rev Content
1 elmer 1.19 ### RPM external qt 3.3.6-CMS18
2 eulisse 1.1 ## INITENV UNSET QMAKESPEC
3     ## INITENV SET QTDIR %i
4 elmer 1.15 %define qttype %(echo %realversion | sed 's/[-0-9.]*//')
5     %define qtversion %(echo %realversion | sed 's/-.*//')
6 eulisse 1.1 %if "%qttype" == ""
7     %ifos darwin
8     %define type mac
9     %else
10     %define type x11
11     %endif
12     %else
13     %define type %{qttype}
14     %endif
15    
16     %if "%type" == "x11"
17     %define sourcepkg 1
18     %else
19     %define sourcepkg 0
20     %endif
21    
22     # Requires: zlib, ...
23     Source0: ftp://ftp.trolltech.com/qt/source/%n-mac-free-%{qtversion}.tar.bz2
24     Source1: ftp://ftp.trolltech.com/qt/source/%n-x11-free-%{qtversion}.tar.bz2
25 elmer 1.7 Patch0: qt-mkspecs-qmake.conf
26     Patch1: qt-mkspecs-qplatformdefs.h
27     Patch2: qt-src-kernel-qaccessible_mac.cpp
28     Patch3: qt-src-qt_install.pri
29 elmer 1.15 Patch4: qt-mkspecs-qmake.conf_2
30 eulisse 1.1
31     %prep
32     %setup -T -b %sourcepkg -n %n-%type-free-%{qtversion}
33 elmer 1.12 #%ifos darwin
34     #%patch1 -p0
35     #%patch2 -p0
36     #%patch3 -p0
37     #%endif
38 elmer 1.15 # The kludge supports the libfontconfig kludge described below
39 elmer 1.20 %if (("%cmsplatf" == "slc4_ia32_gcc345")||("%cmsplatf" == "slc4_ia32_gcc412")||("%cmsplatf" == "slc4_ia32_gcc422"))
40 elmer 1.18 %patch4 -p1
41     %endif
42 eulisse 1.1
43     %build
44     unset QMAKESPEC || true
45     export QTDIR=$PWD
46     export PATH=$QTDIR/bin:$PATH
47     export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
48     export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH
49 eulisse 1.3
50     case $(uname -m) in
51     x86_64)
52     export CONFIG_ARGS="-platform linux-g++-64"
53     esac
54    
55     echo yes | ./configure -prefix %i -thread -stl $CONFIG_ARGS
56 eulisse 1.1 # install_framework is hosed
57     perl -p -i -e 's/^install_framework:/install_framework:\ninstall_framework_no:/' src/Makefile
58 elmer 1.15 # The following is a kludge around the fact that the fact that the
59     # /usr/lib/libfontconfig.so soft link (for 32-bit lib) is missing
60     # on the 64-bit machines
61 elmer 1.20 %if (("%cmsplatf" == "slc4_ia32_gcc345")||("%cmsplatf" == "slc4_ia32_gcc412")||("%cmsplatf" == "slc4_ia32_gcc422"))
62 elmer 1.18 mkdir -p %{_builddir}/lib
63     ln -s /usr/lib/libfontconfig.so.1 %{_builddir}/%n-%type-free-%{qtversion}/lib/libfontconfig.so
64     %endif
65 elmer 1.15
66 eulisse 1.2 make %makeprocesses
67 muzaffar 1.17
68     %install
69     make install
70    
71     # SCRAM ToolBox toolfile
72     mkdir -p %i/etc/scram.d
73     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
74     <doc type=BuildSystem::ToolDoc version=1.0>
75     <Tool name=%n version=%v>
76     <info url="http://www.trolltech.com/products/qt.html"></info>
77     <LIB name=qt-mt>
78     <Client>
79     <Environment name=QT_BASE default="%i"></Environment>
80     <Environment name=LIBDIR default="$QT_BASE/lib"></Environment>
81     <Environment name=INCLUDE default="$QT_BASE/include"></Environment>
82     </Client>
83     <Flags CPPDEFINES="QT_ALTERNATE_QTSMANIP QT_CLEAN_NAMESPACE QT_THREAD_SUPPORT">
84     <Runtime name=PATH value="$QT_BASE/bin" type=path>
85     <use name=X11>
86     <use name=opengl>
87     <use name=zlib>
88     </Tool>
89     EOF_TOOLFILE
90    
91 eulisse 1.11 %post
92     %{relocateConfig}lib/libqt-mt.la
93 muzaffar 1.17 %{relocateConfig}etc/scram.d/%n
94 eulisse 1.11