ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/qt.spec
Revision: 1.25
Committed: Mon Nov 24 09:41:07 2008 UTC (16 years, 5 months ago) by elmer
Branch: MAIN
CVS Tags: pe20090216a-30Xports-432, WEBTOOLS-APPS_20090130, WEBTOOLS-APPS_20090129, pe20090127c-30Xports-432, pe20090127b-30Xports-432, pe20090127a-30Xports-432, pe20090125a-30Xports-432, PRODAGENT_0_12_10_20090122, PRODAGENT_0_12_10_pre1_MISC, sw_20090115a, sw_20090115, pe20090114c-ports, pe20090114b-ports, pe20090114a-ports, pe20081213c-30Xports-432, pe20081213c-30Xports, pe20081213b-30Xports, pe20081213a-30Xports, pe20081125d-30Xports-432, pe20081125d-30Xports, pe20081125c-30Xports-432, pe20081125c-30Xports, pe20081125b-30Xports, pe20081125b-30Xports-432, pe20081125a-30Xports, pe20081124d-30Xports, pe20081124c-30Xports, pe20081124b-30Xports
Changes since 1.24: +2 -2 lines
Log Message:
Modify conditionals to support slc5_ia32* in addition to slc4_ia32*

File Contents

# User Rev Content
1 elmer 1.24 ### RPM external qt 3.3.8
2 eulisse 1.1 ## INITENV UNSET QMAKESPEC
3     ## INITENV SET QTDIR %i
4 elmer 1.15 %define qttype %(echo %realversion | sed 's/[-0-9.]*//')
5     %define qtversion %(echo %realversion | sed 's/-.*//')
6 eulisse 1.1 %if "%qttype" == ""
7     %ifos darwin
8     %define type mac
9     %else
10     %define type x11
11     %endif
12     %else
13     %define type %{qttype}
14     %endif
15    
16     %if "%type" == "x11"
17     %define sourcepkg 1
18     %else
19     %define sourcepkg 0
20     %endif
21    
22     # Requires: zlib, ...
23     Source0: ftp://ftp.trolltech.com/qt/source/%n-mac-free-%{qtversion}.tar.bz2
24     Source1: ftp://ftp.trolltech.com/qt/source/%n-x11-free-%{qtversion}.tar.bz2
25 elmer 1.7 Patch0: qt-mkspecs-qmake.conf
26     Patch1: qt-mkspecs-qplatformdefs.h
27     Patch2: qt-src-kernel-qaccessible_mac.cpp
28     Patch3: qt-src-qt_install.pri
29 elmer 1.15 Patch4: qt-mkspecs-qmake.conf_2
30 eulisse 1.21 Patch5: qt3-leopard
31 eulisse 1.1
32     %prep
33     %setup -T -b %sourcepkg -n %n-%type-free-%{qtversion}
34 elmer 1.12 #%ifos darwin
35     #%patch1 -p0
36     #%patch2 -p0
37     #%patch3 -p0
38     #%endif
39 eulisse 1.21
40     case %cmsplatf in
41 elmer 1.25 slc4_ia32* | slc5_ia32*)
42 eulisse 1.21 # The kludge supports the libfontconfig kludge described below
43 elmer 1.18 %patch4 -p1
44 eulisse 1.21 ;;
45     osx105* )
46     %patch5 -p1
47     ;;
48     esac
49 eulisse 1.1
50     %build
51     unset QMAKESPEC || true
52     export QTDIR=$PWD
53     export PATH=$QTDIR/bin:$PATH
54     export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
55     export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH
56 eulisse 1.3
57     case $(uname -m) in
58     x86_64)
59     export CONFIG_ARGS="-platform linux-g++-64"
60     esac
61    
62     echo yes | ./configure -prefix %i -thread -stl $CONFIG_ARGS
63 eulisse 1.1 # install_framework is hosed
64     perl -p -i -e 's/^install_framework:/install_framework:\ninstall_framework_no:/' src/Makefile
65 elmer 1.15 # The following is a kludge around the fact that the fact that the
66     # /usr/lib/libfontconfig.so soft link (for 32-bit lib) is missing
67     # on the 64-bit machines
68 muzaffar 1.23 case %cmsplatf in
69 elmer 1.25 slc4_ia32* | slc5_ia32*)
70 elmer 1.18 mkdir -p %{_builddir}/lib
71     ln -s /usr/lib/libfontconfig.so.1 %{_builddir}/%n-%type-free-%{qtversion}/lib/libfontconfig.so
72 muzaffar 1.23 esac
73 elmer 1.15
74 eulisse 1.2 make %makeprocesses
75 muzaffar 1.17
76     %install
77     make install
78    
79     # SCRAM ToolBox toolfile
80     mkdir -p %i/etc/scram.d
81     cat << \EOF_TOOLFILE >%i/etc/scram.d/%n
82     <doc type=BuildSystem::ToolDoc version=1.0>
83     <Tool name=%n version=%v>
84     <info url="http://www.trolltech.com/products/qt.html"></info>
85     <LIB name=qt-mt>
86     <Client>
87     <Environment name=QT_BASE default="%i"></Environment>
88     <Environment name=LIBDIR default="$QT_BASE/lib"></Environment>
89     <Environment name=INCLUDE default="$QT_BASE/include"></Environment>
90     </Client>
91     <Flags CPPDEFINES="QT_ALTERNATE_QTSMANIP QT_CLEAN_NAMESPACE QT_THREAD_SUPPORT">
92     <Runtime name=PATH value="$QT_BASE/bin" type=path>
93     <use name=X11>
94     <use name=opengl>
95     <use name=zlib>
96     </Tool>
97     EOF_TOOLFILE
98    
99 eulisse 1.11 %post
100     %{relocateConfig}lib/libqt-mt.la
101 muzaffar 1.17 %{relocateConfig}etc/scram.d/%n
102 eulisse 1.11