ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/qt.spec
Revision: 1.6
Committed: Wed May 17 15:15:44 2006 UTC (18 years, 11 months ago) by eulisse
Branch: MAIN
CVS Tags: CRABSERVER_TEST_BUILD_V4, CRABSERVER_TEST_BUILD_V3, CRABSERVER_TEST_BUILD_V2, CRABSERVER_TEST_BUILD_V1, forCRABSERVER104test, forCRABSERVER103, PRODAGENT_0_10_12_V10, PRODAGENT_0_10_12_V9, PRODAGENT_0_10_12_V8, PRODAGENT_0_10_12_V7, PRODAGENT_0_10_12_V6, PRODAGENT_0_10_12_V5, PRODAGENT_0_10_12_V4, forCS102pre4, PRODAGENT_0_10_12_V3, PRODAGENT_0_10_12_V2, PRODAGENT_0_10_12, PRODAGENT_0_10_3, PRODAGENT_0_10_3_20080521, PRODAGENT_0_8_3_SL4, forPA070pre3-slc3, forPA070pre3-slc4, forPA070pre3-slc, forPA061, forPA060pre7-slc4, forPA060pre3, forDBS106, forPA050pre3, WEBTOOLS_CONFIG_1_pre2, WEBTOOLS_CONFIG_1_pre1, forPA030, forPA020, PR_0_5_4, PR_0_5_0, PR_0_4_21, PRODREQUEST_0_4_0, PR0_3_13, PR0_3_12, PR0-3-11, forPR034, forPR033, forPIL116, forPR032, forPR030, forPR020, forPA011, forPR010, forPA010, af20060928, ProdAgent_pa17, phedex_2_3_series, V00-00-09, V00-00-08, V00-00-07, V00-00-06, V00-00-05
Changes since 1.5: +0 -1 lines
Log Message:
Removes dependency on virtual package x11. Uses system-base.

File Contents

# User Rev Content
1 eulisse 1.4 ### RPM external qt 3.3.4
2 eulisse 1.1 ## INITENV UNSET QMAKESPEC
3     ## INITENV SET QTDIR %i
4     %define qttype %(echo %v | sed 's/[-0-9.]*//')
5     %define qtversion %(echo %v | sed 's/-.*//')
6     %if "%qttype" == ""
7     %ifos darwin
8     %define type mac
9     %else
10     %define type x11
11     %endif
12     %else
13     %define type %{qttype}
14     %endif
15    
16     %if "%type" == "x11"
17     %define sourcepkg 1
18     %else
19     %define sourcepkg 0
20     %endif
21    
22     # Requires: zlib, ...
23     Source0: ftp://ftp.trolltech.com/qt/source/%n-mac-free-%{qtversion}.tar.bz2
24     Source1: ftp://ftp.trolltech.com/qt/source/%n-x11-free-%{qtversion}.tar.bz2
25    
26     %prep
27     %setup -T -b %sourcepkg -n %n-%type-free-%{qtversion}
28    
29     %build
30     unset QMAKESPEC || true
31     export QTDIR=$PWD
32     export PATH=$QTDIR/bin:$PATH
33     export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
34     export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH
35 eulisse 1.3
36     case $(uname -m) in
37     x86_64)
38     export CONFIG_ARGS="-platform linux-g++-64"
39     esac
40    
41     echo yes | ./configure -prefix %i -thread -stl $CONFIG_ARGS
42 eulisse 1.1 # install_framework is hosed
43     perl -p -i -e 's/^install_framework:/install_framework:\ninstall_framework_no:/' src/Makefile
44 eulisse 1.2 make %makeprocesses