ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/qt3.spec
Revision: 1.2
Committed: Tue Feb 3 08:27:02 2009 UTC (16 years, 2 months ago) by elmer
Branch: MAIN
CVS Tags: T0M_0_0_5, T0M_0_0_4, T0M_0_0_3, WEBTOOLS-APPS_20090203_1, WEBTOOLS-APPS_20090203, T0M_0_0_2
Changes since 1.1: +1 -1 lines
Log Message:
  Fix a qt<-->qt3 issue.

File Contents

# User Rev Content
1 elmer 1.1 ### RPM external qt3 3.3.8
2     ## INITENV UNSET QMAKESPEC
3     ## INITENV SET QTDIR %i
4     %define qttype %(echo %realversion | sed 's/[-0-9.]*//')
5     %define qtversion %(echo %realversion | sed 's/-.*//')
6     %if "%qttype" == ""
7     %ifos darwin
8     %define type mac
9     %else
10     %define type x11
11     %endif
12     %else
13     %define type %{qttype}
14     %endif
15    
16     %if "%type" == "x11"
17     %define sourcepkg 1
18     %else
19     %define sourcepkg 0
20     %endif
21    
22     # Requires: zlib, ...
23     Source0: ftp://ftp.trolltech.com/qt/source/qt-mac-free-%{qtversion}.tar.bz2
24     Source1: ftp://ftp.trolltech.com/qt/source/qt-x11-free-%{qtversion}.tar.bz2
25     Patch0: qt-mkspecs-qmake.conf
26     Patch1: qt-mkspecs-qplatformdefs.h
27     Patch2: qt-src-kernel-qaccessible_mac.cpp
28     Patch3: qt-src-qt_install.pri
29     Patch4: qt-mkspecs-qmake.conf_2
30     Patch5: qt3-leopard
31    
32     %prep
33     %setup -T -b %sourcepkg -n qt-%type-free-%{qtversion}
34     #%ifos darwin
35     #%patch1 -p0
36     #%patch2 -p0
37     #%patch3 -p0
38     #%endif
39    
40     case %cmsplatf in
41     slc4_ia32* )
42     # The kludge supports the libfontconfig kludge described below
43     %patch4 -p1
44     ;;
45     osx105* )
46     %patch5 -p1
47     ;;
48     esac
49    
50     %build
51     unset QMAKESPEC || true
52     export QTDIR=$PWD
53     export PATH=$QTDIR/bin:$PATH
54     export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
55     export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH
56    
57     case $(uname -m) in
58     x86_64)
59     export CONFIG_ARGS="-platform linux-g++-64"
60     esac
61    
62     echo yes | ./configure -prefix %i -thread -stl $CONFIG_ARGS
63     # install_framework is hosed
64     perl -p -i -e 's/^install_framework:/install_framework:\ninstall_framework_no:/' src/Makefile
65     # The following is a kludge around the fact that the fact that the
66     # /usr/lib/libfontconfig.so soft link (for 32-bit lib) is missing
67     # on the 64-bit machines
68     %if (("%cmsplatf" == "slc4_ia32_gcc345")||("%cmsplatf" == "slc4_ia32_gcc412")||("%cmsplatf" == "slc4_ia32_gcc422"))
69     mkdir -p %{_builddir}/lib
70 elmer 1.2 ln -s /usr/lib/libfontconfig.so.1 %{_builddir}/qt-%type-free-%{qtversion}/lib/libfontconfig.so
71 elmer 1.1 %endif
72    
73     make %makeprocesses
74    
75     %install
76     make install
77    
78     # SCRAM ToolBox toolfile
79     mkdir -p %i/etc/scram.d
80     cat << \EOF_TOOLFILE >%i/etc/scram.d/qt3
81     <doc type=BuildSystem::ToolDoc version=1.0>
82     <Tool name=qt3 version=%v>
83     <info url="http://www.trolltech.com/products/qt.html"></info>
84     <LIB name=qt-mt>
85     <Client>
86     <Environment name=QT_BASE default="%i"></Environment>
87     <Environment name=LIBDIR default="$QT_BASE/lib"></Environment>
88     <Environment name=INCLUDE default="$QT_BASE/include"></Environment>
89     </Client>
90     <Flags CPPDEFINES="QT_ALTERNATE_QTSMANIP QT_CLEAN_NAMESPACE QT_THREAD_SUPPORT">
91     <Runtime name=PATH value="$QT_BASE/bin" type=path>
92     <use name=X11>
93     <use name=opengl>
94     <use name=zlib>
95     </Tool>
96     EOF_TOOLFILE
97    
98     %post
99     %{relocateConfig}lib/libqt-mt.la
100     %{relocateConfig}etc/scram.d/qt3
101