Revision: | 1.6 |
Committed: | Sun Apr 22 13:46:53 2007 UTC (18 years ago) by elmer |
Branch: | MAIN |
CVS Tags: | HEAD |
Changes since 1.5: | +0 -0 lines |
State: | FILE REMOVED |
Error occurred while calculating annotation data. | |
Log Message: | Remove no longer needed spec files. (They are always available from the Attic if need be...) |
# | Content |
---|---|
1 | ### RPM external qutexmlrpc 0.2 |
2 | Requires: gcc-wrapper |
3 | # Patches by Lassi A. Tuura <lat@iki.fi> (FIXME: contribute) |
4 | Requires: qt |
5 | #Source: http://switch.dl.sourceforge.net/sourceforge/qutexr/%n-%v.tar.gz |
6 | Source: http://service-spi.web.cern.ch/service-spi/external/tarFiles/QuteXMLRPC-%{v}.tar.gz |
7 | |
8 | %prep |
9 | %setup -n QuteXMLRPC-%{v} |
10 | |
11 | %build |
12 | ## IMPORT gcc-wrapper |
13 | # Allow Qt location to be overridden from RPM command line |
14 | %if "%{?qtpath:set}" == "set" |
15 | QT_ROOT="%qtpath" |
16 | export QT_ROOT |
17 | unset QMAKESPEC || true |
18 | export QTDIR=$QT_ROOT |
19 | export PATH=$QTDIR/bin:$PATH |
20 | export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH |
21 | export DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH |
22 | %endif |
23 | |
24 | cd src |
25 | qmake |
26 | make |
27 | |
28 | %install |
29 | cd src |
30 | mkdir -p %i/lib %i/include/qutexmlrpc |
31 | tar -cf - libqutexr.* | tar -C %i/lib -xvf - |
32 | tar -cf - *.h | tar -C %i/include -xvf - |
33 | # |