ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/rivet.spec
Revision: 1.17
Committed: Mon May 14 12:11:53 2012 UTC (12 years, 11 months ago) by davidlt
Branch: MAIN
CVS Tags: davidlt_20120715_1021-60X-gcc470, davidlt_20120714_2228-60X-gcc470, CMSSW_6_0_0_pre8-gcc470, davidlt_20120712_1112-60X-gcc470, daForCMSSW_6_0_0_pre8-slc5_amd64_gcc470, davidlt_20120710_1801-60X-gcc470, davidlt_20120709_0945-60X-gcc470, davidlt_20120629_1419-60X-gcc470, davidlt_20120627_1634-60X-gcc470, davidlt_20120627_1104-60X-gcc470, davidlt_20120625_1024-60X-gcc470, CMSSW_6_0_0_pre7-gcc470, daForCMSSW_6_0_0_pre7-slc5_amd64_gcc470, davidlt_20120614_2147-gcc470, davidlt_20120613_1051-60X-gcc470, davidlt_20120611_1739-gcc470, davidlt_20120608_1804-60X-gcc470, CMSSW_6_0_0_pre6Nmix-gcc470, daForCMSSW_6_0_0_pre6Nmix-slc5_amd64_gcc470, CMSSW_6_0_0_pre6g495p01-gcc470, daForCMSSW_6_0_0_pre6g495p01-slc5_amd64_gcc470, davidlt_20120607_1801-60X-gcc470, davidlt_20120607_1525-60X-gcc470, davidlt_20120606_2304-60X-gcc470, davidlt_20120605_2037-60X-gcc470, davidlt_20120604_1841-60X-gcc470, CMSSW_6_0_0_pre6-gcc470, daForCMSSW_6_0_0_pre6-slc5_amd64_gcc470, davidlt_20120531_1111-60X-gcc470, davidlt_20120529_1110-60X-gcc470, davidlt_20120529_1024-60X-gcc470, davidlt_20120528_1230-60X-gcc470, davidlt_20120525_1144-60X-gcc470, davidlt_test_gcc470_1
Changes since 1.16: +12 -1 lines
Log Message:
Compile in C++11 mode.

File Contents

# User Rev Content
1 fabiocos 1.14 ### RPM external rivet 1.5.1
2 elmer 1.1 Source: http://www.hepforge.org/archive/rivet/Rivet-%{realversion}.tar.gz
3 elmer 1.5
4 elmer 1.1 Requires: hepmc boost fastjet swig gsl
5 elmer 1.10 Patch0: rivet-1.4.0
6 davidlt 1.16 Patch1: rivet-1.5.1-fix-gcc47
7 davidlt 1.17
8     %if "%{?cms_cxx:set}" != "set"
9     %define cms_cxx g++
10     %endif
11    
12     %if "%{?cms_cxxflags:set}" != "set"
13     %define cms_cxxflags -O2 -std=c++0x
14     %endif
15    
16 elmer 1.1 %prep
17     %setup -n Rivet-%{realversion}
18 elmer 1.11 %patch0 -p0
19 davidlt 1.16 %patch1 -p1
20 davidlt 1.17 ./configure --disable-silent-rules --prefix=%i --with-boost=${BOOST_ROOT} --with-hepmc=$HEPMC_ROOT \
21     --with-fastjet=$FASTJET_ROOT --with-gsl=$GSL_ROOT --disable-doxygen --disable-pdfmanual --with-pic \
22     CXX="$(which %cms_cxx)" CXXFLAGS="%cms_cxxflags"
23 elmer 1.3 # The following hack insures that the bins with the library linked explicitly
24     # rather than indirectly, as required by the gold linker
25     perl -p -i -e "s|LIBS = $|LIBS = -lHepMC|g" bin/Makefile
26 elmer 1.1 %build
27     make
28     %install
29     make install
30 elmer 1.4 # The following creates a (for now) empty directory consistent with the
31     # tool definition (probably the PYTHONPATH entry could be removed there,
32     # too, but I'm still not sure if there is a use case for the python or not)
33     mkdir -p %i/lib/python2.6/site-packages
34 zafar 1.15