1 |
muzaffar |
1.7 |
### RPM lcg root-toolfile 2.0
|
2 |
eulisse |
1.1 |
Requires: root
|
3 |
muzaffar |
1.3 |
%prep
|
4 |
eulisse |
1.1 |
|
5 |
|
|
%build
|
6 |
muzaffar |
1.3 |
|
7 |
eulisse |
1.1 |
%install
|
8 |
|
|
|
9 |
muzaffar |
1.3 |
mkdir -p %i/etc/scram.d
|
10 |
muzaffar |
1.7 |
# root_interface toolfile
|
11 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/root_interface.xml
|
12 |
muzaffar |
1.8 |
<tool name="root_interface" version="@TOOL_VERSION@">
|
13 |
muzaffar |
1.7 |
<info url="http://root.cern.ch/root/"/>
|
14 |
|
|
<client>
|
15 |
|
|
<environment name="ROOT_INTERFACE_BASE" default="@TOOL_ROOT@"/>
|
16 |
|
|
<environment name="INCLUDE" default="$ROOT_INTERFACE_BASE/include"/>
|
17 |
|
|
<environment name="LIBDIR" default="$ROOT_INTERFACE_BASE/lib"/>
|
18 |
|
|
</client>
|
19 |
|
|
<runtime name="PATH" value="$ROOT_INTERFACE_BASE/bin" type="path"/>
|
20 |
|
|
<runtime name="PYTHONPATH" value="$ROOT_INTERFACE_BASE/lib" type="path"/>
|
21 |
|
|
<runtime name="ROOTSYS" value="$ROOT_INTERFACE_BASE/"/>
|
22 |
|
|
</tool>
|
23 |
|
|
EOF_TOOLFILE
|
24 |
|
|
|
25 |
|
|
# rootcint toolfile
|
26 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcint.xml
|
27 |
|
|
<tool name="rootcint" version="@TOOL_VERSION@">
|
28 |
muzaffar |
1.3 |
<info url="http://root.cern.ch/root/"/>
|
29 |
|
|
<lib name="Core"/>
|
30 |
|
|
<lib name="Cint"/>
|
31 |
|
|
<client>
|
32 |
muzaffar |
1.7 |
<environment name="ROOTCINT_BASE" default="@TOOL_ROOT@"/>
|
33 |
|
|
<environment name="INCLUDE" default="$ROOTCINT_BASE/cint"/>
|
34 |
muzaffar |
1.3 |
</client>
|
35 |
muzaffar |
1.7 |
<use name="root_interface"/>
|
36 |
muzaffar |
1.3 |
<use name="sockets"/>
|
37 |
|
|
<use name="pcre"/>
|
38 |
|
|
<use name="zlib"/>
|
39 |
|
|
</tool>
|
40 |
|
|
EOF_TOOLFILE
|
41 |
|
|
|
42 |
muzaffar |
1.7 |
# rootrint toolfile
|
43 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrint.xml
|
44 |
|
|
<tool name="rootrint" version="@TOOL_VERSION@">
|
45 |
|
|
<info url="http://root.cern.ch/root/"/>
|
46 |
|
|
<lib name="Rint"/>
|
47 |
|
|
<use name="rootcint"/>
|
48 |
|
|
</tool>
|
49 |
|
|
EOF_TOOLFILE
|
50 |
|
|
|
51 |
|
|
# rootrio toolfile
|
52 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrio.xml
|
53 |
|
|
<tool name="rootrio" version="@TOOL_VERSION@">
|
54 |
|
|
<info url="http://root.cern.ch/root/"/>
|
55 |
|
|
<lib name="RIO"/>
|
56 |
|
|
<use name="rootcint"/>
|
57 |
|
|
</tool>
|
58 |
|
|
EOF_TOOLFILE
|
59 |
|
|
|
60 |
muzaffar |
1.9 |
# rootthread toolfile
|
61 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootthread.xml
|
62 |
|
|
<tool name="rootthread" version="@TOOL_VERSION@">
|
63 |
|
|
<info url="http://root.cern.ch/root/"/>
|
64 |
|
|
<lib name="Thread"/>
|
65 |
|
|
<use name="rootrio"/>
|
66 |
|
|
</tool>
|
67 |
|
|
EOF_TOOLFILE
|
68 |
|
|
|
69 |
muzaffar |
1.7 |
# rootxmlio toolfile
|
70 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootxmlio.xml
|
71 |
|
|
<tool name="rootxmlio" version="@TOOL_VERSION@">
|
72 |
|
|
<info url="http://root.cern.ch/root/"/>
|
73 |
|
|
<lib name="XMLIO"/>
|
74 |
|
|
<use name="rootrio"/>
|
75 |
|
|
</tool>
|
76 |
|
|
EOF_TOOLFILE
|
77 |
|
|
|
78 |
muzaffar |
1.9 |
# rootmathcore toolfile
|
79 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmathcore.xml
|
80 |
|
|
<tool name="rootmathcore" version="@TOOL_VERSION@">
|
81 |
|
|
<info url="http://root.cern.ch/root/"/>
|
82 |
|
|
<lib name="MathCore"/>
|
83 |
|
|
<use name="rootcint"/>
|
84 |
|
|
</tool>
|
85 |
|
|
EOF_TOOLFILE
|
86 |
|
|
|
87 |
muzaffar |
1.7 |
# rootcore toolfile
|
88 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcore.xml
|
89 |
|
|
<tool name="rootcore" version="@TOOL_VERSION@">
|
90 |
muzaffar |
1.3 |
<info url="http://root.cern.ch/root/"/>
|
91 |
muzaffar |
1.7 |
<lib name="Tree"/>
|
92 |
|
|
<lib name="Net"/>
|
93 |
muzaffar |
1.9 |
<use name="rootmathcore"/>
|
94 |
|
|
<use name="rootthread"/>
|
95 |
muzaffar |
1.3 |
</tool>
|
96 |
|
|
EOF_TOOLFILE
|
97 |
|
|
|
98 |
|
|
# roothistmatrix toolfile
|
99 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/roothistmatrix.xml
|
100 |
|
|
<tool name="roothistmatrix" version="@TOOL_VERSION@">
|
101 |
|
|
<info url="http://root.cern.ch/root/"/>
|
102 |
|
|
<lib name="Hist"/>
|
103 |
|
|
<lib name="Matrix"/>
|
104 |
muzaffar |
1.7 |
<use name="rootcore"/>
|
105 |
|
|
</tool>
|
106 |
|
|
EOF_TOOLFILE
|
107 |
|
|
|
108 |
muzaffar |
1.9 |
# rootspectrum toolfile
|
109 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootspectrum.xml
|
110 |
|
|
<tool name="rootspectrum" version="@TOOL_VERSION@">
|
111 |
|
|
<info url="http://root.cern.ch/root/"/>
|
112 |
|
|
<lib name="Spectrum"/>
|
113 |
|
|
<use name="roothistmatrix"/>
|
114 |
|
|
</tool>
|
115 |
|
|
EOF_TOOLFILE
|
116 |
|
|
|
117 |
muzaffar |
1.7 |
# rootphysics toolfile
|
118 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootphysics.xml
|
119 |
|
|
<tool name="rootphysics" version="@TOOL_VERSION@">
|
120 |
|
|
<info url="http://root.cern.ch/root/"/>
|
121 |
|
|
<lib name="Physics"/>
|
122 |
|
|
<use name="roothistmatrix"/>
|
123 |
|
|
</tool>
|
124 |
|
|
EOF_TOOLFILE
|
125 |
|
|
|
126 |
|
|
# root toolfile, alias for rootphysics. Using rootphysics is preferred.
|
127 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/root.xml
|
128 |
|
|
<tool name="root" version="@TOOL_VERSION@">
|
129 |
|
|
<info url="http://root.cern.ch/root/"/>
|
130 |
|
|
<use name="rootphysics"/>
|
131 |
muzaffar |
1.3 |
</tool>
|
132 |
|
|
EOF_TOOLFILE
|
133 |
|
|
|
134 |
|
|
# rootgpad toolfile
|
135 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgpad.xml
|
136 |
|
|
<tool name="rootgpad" version="@TOOL_VERSION@">
|
137 |
|
|
<info url="http://root.cern.ch/root/"/>
|
138 |
|
|
<lib name="Gpad"/>
|
139 |
|
|
<lib name="Graf"/>
|
140 |
|
|
<use name="roothistmatrix"/>
|
141 |
|
|
</tool>
|
142 |
|
|
EOF_TOOLFILE
|
143 |
|
|
|
144 |
|
|
# rootgraphics toolfile, identical to old "root" toolfile
|
145 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgraphics.xml
|
146 |
|
|
<tool name="rootgraphics" version="@TOOL_VERSION@">
|
147 |
|
|
<info url="http://root.cern.ch/root/"/>
|
148 |
|
|
<lib name="TreePlayer"/>
|
149 |
|
|
<lib name="Graf3d"/>
|
150 |
|
|
<lib name="Postscript"/>
|
151 |
|
|
<use name="rootgpad"/>
|
152 |
|
|
</tool>
|
153 |
|
|
EOF_TOOLFILE
|
154 |
|
|
|
155 |
muzaffar |
1.9 |
# rooteg toolfile, identical to old "root" toolfile
|
156 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rooteg.xml
|
157 |
|
|
<tool name="rooteg" version="@TOOL_VERSION@">
|
158 |
|
|
<info url="http://root.cern.ch/root/"/>
|
159 |
|
|
<lib name="EG"/>
|
160 |
|
|
<use name="rootgraphics"/>
|
161 |
|
|
</tool>
|
162 |
|
|
EOF_TOOLFILE
|
163 |
|
|
|
164 |
|
|
# rootpy toolfile, identical to old "root" toolfile
|
165 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootpy.xml
|
166 |
|
|
<tool name="rootpy" version="@TOOL_VERSION@">
|
167 |
|
|
<info url="http://root.cern.ch/root/"/>
|
168 |
|
|
<lib name="PyROOT"/>
|
169 |
|
|
<use name="rootgraphics"/>
|
170 |
|
|
</tool>
|
171 |
|
|
EOF_TOOLFILE
|
172 |
|
|
|
173 |
elmer |
1.6 |
# rootinteractive toolfile
|
174 |
muzaffar |
1.3 |
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootinteractive.xml
|
175 |
|
|
<tool name="rootinteractive" version="@TOOL_VERSION@">
|
176 |
|
|
<info url="http://root.cern.ch/root/"/>
|
177 |
|
|
<lib name="Gui"/>
|
178 |
|
|
<use name="libjpg"/>
|
179 |
|
|
<use name="libpng"/>
|
180 |
|
|
<use name="rootgpad"/>
|
181 |
muzaffar |
1.7 |
<use name="rootrint"/>
|
182 |
muzaffar |
1.3 |
</tool>
|
183 |
|
|
EOF_TOOLFILE
|
184 |
|
|
|
185 |
|
|
# rootmath toolfile
|
186 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmath.xml
|
187 |
|
|
<tool name="rootmath" version="@TOOL_VERSION@">
|
188 |
|
|
<info url="http://root.cern.ch/root/"/>
|
189 |
|
|
<lib name="GenVector"/>
|
190 |
|
|
<lib name="MathMore"/>
|
191 |
muzaffar |
1.7 |
<use name="rootcore"/>
|
192 |
muzaffar |
1.3 |
<use name="gsl"/>
|
193 |
|
|
</tool>
|
194 |
|
|
EOF_TOOLFILE
|
195 |
|
|
|
196 |
|
|
# rootminuit toolfile
|
197 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit.xml
|
198 |
|
|
<tool name="rootminuit" version="@TOOL_VERSION@">
|
199 |
|
|
<info url="http://root.cern.ch/root/"/>
|
200 |
|
|
<lib name="Minuit"/>
|
201 |
|
|
<use name="rootgpad"/>
|
202 |
|
|
</tool>
|
203 |
|
|
EOF_TOOLFILE
|
204 |
|
|
|
205 |
|
|
# rootminuit2 toolfile
|
206 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit2.xml
|
207 |
|
|
<tool name="rootminuit2" version="@TOOL_VERSION@">
|
208 |
|
|
<info url="http://root.cern.ch/root/"/>
|
209 |
|
|
<lib name="Minuit2"/>
|
210 |
|
|
<use name="rootgpad"/>
|
211 |
|
|
</tool>
|
212 |
|
|
EOF_TOOLFILE
|
213 |
|
|
|
214 |
|
|
# rootrflx toolfile
|
215 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrflx.xml
|
216 |
|
|
<tool name="rootrflx" version="@TOOL_VERSION@">
|
217 |
|
|
<info url="http://root.cern.ch/root/"/>
|
218 |
|
|
<lib name="Reflex"/>
|
219 |
|
|
<client>
|
220 |
|
|
<environment name="ROOTRFLX_BASE" default="@TOOL_ROOT@"/>
|
221 |
|
|
</client>
|
222 |
eulisse |
1.4 |
<flags GENREFLEX_GCCXMLOPT="@GENREFLEX_GCCXMLOPT@"/>
|
223 |
davidlt |
1.10 |
<flags GENREFLEX_CPPFLAGS="-DCMS_DICT_IMPL -D_REENTRANT -DGNUSOURCE -D__STRICT_ANSI__"/>
|
224 |
eulisse |
1.4 |
<flags GENREFLEX_ARGS="--deep"/>
|
225 |
muzaffar |
1.3 |
<runtime name="GENREFLEX" value="$ROOTRFLX_BASE/bin/genreflex"/>
|
226 |
|
|
<use name="gccxml"/>
|
227 |
muzaffar |
1.7 |
<use name="root_interface"/>
|
228 |
muzaffar |
1.3 |
</tool>
|
229 |
|
|
EOF_TOOLFILE
|
230 |
|
|
|
231 |
|
|
# roothtml toolfile
|
232 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/roothtml.xml
|
233 |
|
|
<tool name="roothtml" version="@TOOL_VERSION@">
|
234 |
|
|
<info url="http://root.cern.ch/root/"/>
|
235 |
|
|
<lib name="Html"/>
|
236 |
|
|
<use name="rootgpad"/>
|
237 |
|
|
</tool>
|
238 |
|
|
EOF_TOOLFILE
|
239 |
|
|
|
240 |
|
|
# rootmlp toolfile
|
241 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmlp.xml
|
242 |
|
|
<tool name="rootmlp" version="@TOOL_VERSION@">
|
243 |
|
|
<info url="http://root.cern.ch/root/"/>
|
244 |
|
|
<lib name="MLP"/>
|
245 |
muzaffar |
1.7 |
<use name="rootgraphics"/>
|
246 |
muzaffar |
1.3 |
</tool>
|
247 |
|
|
EOF_TOOLFILE
|
248 |
|
|
|
249 |
|
|
# roottmva toolfile
|
250 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/roottmva.xml
|
251 |
|
|
<tool name="roottmva" version="@TOOL_VERSION@">
|
252 |
|
|
<info url="http://root.cern.ch/root/"/>
|
253 |
|
|
<lib name="TMVA"/>
|
254 |
muzaffar |
1.7 |
<use name="rootmlp"/>
|
255 |
muzaffar |
1.3 |
<use name="rootminuit"/>
|
256 |
|
|
</tool>
|
257 |
|
|
EOF_TOOLFILE
|
258 |
|
|
|
259 |
elmer |
1.5 |
# rootxml toolfile
|
260 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootxml.xml
|
261 |
muzaffar |
1.7 |
<tool name="rootxml" version="@TOOL_VERSION@">
|
262 |
|
|
<info url="http://root.cern.ch/root/"/>
|
263 |
|
|
<lib name="XMLParser"/>
|
264 |
|
|
<use name="rootcore"/>
|
265 |
|
|
</tool>
|
266 |
elmer |
1.5 |
EOF_TOOLFILE
|
267 |
|
|
|
268 |
|
|
# rootfoam toolfile
|
269 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootfoam.xml
|
270 |
muzaffar |
1.7 |
<tool name="rootfoam" version="@TOOL_VERSION@">
|
271 |
|
|
<info url="http://root.cern.ch/root/"/>
|
272 |
|
|
<lib name="Foam"/>
|
273 |
|
|
<use name="roothistmatrix"/>
|
274 |
|
|
</tool>
|
275 |
elmer |
1.5 |
EOF_TOOLFILE
|
276 |
|
|
|
277 |
muzaffar |
1.7 |
# rootcintex toolfile
|
278 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcintex.xml
|
279 |
|
|
<tool name="rootcintex" version="@TOOL_VERSION@">
|
280 |
|
|
<info url="http://root.cern.ch/root/"/>
|
281 |
|
|
<lib name="Cintex"/>
|
282 |
|
|
<use name="rootrflx"/>
|
283 |
|
|
<use name="rootcint"/>
|
284 |
|
|
</tool>
|
285 |
|
|
EOF_TOOLFILE
|
286 |
|
|
|
287 |
muzaffar |
1.9 |
# rootgeom toolfile
|
288 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgeom.xml
|
289 |
|
|
<tool name="rootgeom" version="@TOOL_VERSION@">
|
290 |
|
|
<info url="http://root.cern.ch/root/"/>
|
291 |
|
|
<lib name="Geom"/>
|
292 |
|
|
<use name="rootrio"/>
|
293 |
|
|
<use name="rootmathcore"/>
|
294 |
|
|
</tool>
|
295 |
|
|
EOF_TOOLFILE
|
296 |
|
|
|
297 |
|
|
# rootgeompainter toolfile
|
298 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgeompainter.xml
|
299 |
|
|
<tool name="rootgeompainter" version="@TOOL_VERSION@">
|
300 |
|
|
<info url="http://root.cern.ch/root/"/>
|
301 |
|
|
<lib name="GeomPainter"/>
|
302 |
|
|
<use name="rootgeom"/>
|
303 |
|
|
<use name="rootgraphics"/>
|
304 |
|
|
</tool>
|
305 |
|
|
EOF_TOOLFILE
|
306 |
|
|
|
307 |
|
|
# rootrgl toolfile
|
308 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrgl.xml
|
309 |
|
|
<tool name="rootrgl" version="@TOOL_VERSION@">
|
310 |
|
|
<info url="http://root.cern.ch/root/"/>
|
311 |
|
|
<lib name="RGL"/>
|
312 |
|
|
<use name="rootinteractive"/>
|
313 |
|
|
<use name="rootgraphics"/>
|
314 |
|
|
</tool>
|
315 |
|
|
EOF_TOOLFILE
|
316 |
|
|
|
317 |
|
|
# rooteve toolfile
|
318 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rooteve.xml
|
319 |
|
|
<tool name="rooteve" version="@TOOL_VERSION@">
|
320 |
|
|
<info url="http://root.cern.ch/root/"/>
|
321 |
|
|
<lib name="Eve"/>
|
322 |
|
|
<use name="rootgeompainter"/>
|
323 |
|
|
<use name="rootrgl"/>
|
324 |
|
|
</tool>
|
325 |
|
|
EOF_TOOLFILE
|
326 |
|
|
|
327 |
|
|
# rootguihtml toolfile
|
328 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootguihtml.xml
|
329 |
|
|
<tool name="rootguihtml" version="@TOOL_VERSION@">
|
330 |
|
|
<info url="http://root.cern.ch/root/"/>
|
331 |
|
|
<lib name="GuiHtml"/>
|
332 |
|
|
<use name="rootinteractive"/>
|
333 |
|
|
</tool>
|
334 |
|
|
EOF_TOOLFILE
|
335 |
|
|
|
336 |
muzaffar |
1.7 |
case %cmsos in
|
337 |
|
|
*_ia32)
|
338 |
|
|
GENREFLEX_GCCXMLOPT="-m32"
|
339 |
|
|
;;
|
340 |
|
|
*_amd64)
|
341 |
|
|
GENREFLEX_GCCXMLOPT="-m64"
|
342 |
|
|
;;
|
343 |
|
|
esac
|
344 |
|
|
export GENREFLEX_GCCXMLOPT
|
345 |
|
|
|
346 |
muzaffar |
1.3 |
## IMPORT scram-tools-post
|