ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.1
Committed: Tue Feb 21 08:09:59 2006 UTC (19 years, 2 months ago) by eulisse
Branch: MAIN
CVS Tags: test1, NataliaStart
Log Message:
First added to repository.

File Contents

# User Rev Content
1 eulisse 1.1 ### RPM lcg root 5.08.00
2     # Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %v | tr . -)&module=root&output=/%{n}_v%{v}.source.tar.gz
3     Source: ftp://root.cern.ch/%n/%{n}_v%{v}.source.tar.gz
4    
5     %prep
6     %setup -n root
7    
8     %build
9     mkdir -p %i
10     export ROOTSYS=%i
11     case $(uname) in
12     Linux)
13     ./configure linux ;;
14     Darwin)
15     ./configure macosx ;;
16     esac
17     make
18    
19     %install
20     # Override installers if we are using GNU fileutils cp. On OS X
21     # ROOT's INSTALL is defined to "cp -pPR", which only works with
22     # the system cp (/bin/cp). If you have fileutils on fink, you
23     # lose. Check which one is getting picked up and select syntax
24     # accordingly. (FIXME: do we need to check that -P is accepted?)
25     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
26     cp="cp -dpR"
27     else
28     cp="cp -pPR"
29     fi
30    
31     export ROOTSYS=%i
32     make INSTALL="$cp" INSTALLDATA="$cp" install