ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.13
Committed: Thu Jun 8 13:38:42 2006 UTC (18 years, 10 months ago) by eulisse
Branch: MAIN
CVS Tags: V00-00-10
Changes since 1.12: +1 -1 lines
Log Message:
libjpg libtiff and libpng added among the dependencies.

File Contents

# User Rev Content
1 eulisse 1.6 ### RPM lcg root 5.10.00c
2 eulisse 1.5 # INITENV +PATH PYTHONPATH %i/lib/python
3 eulisse 1.1 # Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %v | tr . -)&module=root&output=/%{n}_v%{v}.source.tar.gz
4     Source: ftp://root.cern.ch/%n/%{n}_v%{v}.source.tar.gz
5 eulisse 1.13 Requires: gccxml python qt gsl rfio openssl mysql libpng libjpg libtiff
6 eulisse 1.4 Patch0: root
7 eulisse 1.1 %prep
8     %setup -n root
9 eulisse 1.4 %patch0
10 eulisse 1.1
11     %build
12     mkdir -p %i
13     export ROOTSYS=%i
14 eulisse 1.2 CONFIG_ARGS="--enable-table
15     --with-gccxml=${GCCXML_ROOT}
16     --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include
17 eulisse 1.12 --enable-mysql --with-mysql-libdir=${MYSQL_ROOT}/lib --with-mysql-incdir=${MYSQL_ROOT}/include
18 eulisse 1.2 --enable-explicitlink
19     --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
20     --enable-mathcore
21     --enable-reflex
22     --enable-cintex
23     --enable-minuit2
24 eulisse 1.7 --enable-roofit
25     --disable-ldap
26     --disable-krb5
27     --with-ssl-incdir=${OPENSSL_ROOT}/include
28     --with-ssl-libdir=${OPENSSL_ROOT}/lib
29     --with-shift-incdir=${RFIO_ROOT}/include
30     --with-shift-libdir=${RFIO_ROOT}/lib
31     --disable-pgsql
32     --disable-xml"
33 eulisse 1.2
34     case $(uname)-$(uname -m) in
35     Linux-x86_64)
36     ./configure linuxx8664gcc $CONFIG_ARGS;;
37     Linux*)
38     ./configure linux $CONFIG_ARGS;;
39 elmer 1.11 Darwin*)
40 eulisse 1.2 ./configure macosx $CONFIG_ARGS;;
41 eulisse 1.1 esac
42 eulisse 1.2
43     make %makeprocesses
44 eulisse 1.1
45     %install
46     # Override installers if we are using GNU fileutils cp. On OS X
47     # ROOT's INSTALL is defined to "cp -pPR", which only works with
48     # the system cp (/bin/cp). If you have fileutils on fink, you
49     # lose. Check which one is getting picked up and select syntax
50     # accordingly. (FIXME: do we need to check that -P is accepted?)
51     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
52     cp="cp -dpR"
53     else
54     cp="cp -pPR"
55     fi
56    
57 eulisse 1.6 export ROOTSYS=%i/root
58 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
59 eulisse 1.8 mkdir -p %i/root/lib/python
60 eulisse 1.6 cp -r reflex/python/genreflex %i/root/lib/python