ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.191
Committed: Wed Feb 24 16:00:39 2010 UTC (15 years, 2 months ago) by dsr
Branch: MAIN
CVS Tags: dsr20100326fwlite355osx, CMSSW_3_6_0_pre4, pe20100324a-for36X, pe20100321a-for36X, CMSSW_3_6_0_pre3, pe20100313a-for36X, pe20100312a-for36X, pe20100311a-for36X, pe20100307a-for36X, pe20100305e-for36X, pe20100305d-for36X, pe20100305c-for36X, pe20100305b-for36X
Changes since 1.190: +10 -1 lines
Log Message:
set -arch flag on osx based on cmsplatf architecture; needed so that ACLiC in i386 builds still uses i386 architecture when installed on x86_64

File Contents

# User Rev Content
1 eulisse 1.190 ### RPM lcg root 5.22.00d
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.177 ## INITENV SET ROOTSYS %i
4 ratnik 1.106 #Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz
5 elmer 1.144 Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
6 muzaffar 1.165 %define closingbrace )
7 elmer 1.179 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
8 elmer 1.96
9 elmer 1.155 Patch0: root-5.18-00-libpng
10 eulisse 1.190 Patch1: root-5.21-04-CINT-maxlongline
11     Patch2: root-5.22-00-TMVA-shut-the-hell-up-for-once
12     Patch3: root-5.22-00a-TMVA-shut-the-hell-up-again
13     Patch4: root-5.22-00d-fireworks-graf3d-gui
14     Patch5: root-5.22-00a-roofit-silence-static-printout
15     Patch6: root-5.22-00a-TMVA-just-shut-the-hell-up
16     Patch7: root-5.22-00a-th1
17     Patch8: root-5.22-00a-smatrix
18     Patch9: root-5.22-00a-fireworks1
19     Patch10: root-5.22-00a-gcc44
20     Patch11: root-5.22-00a-fireworks2
21     Patch12: root-5.22-00a-fireworks3
22     Patch13: root-5.22-00a-gcc43-array-bounds-dictionary-workaround
23     Patch14: root-5.22-00a-fireworks4
24     Patch15: root-5.22-00d-fireworks5
25     Patch16: root-5.22-00d-genreflex_python26_popen3
26     Patch17: root-5.22-00d-fireworks6
27     Patch18: root-5.22-00d-linker-gnu-hash-style
28     Patch19: root-5.22-00d-TFile-version3-Init
29     Patch20: root-5.22-00d-cint-namespace
30 elmer 1.98
31     %define cpu %(echo %cmsplatf | cut -d_ -f2)
32    
33 ratnik 1.106 Requires: gccxml gsl castor libjpg dcap pcre python
34 dlange 1.103
35 muzaffar 1.164 %if "%online" != "true"
36 elmer 1.181 Requires: qt openssl libpng zlib libungif xrootd
37 dlange 1.103 %else
38     %define skiplibtiff true
39     %endif
40    
41     %if "%cpu" == "amd64"
42     %define skiplibtiff true
43     %endif
44    
45     %if "%skiplibtiff" != "true"
46 elmer 1.98 Requires: libtiff
47     %endif
48 eulisse 1.25
49 eulisse 1.1 %prep
50     %setup -n root
51 ratnik 1.106 %patch0 -p1
52     %patch1 -p1
53 elmer 1.141 %patch2 -p1
54 elmer 1.148 %patch3 -p1
55     %patch4 -p1
56 eulisse 1.190
57 elmer 1.149 %patch5 -p1
58 eulisse 1.190 %patch6 -p1
59     %patch7 -p1
60     %patch8 -p1
61     %patch9 -p1
62    
63     # patch10 is compiler version dependent, see below
64     %patch11 -p1
65     %patch12 -p1
66     # patch13 is compiler version dependent, see below
67    
68     # work around patch issue...
69     rm graf3d/gl/src/gl2ps.c
70     %patch14 -p1
71     #work around patch issues in patch14(?)
72     rm graf3d/eve/inc/TEveLegoOverlay.h.orig
73     rm graf3d/eve/src/TEveLegoOverlay.cxx
74     rm graf3d/gl/inc/gl2ps.h.orig
75     rm graf3d/gl/src/gl2ps.c.orig
76     %patch15 -p1
77     %patch16 -p1
78     %patch17 -p1
79     %patch19 -p1
80     %patch20 -p1
81    
82     case %gccver in
83     4.3.*)
84     %patch13 -p1
85     ;;
86     4.4.*)
87     %patch10 -p1
88     ;;
89     esac
90    
91     # The following patch can only be applied on SLC5 or later (extra linker
92     # options only available with the SLC5 binutils)
93     case %cmsplatf in
94     slc5_* | slc5onl_* )
95     %patch18 -p1
96     ;;
97     esac
98 elmer 1.185
99 eulisse 1.1 %build
100 andreasp 1.163
101 eulisse 1.1 mkdir -p %i
102 elmer 1.14 export ROOTSYS=%_builddir/root
103 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
104 dlange 1.103
105 muzaffar 1.164 %if "%online" == "true"
106 elmer 1.181 # Use system qt. Also skip xrootd and odbc for online case:
107 ratnik 1.111
108 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
109 ratnik 1.111 --disable-xrootd
110     --disable-odbc
111 muzaffar 1.164 --disable-qt --disable-qtgsi"
112 dlange 1.103 %else
113 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
114 elmer 1.145 --with-xrootd=$XROOTD_ROOT
115 ratnik 1.106 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
116     --with-ssl-incdir=${OPENSSL_ROOT}/include
117 muzaffar 1.164 --with-ssl-libdir=${OPENSSL_ROOT}/lib
118     --enable-qtgsi"
119 dlange 1.103 %endif
120    
121 muzaffar 1.164 CONFIG_ARGS="--enable-table
122 eulisse 1.20 --disable-builtin-pcre
123     --disable-builtin-freetype
124     --disable-builtin-zlib
125 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
126 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
127 eulisse 1.2 --enable-explicitlink
128 eulisse 1.20 --enable-mathmore
129 eulisse 1.2 --enable-reflex
130     --enable-cintex
131     --enable-minuit2
132 elmer 1.98 --disable-ldap
133 gowdy 1.143 --disable-krb5
134 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
135     --with-gsl-libdir=${GSL_ROOT}/lib
136 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
137 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
138     --disable-pgsql
139 elmer 1.181 --disable-mysql
140 elmer 1.187 --disable-xml ${EXTRA_CONFIG_ARGS}"
141 elmer 1.98
142 elmer 1.183 case $(uname)-$(uname -m) in
143 eulisse 1.2 Linux-x86_64)
144 elmer 1.141 ./configure linuxx8664gcc $CONFIG_ARGS --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift --disable-astiff;;
145 elmer 1.54 Linux-i*86)
146 dlange 1.110 ./configure linux $CONFIG_ARGS --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift;;
147 elmer 1.11 Darwin*)
148 dsr 1.191 case %cmsplatf in
149     *_ia32_* )
150     comparch=i386 ;;
151     *_amd64_* )
152     comparch=x86_64 ;;
153     * )
154     comparch=ppc ;;
155     esac
156     export CC="gcc -arch $comparch" CXX="g++ -arch $comparch"
157     ./configure macosx $CONFIG_ARGS --with-cc="$CC" --with-cxx="$CXX" --disable-rfio --disable-builtin_afterimage ;;
158 elmer 1.54 Linux-ppc64*)
159 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
160 eulisse 1.1 esac
161 eulisse 1.2
162 eulisse 1.147 case %cmsplatf in
163     osx*)
164     makeopts=
165     ;;
166     *)
167     makeopts="%makeprocesses"
168     ;;
169     esac
170    
171     make $makeopts
172 eulisse 1.20 make cintdlls
173 eulisse 1.147
174 eulisse 1.1 %install
175     # Override installers if we are using GNU fileutils cp. On OS X
176     # ROOT's INSTALL is defined to "cp -pPR", which only works with
177     # the system cp (/bin/cp). If you have fileutils on fink, you
178     # lose. Check which one is getting picked up and select syntax
179     # accordingly. (FIXME: do we need to check that -P is accepted?)
180     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
181     cp="cp -dpR"
182     else
183     cp="cp -pPR"
184     fi
185    
186 dlange 1.57 export ROOTSYS=%i
187 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
188 dlange 1.57 mkdir -p $ROOTSYS/lib/python
189 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python
190 eulisse 1.35 #
191 elmer 1.98
192     # SCRAM ToolBox toolfile
193     mkdir -p %i/etc/scram.d
194     # rootcore toolfile
195 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcore.xml
196     <tool name="rootcore" version="%v">
197     <info url="http://root.cern.ch/root/"/>
198     <lib name="Tree"/>
199     <lib name="Net"/>
200     <lib name="Thread"/>
201     <lib name="MathCore"/>
202     <lib name="RIO"/>
203     <lib name="Core"/>
204     <lib name="Cint"/>
205     <client>
206     <environment name="ROOTCORE_BASE" default="%i"/>
207     <environment name="LIBDIR" default="$ROOTCORE_BASE/lib"/>
208     <environment name="INCLUDE" default="$ROOTCORE_BASE/include"/>
209     <environment name="INCLUDE" default="$ROOTCORE_BASE/cint"/>
210     </client>
211     <runtime name="PATH" value="$ROOTCORE_BASE/bin" type="path"/>
212     <runtime name="ROOTSYS" value="$ROOTCORE_BASE/"/>
213     <runtime name="PYTHONPATH" value="$ROOTCORE_BASE/lib" type="path"/>
214     <use name="sockets"/>
215     <use name="pcre"/>
216     <use name="zlib"/>
217     </tool>
218 elmer 1.98 EOF_TOOLFILE
219    
220 elmer 1.121 # root toolfile, alias for rootphysics. Using rootphysics is preferred.
221 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/root.xml
222     <tool name="root" version="%v">
223     <info url="http://root.cern.ch/root/"/>
224     <use name="rootphysics"/>
225     </tool>
226 elmer 1.121 EOF_TOOLFILE
227    
228     # roothistmatrix toolfile
229 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/roothistmatrix.xml
230     <tool name="roothistmatrix" version="%v">
231     <info url="http://root.cern.ch/root/"/>
232     <lib name="Hist"/>
233     <lib name="Matrix"/>
234     <use name="ROOTCore"/>
235     </tool>
236 elmer 1.121 EOF_TOOLFILE
237    
238 muzaffar 1.158 # rootgpad toolfile
239 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgpad.xml
240     <tool name="rootgpad" version="%v">
241     <info url="http://root.cern.ch/root/"/>
242     <lib name="Gpad"/>
243     <lib name="Graf"/>
244     <use name="roothistmatrix"/>
245     </tool>
246 muzaffar 1.158 EOF_TOOLFILE
247    
248 elmer 1.121 # rootphysics toolfile
249 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootphysics.xml
250     <tool name="rootphysics" version="%v">
251     <info url="http://root.cern.ch/root/"/>
252     <lib name="Physics"/>
253     <use name="roothistmatrix"/>
254     </tool>
255 elmer 1.98 EOF_TOOLFILE
256    
257 elmer 1.121 # rootgraphics toolfile, identical to old "root" toolfile
258 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgraphics.xml
259     <tool name="rootgraphics" version="%v">
260     <info url="http://root.cern.ch/root/"/>
261     <lib name="TreePlayer"/>
262     <lib name="Graf3d"/>
263     <lib name="Postscript"/>
264     <use name="rootgpad"/>
265     </tool>
266 elmer 1.120 EOF_TOOLFILE
267    
268 elmer 1.98 # rootcintex toolfile
269 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcintex.xml
270     <tool name="rootcintex" version="%v">
271     <info url="http://root.cern.ch/root/"/>
272     <lib name="Cintex"/>
273     <use name="ROOTRflx"/>
274     <use name="ROOTCore"/>
275     </tool>
276 elmer 1.98 EOF_TOOLFILE
277    
278 eulisse 1.189 # rootinteractive toolfile (GQt/qt lib dependencies
279     # have been moved to rootqt.xml)
280 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootinteractive.xml
281     <tool name="rootinteractive" version="%v">
282     <info url="http://root.cern.ch/root/"/>
283     <lib name="Rint"/>
284     <lib name="Gui"/>
285     <use name="libjpg"/>
286     <use name="libpng"/>
287     <use name="rootgpad"/>
288     </tool>
289 elmer 1.146 EOF_TOOLFILE
290    
291 eulisse 1.189 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootqt.xml
292     <tool name="rootqt" version="%v">
293     <info url="http://root.cern.ch/root/"/>
294     <lib name="GQt"/>
295     <use name="qt"/>
296     </tool>
297     EOF_TOOLFILE
298    
299 elmer 1.98 # rootmath toolfile
300 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmath.xml
301     <tool name="rootmath" version="%v">
302     <info url="http://root.cern.ch/root/"/>
303     <lib name="GenVector"/>
304     <lib name="MathMore"/>
305     <use name="ROOTCore"/>
306     <use name="gsl"/>
307     </tool>
308 elmer 1.98 EOF_TOOLFILE
309    
310     # rootminuit toolfile
311 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit.xml
312     <tool name="rootminuit" version="%v">
313     <info url="http://root.cern.ch/root/"/>
314     <lib name="Minuit"/>
315     <use name="rootgpad"/>
316     </tool>
317 elmer 1.98 EOF_TOOLFILE
318    
319     # rootminuit2 toolfile
320 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit2.xml
321     <tool name="rootminuit2" version="%v">
322     <info url="http://root.cern.ch/root/"/>
323     <lib name="Minuit2"/>
324     <use name="rootgpad"/>
325     </tool>
326 elmer 1.98 EOF_TOOLFILE
327    
328     # rootrflx toolfile
329 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrflx.xml
330     <tool name="rootrflx" version="%v">
331     <info url="http://root.cern.ch/root/"/>
332     <lib name="Reflex"/>
333     <client>
334     <environment name="ROOTRFLX_BASE" default="%i"/>
335     <environment name="LIBDIR" default="$ROOTRFLX_BASE/lib"/>
336     <environment name="INCLUDE" default="$ROOTRFLX_BASE/include"/>
337     </client>
338     <runtime name="PATH" value="$ROOTRFLX_BASE/bin" type="path"/>
339     <runtime name="ROOTSYS" value="$ROOTRFLX_BASE/"/>
340     <runtime name="GENREFLEX" value="$ROOTRFLX_BASE/bin/genreflex"/>
341     <use name="sockets"/>
342     <use name="gccxml"/>
343     </tool>
344 elmer 1.98 EOF_TOOLFILE
345    
346     # roothtml toolfile
347 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/roothtml.xml
348     <tool name="roothtml" version="%v">
349     <info url="http://root.cern.ch/root/"/>
350     <lib name="Html"/>
351     <use name="rootgpad"/>
352     </tool>
353 elmer 1.98 EOF_TOOLFILE
354    
355     # rootmlp toolfile
356 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmlp.xml
357     <tool name="rootmlp" version="%v">
358     <info url="http://root.cern.ch/root/"/>
359     <lib name="MLP"/>
360     <use name="RootGraphics"/>
361     </tool>
362 elmer 1.98 EOF_TOOLFILE
363    
364     # roottmva toolfile
365 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/roottmva.xml
366     <tool name="roottmva" version="%v">
367     <info url="http://root.cern.ch/root/"/>
368     <lib name="TMVA"/>
369     <use name="ROOTMLP"/>
370     <use name="rootminuit"/>
371     </tool>
372 elmer 1.98 EOF_TOOLFILE
373    
374     # rootthread toolfile
375 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootthread.xml
376     <tool name="rootthread" version="%v">
377     <info url="http://root.cern.ch/root/"/>
378     <use name="ROOTCore"/>
379     </tool>
380 elmer 1.98 EOF_TOOLFILE
381    
382     %post
383 muzaffar 1.184 perl -p -i -e "s|%{instroot}|$RPM_INSTALL_PREFIX|g" $(find $RPM_INSTALL_PREFIX/%pkgrel/etc/scram.d -type f)