ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.193
Committed: Mon Mar 29 11:21:08 2010 UTC (15 years, 1 month ago) by elmer
Branch: MAIN
Changes since 1.192: +2 -2 lines
Log Message:
Drop the SMatrix Offsets patch. It should no longer be needed for gcc4x.

File Contents

# User Rev Content
1 eulisse 1.190 ### RPM lcg root 5.22.00d
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.177 ## INITENV SET ROOTSYS %i
4 ratnik 1.106 #Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz
5 elmer 1.144 Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
6 muzaffar 1.165 %define closingbrace )
7 elmer 1.179 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
8 elmer 1.96
9 elmer 1.155 Patch0: root-5.18-00-libpng
10 eulisse 1.190 Patch1: root-5.21-04-CINT-maxlongline
11     Patch2: root-5.22-00-TMVA-shut-the-hell-up-for-once
12     Patch3: root-5.22-00a-TMVA-shut-the-hell-up-again
13     Patch4: root-5.22-00d-fireworks-graf3d-gui
14     Patch5: root-5.22-00a-roofit-silence-static-printout
15     Patch6: root-5.22-00a-TMVA-just-shut-the-hell-up
16     Patch7: root-5.22-00a-th1
17 elmer 1.193 # patch 8 was dropped
18 eulisse 1.190 Patch9: root-5.22-00a-fireworks1
19     Patch10: root-5.22-00a-gcc44
20     Patch11: root-5.22-00a-fireworks2
21     Patch12: root-5.22-00a-fireworks3
22     Patch13: root-5.22-00a-gcc43-array-bounds-dictionary-workaround
23     Patch14: root-5.22-00a-fireworks4
24     Patch15: root-5.22-00d-fireworks5
25     Patch16: root-5.22-00d-genreflex_python26_popen3
26     Patch17: root-5.22-00d-fireworks6
27     Patch18: root-5.22-00d-linker-gnu-hash-style
28     Patch19: root-5.22-00d-TFile-version3-Init
29     Patch20: root-5.22-00d-cint-namespace
30 elmer 1.192 Patch21: root-5.22-00d-fireworks7
31 elmer 1.98
32     %define cpu %(echo %cmsplatf | cut -d_ -f2)
33    
34 ratnik 1.106 Requires: gccxml gsl castor libjpg dcap pcre python
35 dlange 1.103
36 muzaffar 1.164 %if "%online" != "true"
37 elmer 1.181 Requires: qt openssl libpng zlib libungif xrootd
38 dlange 1.103 %else
39     %define skiplibtiff true
40     %endif
41    
42     %if "%cpu" == "amd64"
43     %define skiplibtiff true
44     %endif
45    
46     %if "%skiplibtiff" != "true"
47 elmer 1.98 Requires: libtiff
48     %endif
49 eulisse 1.25
50 eulisse 1.1 %prep
51     %setup -n root
52 ratnik 1.106 %patch0 -p1
53     %patch1 -p1
54 elmer 1.141 %patch2 -p1
55 elmer 1.148 %patch3 -p1
56     %patch4 -p1
57 eulisse 1.190
58 elmer 1.149 %patch5 -p1
59 eulisse 1.190 %patch6 -p1
60     %patch7 -p1
61 elmer 1.193 # patch 8 was dropped
62 eulisse 1.190 %patch9 -p1
63    
64     # patch10 is compiler version dependent, see below
65     %patch11 -p1
66     %patch12 -p1
67     # patch13 is compiler version dependent, see below
68    
69     # work around patch issue...
70     rm graf3d/gl/src/gl2ps.c
71     %patch14 -p1
72     #work around patch issues in patch14(?)
73     rm graf3d/eve/inc/TEveLegoOverlay.h.orig
74     rm graf3d/eve/src/TEveLegoOverlay.cxx
75     rm graf3d/gl/inc/gl2ps.h.orig
76     rm graf3d/gl/src/gl2ps.c.orig
77     %patch15 -p1
78     %patch16 -p1
79     %patch17 -p1
80     %patch19 -p1
81     %patch20 -p1
82 elmer 1.192 %patch21 -p1
83 eulisse 1.190
84     case %gccver in
85     4.3.*)
86     %patch13 -p1
87     ;;
88     4.4.*)
89     %patch10 -p1
90     ;;
91     esac
92    
93     # The following patch can only be applied on SLC5 or later (extra linker
94     # options only available with the SLC5 binutils)
95     case %cmsplatf in
96     slc5_* | slc5onl_* )
97     %patch18 -p1
98     ;;
99     esac
100 elmer 1.185
101 eulisse 1.1 %build
102 andreasp 1.163
103 eulisse 1.1 mkdir -p %i
104 elmer 1.14 export ROOTSYS=%_builddir/root
105 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
106 dlange 1.103
107 muzaffar 1.164 %if "%online" == "true"
108 elmer 1.181 # Use system qt. Also skip xrootd and odbc for online case:
109 ratnik 1.111
110 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
111 ratnik 1.111 --disable-xrootd
112     --disable-odbc
113 muzaffar 1.164 --disable-qt --disable-qtgsi"
114 dlange 1.103 %else
115 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
116 elmer 1.145 --with-xrootd=$XROOTD_ROOT
117 ratnik 1.106 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
118     --with-ssl-incdir=${OPENSSL_ROOT}/include
119 muzaffar 1.164 --with-ssl-libdir=${OPENSSL_ROOT}/lib
120     --enable-qtgsi"
121 dlange 1.103 %endif
122    
123 muzaffar 1.164 CONFIG_ARGS="--enable-table
124 eulisse 1.20 --disable-builtin-pcre
125     --disable-builtin-freetype
126     --disable-builtin-zlib
127 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
128 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
129 eulisse 1.2 --enable-explicitlink
130 eulisse 1.20 --enable-mathmore
131 eulisse 1.2 --enable-reflex
132     --enable-cintex
133     --enable-minuit2
134 elmer 1.98 --disable-ldap
135 gowdy 1.143 --disable-krb5
136 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
137     --with-gsl-libdir=${GSL_ROOT}/lib
138 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
139 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
140     --disable-pgsql
141 elmer 1.181 --disable-mysql
142 elmer 1.187 --disable-xml ${EXTRA_CONFIG_ARGS}"
143 elmer 1.98
144 elmer 1.183 case $(uname)-$(uname -m) in
145 eulisse 1.2 Linux-x86_64)
146 elmer 1.141 ./configure linuxx8664gcc $CONFIG_ARGS --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift --disable-astiff;;
147 elmer 1.54 Linux-i*86)
148 dlange 1.110 ./configure linux $CONFIG_ARGS --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift;;
149 elmer 1.11 Darwin*)
150 dsr 1.191 case %cmsplatf in
151     *_ia32_* )
152     comparch=i386 ;;
153     *_amd64_* )
154     comparch=x86_64 ;;
155     * )
156     comparch=ppc ;;
157     esac
158     export CC="gcc -arch $comparch" CXX="g++ -arch $comparch"
159     ./configure macosx $CONFIG_ARGS --with-cc="$CC" --with-cxx="$CXX" --disable-rfio --disable-builtin_afterimage ;;
160 elmer 1.54 Linux-ppc64*)
161 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
162 eulisse 1.1 esac
163 eulisse 1.2
164 eulisse 1.147 case %cmsplatf in
165     osx*)
166     makeopts=
167     ;;
168     *)
169     makeopts="%makeprocesses"
170     ;;
171     esac
172    
173     make $makeopts
174 eulisse 1.20 make cintdlls
175 eulisse 1.147
176 eulisse 1.1 %install
177     # Override installers if we are using GNU fileutils cp. On OS X
178     # ROOT's INSTALL is defined to "cp -pPR", which only works with
179     # the system cp (/bin/cp). If you have fileutils on fink, you
180     # lose. Check which one is getting picked up and select syntax
181     # accordingly. (FIXME: do we need to check that -P is accepted?)
182     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
183     cp="cp -dpR"
184     else
185     cp="cp -pPR"
186     fi
187    
188 dlange 1.57 export ROOTSYS=%i
189 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
190 dlange 1.57 mkdir -p $ROOTSYS/lib/python
191 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python
192 eulisse 1.35 #
193 elmer 1.98
194     # SCRAM ToolBox toolfile
195     mkdir -p %i/etc/scram.d
196     # rootcore toolfile
197 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcore.xml
198     <tool name="rootcore" version="%v">
199     <info url="http://root.cern.ch/root/"/>
200     <lib name="Tree"/>
201     <lib name="Net"/>
202     <lib name="Thread"/>
203     <lib name="MathCore"/>
204     <lib name="RIO"/>
205     <lib name="Core"/>
206     <lib name="Cint"/>
207     <client>
208     <environment name="ROOTCORE_BASE" default="%i"/>
209     <environment name="LIBDIR" default="$ROOTCORE_BASE/lib"/>
210     <environment name="INCLUDE" default="$ROOTCORE_BASE/include"/>
211     <environment name="INCLUDE" default="$ROOTCORE_BASE/cint"/>
212     </client>
213     <runtime name="PATH" value="$ROOTCORE_BASE/bin" type="path"/>
214     <runtime name="ROOTSYS" value="$ROOTCORE_BASE/"/>
215     <runtime name="PYTHONPATH" value="$ROOTCORE_BASE/lib" type="path"/>
216     <use name="sockets"/>
217     <use name="pcre"/>
218     <use name="zlib"/>
219     </tool>
220 elmer 1.98 EOF_TOOLFILE
221    
222 elmer 1.121 # root toolfile, alias for rootphysics. Using rootphysics is preferred.
223 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/root.xml
224     <tool name="root" version="%v">
225     <info url="http://root.cern.ch/root/"/>
226     <use name="rootphysics"/>
227     </tool>
228 elmer 1.121 EOF_TOOLFILE
229    
230     # roothistmatrix toolfile
231 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/roothistmatrix.xml
232     <tool name="roothistmatrix" version="%v">
233     <info url="http://root.cern.ch/root/"/>
234     <lib name="Hist"/>
235     <lib name="Matrix"/>
236     <use name="ROOTCore"/>
237     </tool>
238 elmer 1.121 EOF_TOOLFILE
239    
240 muzaffar 1.158 # rootgpad toolfile
241 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgpad.xml
242     <tool name="rootgpad" version="%v">
243     <info url="http://root.cern.ch/root/"/>
244     <lib name="Gpad"/>
245     <lib name="Graf"/>
246     <use name="roothistmatrix"/>
247     </tool>
248 muzaffar 1.158 EOF_TOOLFILE
249    
250 elmer 1.121 # rootphysics toolfile
251 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootphysics.xml
252     <tool name="rootphysics" version="%v">
253     <info url="http://root.cern.ch/root/"/>
254     <lib name="Physics"/>
255     <use name="roothistmatrix"/>
256     </tool>
257 elmer 1.98 EOF_TOOLFILE
258    
259 elmer 1.121 # rootgraphics toolfile, identical to old "root" toolfile
260 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgraphics.xml
261     <tool name="rootgraphics" version="%v">
262     <info url="http://root.cern.ch/root/"/>
263     <lib name="TreePlayer"/>
264     <lib name="Graf3d"/>
265     <lib name="Postscript"/>
266     <use name="rootgpad"/>
267     </tool>
268 elmer 1.120 EOF_TOOLFILE
269    
270 elmer 1.98 # rootcintex toolfile
271 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcintex.xml
272     <tool name="rootcintex" version="%v">
273     <info url="http://root.cern.ch/root/"/>
274     <lib name="Cintex"/>
275     <use name="ROOTRflx"/>
276     <use name="ROOTCore"/>
277     </tool>
278 elmer 1.98 EOF_TOOLFILE
279    
280 eulisse 1.189 # rootinteractive toolfile (GQt/qt lib dependencies
281     # have been moved to rootqt.xml)
282 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootinteractive.xml
283     <tool name="rootinteractive" version="%v">
284     <info url="http://root.cern.ch/root/"/>
285     <lib name="Rint"/>
286     <lib name="Gui"/>
287     <use name="libjpg"/>
288     <use name="libpng"/>
289     <use name="rootgpad"/>
290     </tool>
291 elmer 1.146 EOF_TOOLFILE
292    
293 eulisse 1.189 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootqt.xml
294     <tool name="rootqt" version="%v">
295     <info url="http://root.cern.ch/root/"/>
296     <lib name="GQt"/>
297     <use name="qt"/>
298     </tool>
299     EOF_TOOLFILE
300    
301 elmer 1.98 # rootmath toolfile
302 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmath.xml
303     <tool name="rootmath" version="%v">
304     <info url="http://root.cern.ch/root/"/>
305     <lib name="GenVector"/>
306     <lib name="MathMore"/>
307     <use name="ROOTCore"/>
308     <use name="gsl"/>
309     </tool>
310 elmer 1.98 EOF_TOOLFILE
311    
312     # rootminuit toolfile
313 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit.xml
314     <tool name="rootminuit" version="%v">
315     <info url="http://root.cern.ch/root/"/>
316     <lib name="Minuit"/>
317     <use name="rootgpad"/>
318     </tool>
319 elmer 1.98 EOF_TOOLFILE
320    
321     # rootminuit2 toolfile
322 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit2.xml
323     <tool name="rootminuit2" version="%v">
324     <info url="http://root.cern.ch/root/"/>
325     <lib name="Minuit2"/>
326     <use name="rootgpad"/>
327     </tool>
328 elmer 1.98 EOF_TOOLFILE
329    
330     # rootrflx toolfile
331 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrflx.xml
332     <tool name="rootrflx" version="%v">
333     <info url="http://root.cern.ch/root/"/>
334     <lib name="Reflex"/>
335     <client>
336     <environment name="ROOTRFLX_BASE" default="%i"/>
337     <environment name="LIBDIR" default="$ROOTRFLX_BASE/lib"/>
338     <environment name="INCLUDE" default="$ROOTRFLX_BASE/include"/>
339     </client>
340     <runtime name="PATH" value="$ROOTRFLX_BASE/bin" type="path"/>
341     <runtime name="ROOTSYS" value="$ROOTRFLX_BASE/"/>
342     <runtime name="GENREFLEX" value="$ROOTRFLX_BASE/bin/genreflex"/>
343     <use name="sockets"/>
344     <use name="gccxml"/>
345     </tool>
346 elmer 1.98 EOF_TOOLFILE
347    
348     # roothtml toolfile
349 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/roothtml.xml
350     <tool name="roothtml" version="%v">
351     <info url="http://root.cern.ch/root/"/>
352     <lib name="Html"/>
353     <use name="rootgpad"/>
354     </tool>
355 elmer 1.98 EOF_TOOLFILE
356    
357     # rootmlp toolfile
358 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmlp.xml
359     <tool name="rootmlp" version="%v">
360     <info url="http://root.cern.ch/root/"/>
361     <lib name="MLP"/>
362     <use name="RootGraphics"/>
363     </tool>
364 elmer 1.98 EOF_TOOLFILE
365    
366     # roottmva toolfile
367 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/roottmva.xml
368     <tool name="roottmva" version="%v">
369     <info url="http://root.cern.ch/root/"/>
370     <lib name="TMVA"/>
371     <use name="ROOTMLP"/>
372     <use name="rootminuit"/>
373     </tool>
374 elmer 1.98 EOF_TOOLFILE
375    
376     # rootthread toolfile
377 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootthread.xml
378     <tool name="rootthread" version="%v">
379     <info url="http://root.cern.ch/root/"/>
380     <use name="ROOTCore"/>
381     </tool>
382 elmer 1.98 EOF_TOOLFILE
383    
384     %post
385 muzaffar 1.184 perl -p -i -e "s|%{instroot}|$RPM_INSTALL_PREFIX|g" $(find $RPM_INSTALL_PREFIX/%pkgrel/etc/scram.d -type f)