ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.197
Committed: Tue May 11 23:28:21 2010 UTC (14 years, 11 months ago) by elmer
Branch: MAIN
Changes since 1.196: +2 -8 lines
Log Message:
  Update to version 5.27/02

File Contents

# User Rev Content
1 elmer 1.197 ### RPM lcg root 5.27.02
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.177 ## INITENV SET ROOTSYS %i
4 ratnik 1.106 #Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz
5 elmer 1.144 Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
6 muzaffar 1.165 %define closingbrace )
7 elmer 1.179 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
8 elmer 1.96
9 elmer 1.196 Patch0: root-5.18-00-libpng
10     Patch1: root-5.22-00-TMVA-shut-the-hell-up-for-once
11     Patch2: root-5.22-00a-roofit-silence-static-printout
12     Patch3: root-5.22-00d-linker-gnu-hash-style
13     Patch4: root-5.26-00a-CINT-maxlongline
14     Patch5: root-5.26-00a-silence-TMVA
15 elmer 1.197 Patch6: root-5.22-00d-TBranchElement-dropped-data-member
16 elmer 1.98
17     %define cpu %(echo %cmsplatf | cut -d_ -f2)
18    
19 ratnik 1.106 Requires: gccxml gsl castor libjpg dcap pcre python
20 dlange 1.103
21 muzaffar 1.164 %if "%online" != "true"
22 elmer 1.181 Requires: qt openssl libpng zlib libungif xrootd
23 dlange 1.103 %else
24     %define skiplibtiff true
25     %endif
26    
27     %if "%cpu" == "amd64"
28     %define skiplibtiff true
29     %endif
30    
31     %if "%skiplibtiff" != "true"
32 elmer 1.98 Requires: libtiff
33     %endif
34 eulisse 1.25
35 eulisse 1.1 %prep
36     %setup -n root
37 ratnik 1.106 %patch0 -p1
38     %patch1 -p1
39 elmer 1.141 %patch2 -p1
40 elmer 1.148 %patch3 -p1
41     %patch4 -p1
42 elmer 1.149 %patch5 -p1
43 eulisse 1.190 %patch6 -p1
44    
45 eulisse 1.1 %build
46 andreasp 1.163
47 eulisse 1.1 mkdir -p %i
48 elmer 1.14 export ROOTSYS=%_builddir/root
49 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
50 dlange 1.103
51 muzaffar 1.164 %if "%online" == "true"
52 elmer 1.181 # Use system qt. Also skip xrootd and odbc for online case:
53 ratnik 1.111
54 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
55 ratnik 1.111 --disable-xrootd
56     --disable-odbc
57 muzaffar 1.164 --disable-qt --disable-qtgsi"
58 dlange 1.103 %else
59 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
60 elmer 1.145 --with-xrootd=$XROOTD_ROOT
61 ratnik 1.106 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
62     --with-ssl-incdir=${OPENSSL_ROOT}/include
63 muzaffar 1.164 --with-ssl-libdir=${OPENSSL_ROOT}/lib
64     --enable-qtgsi"
65 dlange 1.103 %endif
66    
67 muzaffar 1.164 CONFIG_ARGS="--enable-table
68 eulisse 1.20 --disable-builtin-pcre
69     --disable-builtin-freetype
70     --disable-builtin-zlib
71 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
72 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
73 eulisse 1.2 --enable-explicitlink
74 eulisse 1.20 --enable-mathmore
75 eulisse 1.2 --enable-reflex
76     --enable-cintex
77     --enable-minuit2
78 elmer 1.98 --disable-ldap
79 gowdy 1.143 --disable-krb5
80 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
81     --with-gsl-libdir=${GSL_ROOT}/lib
82 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
83 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
84     --disable-pgsql
85 elmer 1.181 --disable-mysql
86 elmer 1.187 --disable-xml ${EXTRA_CONFIG_ARGS}"
87 elmer 1.98
88 elmer 1.183 case $(uname)-$(uname -m) in
89 eulisse 1.2 Linux-x86_64)
90 elmer 1.141 ./configure linuxx8664gcc $CONFIG_ARGS --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift --disable-astiff;;
91 elmer 1.54 Linux-i*86)
92 dlange 1.110 ./configure linux $CONFIG_ARGS --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift;;
93 elmer 1.11 Darwin*)
94 elmer 1.196 ./configure macosx $CONFIG_ARGS --disable-rfio --disable-builtin_afterimage ;;
95 elmer 1.54 Linux-ppc64*)
96 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
97 eulisse 1.1 esac
98 eulisse 1.2
99 eulisse 1.147 case %cmsplatf in
100     osx*)
101     makeopts=
102     ;;
103     *)
104     makeopts="%makeprocesses"
105     ;;
106     esac
107    
108     make $makeopts
109 eulisse 1.20 make cintdlls
110 eulisse 1.147
111 eulisse 1.1 %install
112     # Override installers if we are using GNU fileutils cp. On OS X
113     # ROOT's INSTALL is defined to "cp -pPR", which only works with
114     # the system cp (/bin/cp). If you have fileutils on fink, you
115     # lose. Check which one is getting picked up and select syntax
116     # accordingly. (FIXME: do we need to check that -P is accepted?)
117     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
118     cp="cp -dpR"
119     else
120     cp="cp -pPR"
121     fi
122    
123 dlange 1.57 export ROOTSYS=%i
124 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
125 dlange 1.57 mkdir -p $ROOTSYS/lib/python
126 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python
127 eulisse 1.35 #
128 elmer 1.98
129     # SCRAM ToolBox toolfile
130     mkdir -p %i/etc/scram.d
131     # rootcore toolfile
132 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcore.xml
133     <tool name="rootcore" version="%v">
134     <info url="http://root.cern.ch/root/"/>
135     <lib name="Tree"/>
136     <lib name="Net"/>
137     <lib name="Thread"/>
138     <lib name="MathCore"/>
139     <lib name="RIO"/>
140     <lib name="Core"/>
141     <lib name="Cint"/>
142     <client>
143     <environment name="ROOTCORE_BASE" default="%i"/>
144     <environment name="LIBDIR" default="$ROOTCORE_BASE/lib"/>
145     <environment name="INCLUDE" default="$ROOTCORE_BASE/include"/>
146     <environment name="INCLUDE" default="$ROOTCORE_BASE/cint"/>
147     </client>
148     <runtime name="PATH" value="$ROOTCORE_BASE/bin" type="path"/>
149     <runtime name="ROOTSYS" value="$ROOTCORE_BASE/"/>
150     <runtime name="PYTHONPATH" value="$ROOTCORE_BASE/lib" type="path"/>
151     <use name="sockets"/>
152     <use name="pcre"/>
153     <use name="zlib"/>
154     </tool>
155 elmer 1.98 EOF_TOOLFILE
156    
157 elmer 1.121 # root toolfile, alias for rootphysics. Using rootphysics is preferred.
158 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/root.xml
159     <tool name="root" version="%v">
160     <info url="http://root.cern.ch/root/"/>
161     <use name="rootphysics"/>
162     </tool>
163 elmer 1.121 EOF_TOOLFILE
164    
165     # roothistmatrix toolfile
166 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/roothistmatrix.xml
167     <tool name="roothistmatrix" version="%v">
168     <info url="http://root.cern.ch/root/"/>
169     <lib name="Hist"/>
170     <lib name="Matrix"/>
171     <use name="ROOTCore"/>
172     </tool>
173 elmer 1.121 EOF_TOOLFILE
174    
175 muzaffar 1.158 # rootgpad toolfile
176 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgpad.xml
177     <tool name="rootgpad" version="%v">
178     <info url="http://root.cern.ch/root/"/>
179     <lib name="Gpad"/>
180     <lib name="Graf"/>
181     <use name="roothistmatrix"/>
182     </tool>
183 muzaffar 1.158 EOF_TOOLFILE
184    
185 elmer 1.121 # rootphysics toolfile
186 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootphysics.xml
187     <tool name="rootphysics" version="%v">
188     <info url="http://root.cern.ch/root/"/>
189     <lib name="Physics"/>
190     <use name="roothistmatrix"/>
191     </tool>
192 elmer 1.98 EOF_TOOLFILE
193    
194 elmer 1.121 # rootgraphics toolfile, identical to old "root" toolfile
195 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgraphics.xml
196     <tool name="rootgraphics" version="%v">
197     <info url="http://root.cern.ch/root/"/>
198     <lib name="TreePlayer"/>
199     <lib name="Graf3d"/>
200     <lib name="Postscript"/>
201     <use name="rootgpad"/>
202     </tool>
203 elmer 1.120 EOF_TOOLFILE
204    
205 elmer 1.98 # rootcintex toolfile
206 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcintex.xml
207     <tool name="rootcintex" version="%v">
208     <info url="http://root.cern.ch/root/"/>
209     <lib name="Cintex"/>
210     <use name="ROOTRflx"/>
211     <use name="ROOTCore"/>
212     </tool>
213 elmer 1.98 EOF_TOOLFILE
214    
215 eulisse 1.189 # rootinteractive toolfile (GQt/qt lib dependencies
216     # have been moved to rootqt.xml)
217 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootinteractive.xml
218     <tool name="rootinteractive" version="%v">
219     <info url="http://root.cern.ch/root/"/>
220     <lib name="Rint"/>
221     <lib name="Gui"/>
222     <use name="libjpg"/>
223     <use name="libpng"/>
224     <use name="rootgpad"/>
225     </tool>
226 elmer 1.146 EOF_TOOLFILE
227    
228 eulisse 1.189 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootqt.xml
229     <tool name="rootqt" version="%v">
230     <info url="http://root.cern.ch/root/"/>
231     <lib name="GQt"/>
232     <use name="qt"/>
233     </tool>
234     EOF_TOOLFILE
235    
236 elmer 1.98 # rootmath toolfile
237 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmath.xml
238     <tool name="rootmath" version="%v">
239     <info url="http://root.cern.ch/root/"/>
240     <lib name="GenVector"/>
241     <lib name="MathMore"/>
242     <use name="ROOTCore"/>
243     <use name="gsl"/>
244     </tool>
245 elmer 1.98 EOF_TOOLFILE
246    
247     # rootminuit toolfile
248 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit.xml
249     <tool name="rootminuit" version="%v">
250     <info url="http://root.cern.ch/root/"/>
251     <lib name="Minuit"/>
252     <use name="rootgpad"/>
253     </tool>
254 elmer 1.98 EOF_TOOLFILE
255    
256     # rootminuit2 toolfile
257 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit2.xml
258     <tool name="rootminuit2" version="%v">
259     <info url="http://root.cern.ch/root/"/>
260     <lib name="Minuit2"/>
261     <use name="rootgpad"/>
262     </tool>
263 elmer 1.98 EOF_TOOLFILE
264    
265     # rootrflx toolfile
266 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrflx.xml
267     <tool name="rootrflx" version="%v">
268     <info url="http://root.cern.ch/root/"/>
269     <lib name="Reflex"/>
270     <client>
271     <environment name="ROOTRFLX_BASE" default="%i"/>
272     <environment name="LIBDIR" default="$ROOTRFLX_BASE/lib"/>
273     <environment name="INCLUDE" default="$ROOTRFLX_BASE/include"/>
274     </client>
275     <runtime name="PATH" value="$ROOTRFLX_BASE/bin" type="path"/>
276     <runtime name="ROOTSYS" value="$ROOTRFLX_BASE/"/>
277     <runtime name="GENREFLEX" value="$ROOTRFLX_BASE/bin/genreflex"/>
278     <use name="sockets"/>
279     <use name="gccxml"/>
280     </tool>
281 elmer 1.98 EOF_TOOLFILE
282    
283     # roothtml toolfile
284 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/roothtml.xml
285     <tool name="roothtml" version="%v">
286     <info url="http://root.cern.ch/root/"/>
287     <lib name="Html"/>
288     <use name="rootgpad"/>
289     </tool>
290 elmer 1.98 EOF_TOOLFILE
291    
292     # rootmlp toolfile
293 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmlp.xml
294     <tool name="rootmlp" version="%v">
295     <info url="http://root.cern.ch/root/"/>
296     <lib name="MLP"/>
297     <use name="RootGraphics"/>
298     </tool>
299 elmer 1.98 EOF_TOOLFILE
300    
301     # roottmva toolfile
302 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/roottmva.xml
303     <tool name="roottmva" version="%v">
304     <info url="http://root.cern.ch/root/"/>
305     <lib name="TMVA"/>
306     <use name="ROOTMLP"/>
307     <use name="rootminuit"/>
308     </tool>
309 elmer 1.98 EOF_TOOLFILE
310    
311     # rootthread toolfile
312 muzaffar 1.184 cat << \EOF_TOOLFILE >%i/etc/scram.d/rootthread.xml
313     <tool name="rootthread" version="%v">
314     <info url="http://root.cern.ch/root/"/>
315     <use name="ROOTCore"/>
316     </tool>
317 elmer 1.98 EOF_TOOLFILE
318    
319     %post
320 muzaffar 1.184 perl -p -i -e "s|%{instroot}|$RPM_INSTALL_PREFIX|g" $(find $RPM_INSTALL_PREFIX/%pkgrel/etc/scram.d -type f)