ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.203
Committed: Wed Aug 11 13:04:10 2010 UTC (14 years, 8 months ago) by muzaffar
Branch: MAIN
CVS Tags: pe20100830c-for39Xrb, pe20100830b-for39Xrb, pe20100830a-for39Xrb, pe20100829a-for39Xrb, pe20100827a-for39Xrb, pe20100826a-for39Xrb, pe20100825b-for39Xrb, pe20100825a-for39Xrb, pe20100824c-for39Xrb, pe20100824b-for39Xrb, pe20100824a-for39Xrb
Changes since 1.202: +5 -210 lines
Log Message:
sync to latest changes plus added fix-python-shebang and RootsysOnMac root patches

File Contents

# User Rev Content
1 elmer 1.198 ### RPM lcg root 5.22.00d
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.198 ## INITENV SET ROOTSYS %i
4 ratnik 1.106 #Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz
5 elmer 1.144 Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
6 muzaffar 1.165 %define closingbrace )
7 elmer 1.179 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
8 elmer 1.96
9 muzaffar 1.203 Patch0: root-5.22-00d-externals
10 elmer 1.198 Patch1: root-5.22-00d-CINT-maxlongline-maxtypedef
11     Patch2: root-5.22-00-TMVA-shut-the-hell-up-for-once
12     Patch3: root-5.22-00a-TMVA-shut-the-hell-up-again
13     Patch4: root-5.22-00d-fireworks-graf3d-gui
14     Patch5: root-5.22-00a-roofit-silence-static-printout
15     Patch6: root-5.22-00a-TMVA-just-shut-the-hell-up
16     Patch7: root-5.22-00a-th1
17     Patch8: root-5.22-00d-makelib-ldl
18     Patch9: root-5.22-00a-fireworks1
19     Patch10: root-5.22-00a-gcc44
20     Patch11: root-5.22-00a-fireworks2
21     Patch12: root-5.22-00a-fireworks3
22     Patch13: root-5.22-00a-gcc43-array-bounds-dictionary-workaround
23     Patch14: root-5.22-00a-fireworks4
24     Patch15: root-5.22-00d-fireworks5
25     Patch16: root-5.22-00d-genreflex_python26_popen3
26     Patch17: root-5.22-00d-fireworks6
27     Patch18: root-5.22-00d-linker-gnu-hash-style
28     Patch19: root-5.22-00d-TFile-version3-Init
29     Patch20: root-5.22-00d-cint-namespace
30     Patch21: root-5.22-00d-fireworks7
31     Patch22: root-5.22-00d-TMath-Vavilov
32     Patch23: root-5.22-00d-TBranchElement-dropped-data-member
33 elmer 1.199 Patch24: root-5.22-00d-fireworks8
34 muzaffar 1.202 Patch25: root-5.22-00d-fix-python-shebang
35     Patch26: root-5.22-00d-RootsysOnMac
36 elmer 1.98
37     %define cpu %(echo %cmsplatf | cut -d_ -f2)
38    
39 ratnik 1.106 Requires: gccxml gsl castor libjpg dcap pcre python
40 muzaffar 1.164 %if "%online" != "true"
41 muzaffar 1.203 Requires: qt openssl libpng zlib libungif xrootd libtiff
42 elmer 1.98 %endif
43 eulisse 1.25
44 eulisse 1.1 %prep
45     %setup -n root
46 ratnik 1.106 %patch0 -p1
47     %patch1 -p1
48 elmer 1.141 %patch2 -p1
49 elmer 1.148 %patch3 -p1
50     %patch4 -p1
51 elmer 1.198
52 elmer 1.149 %patch5 -p1
53 eulisse 1.190 %patch6 -p1
54 elmer 1.198 %patch7 -p1
55     %patch8 -p1
56     %patch9 -p1
57    
58     # patch10 is compiler version dependent, see below
59     %patch11 -p1
60     %patch12 -p1
61     # patch13 is compiler version dependent, see below
62    
63     # work around patch issue...
64     rm graf3d/gl/src/gl2ps.c
65     %patch14 -p1
66     #work around patch issues in patch14(?)
67     rm graf3d/eve/inc/TEveLegoOverlay.h.orig
68     rm graf3d/eve/src/TEveLegoOverlay.cxx
69     rm graf3d/gl/inc/gl2ps.h.orig
70     rm graf3d/gl/src/gl2ps.c.orig
71     %patch15 -p1
72     %patch16 -p1
73     %patch17 -p1
74     %patch19 -p1
75     %patch20 -p1
76     %patch21 -p1
77     %patch22 -p1
78     %patch23 -p1
79 elmer 1.199 %patch24 -p1
80 muzaffar 1.202 %patch25 -p1
81     %patch26 -p1
82 elmer 1.198
83     case %gccver in
84     4.3.*)
85     %patch13 -p1
86     ;;
87     4.4.*)
88     %patch10 -p1
89     ;;
90     esac
91    
92     # The following patch can only be applied on SLC5 or later (extra linker
93     # options only available with the SLC5 binutils)
94     case %cmsplatf in
95     slc5_* | slc5onl_* )
96     %patch18 -p1
97     ;;
98     esac
99 eulisse 1.190
100 eulisse 1.1 %build
101 andreasp 1.163
102 eulisse 1.1 mkdir -p %i
103 elmer 1.14 export ROOTSYS=%_builddir/root
104 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
105 dlange 1.103
106 muzaffar 1.164 %if "%online" == "true"
107 elmer 1.181 # Use system qt. Also skip xrootd and odbc for online case:
108 ratnik 1.111
109 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
110 ratnik 1.111 --disable-xrootd
111     --disable-odbc
112 muzaffar 1.203 --disable-qt --disable-qtgsi --disable-astiff"
113 dlange 1.103 %else
114 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
115 elmer 1.145 --with-xrootd=$XROOTD_ROOT
116 ratnik 1.106 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
117     --with-ssl-incdir=${OPENSSL_ROOT}/include
118 muzaffar 1.164 --with-ssl-libdir=${OPENSSL_ROOT}/lib
119     --enable-qtgsi"
120 dlange 1.103 %endif
121    
122 muzaffar 1.164 CONFIG_ARGS="--enable-table
123 eulisse 1.20 --disable-builtin-pcre
124     --disable-builtin-freetype
125     --disable-builtin-zlib
126 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
127 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
128 eulisse 1.2 --enable-explicitlink
129 eulisse 1.20 --enable-mathmore
130 eulisse 1.2 --enable-reflex
131     --enable-cintex
132     --enable-minuit2
133 elmer 1.98 --disable-ldap
134 gowdy 1.143 --disable-krb5
135 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
136     --with-gsl-libdir=${GSL_ROOT}/lib
137 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
138 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
139     --disable-pgsql
140 elmer 1.181 --disable-mysql
141 elmer 1.187 --disable-xml ${EXTRA_CONFIG_ARGS}"
142 elmer 1.98
143 elmer 1.183 case $(uname)-$(uname -m) in
144 eulisse 1.2 Linux-x86_64)
145 muzaffar 1.203 ./configure linuxx8664gcc $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
146 elmer 1.54 Linux-i*86)
147 muzaffar 1.203 ./configure linux $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
148 elmer 1.11 Darwin*)
149 elmer 1.198 case %cmsplatf in
150     *_ia32_* )
151     comparch=i386 ;;
152     *_amd64_* )
153     comparch=x86_64 ;;
154     * )
155     comparch=ppc ;;
156     esac
157     export CC="gcc -arch $comparch" CXX="g++ -arch $comparch"
158     ./configure macosx $CONFIG_ARGS --with-cc="$CC" --with-cxx="$CXX" --disable-rfio --disable-builtin_afterimage ;;
159 elmer 1.54 Linux-ppc64*)
160 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
161 eulisse 1.1 esac
162 eulisse 1.2
163 eulisse 1.147 case %cmsplatf in
164     osx*)
165     makeopts=
166     ;;
167     *)
168     makeopts="%makeprocesses"
169     ;;
170     esac
171    
172     make $makeopts
173 eulisse 1.20 make cintdlls
174 eulisse 1.147
175 eulisse 1.1 %install
176     # Override installers if we are using GNU fileutils cp. On OS X
177     # ROOT's INSTALL is defined to "cp -pPR", which only works with
178     # the system cp (/bin/cp). If you have fileutils on fink, you
179     # lose. Check which one is getting picked up and select syntax
180     # accordingly. (FIXME: do we need to check that -P is accepted?)
181     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
182     cp="cp -dpR"
183     else
184     cp="cp -pPR"
185     fi
186    
187 dlange 1.57 export ROOTSYS=%i
188 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
189 dlange 1.57 mkdir -p $ROOTSYS/lib/python
190 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python