ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.205
Committed: Tue Aug 17 18:25:23 2010 UTC (14 years, 8 months ago) by elmer
Branch: MAIN
CVS Tags: pe20100819a-for390p2r52704, pe20100817a-for390p2r52704
Changes since 1.204: +8 -33 lines
Log Message:
  Remove old, commented patches
  Renumber patches consecutively
  Add 5.27/04 version of "fireworks8" patch (such that it is equivalent to
  "fireworks8" patch applied to ROOT 5.22/00d)

File Contents

# User Rev Content
1 elmer 1.204 ### RPM lcg root 5.27.04
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.198 ## INITENV SET ROOTSYS %i
4 ratnik 1.106 #Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz
5 elmer 1.144 Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
6 muzaffar 1.165 %define closingbrace )
7 elmer 1.179 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
8 elmer 1.96
9 elmer 1.204 Patch0: root-5.18-00-libpng
10     Patch1: root-5.27-04-CINT-maxlongline-maxtypedef
11 elmer 1.205 Patch2: root-5.22-00a-roofit-silence-static-printout
12     Patch3: root-5.22-00d-linker-gnu-hash-style
13     Patch4: root-5.22-00d-TBranchElement-dropped-data-member
14     Patch5: root-5.27-04-fireworks8
15 elmer 1.98
16     %define cpu %(echo %cmsplatf | cut -d_ -f2)
17    
18 ratnik 1.106 Requires: gccxml gsl castor libjpg dcap pcre python
19 muzaffar 1.164 %if "%online" != "true"
20 elmer 1.204 Requires: qt openssl libpng zlib libungif libtiff
21 elmer 1.98 %endif
22 eulisse 1.25
23 eulisse 1.1 %prep
24     %setup -n root
25 ratnik 1.106 %patch0 -p1
26     %patch1 -p1
27 elmer 1.205 %patch2 -p1
28     # patch3 is OS version dependent, see below
29     %patch4 -p1
30 elmer 1.149 %patch5 -p1
31 elmer 1.204
32     # The following patch can only be applied on SLC5 or later (extra linker
33 elmer 1.198 # options only available with the SLC5 binutils)
34     case %cmsplatf in
35     slc5_* | slc5onl_* )
36 elmer 1.205 %patch3 -p1
37 elmer 1.198 ;;
38     esac
39 eulisse 1.190
40 eulisse 1.1 %build
41 andreasp 1.163
42 eulisse 1.1 mkdir -p %i
43 elmer 1.14 export ROOTSYS=%_builddir/root
44 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
45 dlange 1.103
46 muzaffar 1.164 %if "%online" == "true"
47 elmer 1.181 # Use system qt. Also skip xrootd and odbc for online case:
48 ratnik 1.111
49 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
50 ratnik 1.111 --disable-odbc
51 muzaffar 1.203 --disable-qt --disable-qtgsi --disable-astiff"
52 dlange 1.103 %else
53 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
54 ratnik 1.106 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
55     --with-ssl-incdir=${OPENSSL_ROOT}/include
56 muzaffar 1.164 --with-ssl-libdir=${OPENSSL_ROOT}/lib
57     --enable-qtgsi"
58 dlange 1.103 %endif
59    
60 muzaffar 1.164 CONFIG_ARGS="--enable-table
61 eulisse 1.20 --disable-builtin-pcre
62     --disable-builtin-freetype
63     --disable-builtin-zlib
64 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
65 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
66 eulisse 1.2 --enable-explicitlink
67 eulisse 1.20 --enable-mathmore
68 eulisse 1.2 --enable-reflex
69     --enable-cintex
70     --enable-minuit2
71 elmer 1.98 --disable-ldap
72 gowdy 1.143 --disable-krb5
73 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
74     --with-gsl-libdir=${GSL_ROOT}/lib
75 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
76 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
77     --disable-pgsql
78 elmer 1.181 --disable-mysql
79 elmer 1.187 --disable-xml ${EXTRA_CONFIG_ARGS}"
80 elmer 1.98
81 elmer 1.183 case $(uname)-$(uname -m) in
82 eulisse 1.2 Linux-x86_64)
83 muzaffar 1.203 ./configure linuxx8664gcc $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
84 elmer 1.54 Linux-i*86)
85 muzaffar 1.203 ./configure linux $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
86 elmer 1.11 Darwin*)
87 elmer 1.198 case %cmsplatf in
88     *_ia32_* )
89     comparch=i386 ;;
90     *_amd64_* )
91     comparch=x86_64 ;;
92     * )
93     comparch=ppc ;;
94     esac
95     export CC="gcc -arch $comparch" CXX="g++ -arch $comparch"
96     ./configure macosx $CONFIG_ARGS --with-cc="$CC" --with-cxx="$CXX" --disable-rfio --disable-builtin_afterimage ;;
97 elmer 1.54 Linux-ppc64*)
98 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
99 eulisse 1.1 esac
100 eulisse 1.2
101 eulisse 1.147 case %cmsplatf in
102     osx*)
103     makeopts=
104     ;;
105     *)
106     makeopts="%makeprocesses"
107     ;;
108     esac
109    
110     make $makeopts
111 eulisse 1.20 make cintdlls
112 eulisse 1.147
113 eulisse 1.1 %install
114     # Override installers if we are using GNU fileutils cp. On OS X
115     # ROOT's INSTALL is defined to "cp -pPR", which only works with
116     # the system cp (/bin/cp). If you have fileutils on fink, you
117     # lose. Check which one is getting picked up and select syntax
118     # accordingly. (FIXME: do we need to check that -P is accepted?)
119     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
120     cp="cp -dpR"
121     else
122     cp="cp -pPR"
123     fi
124    
125 dlange 1.57 export ROOTSYS=%i
126 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
127 dlange 1.57 mkdir -p $ROOTSYS/lib/python
128 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python
129 elmer 1.204
130     # SCRAM ToolBox toolfile
131     mkdir -p %i/etc/scram.d
132     # rootcore toolfile
133     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcore.xml
134     <tool name="rootcore" version="%v">
135     <info url="http://root.cern.ch/root/"/>
136     <lib name="Tree"/>
137     <lib name="Net"/>
138     <lib name="Thread"/>
139     <lib name="MathCore"/>
140     <lib name="RIO"/>
141     <lib name="Core"/>
142     <lib name="Cint"/>
143     <client>
144     <environment name="ROOTCORE_BASE" default="%i"/>
145     <environment name="LIBDIR" default="$ROOTCORE_BASE/lib"/>
146     <environment name="INCLUDE" default="$ROOTCORE_BASE/include"/>
147     <environment name="INCLUDE" default="$ROOTCORE_BASE/cint"/>
148     </client>
149     <runtime name="PATH" value="$ROOTCORE_BASE/bin" type="path"/>
150     <runtime name="ROOTSYS" value="$ROOTCORE_BASE/"/>
151     <runtime name="PYTHONPATH" value="$ROOTCORE_BASE/lib" type="path"/>
152     <use name="sockets"/>
153     <use name="pcre"/>
154     <use name="zlib"/>
155     </tool>
156     EOF_TOOLFILE
157    
158     # root toolfile, alias for rootphysics. Using rootphysics is preferred.
159     cat << \EOF_TOOLFILE >%i/etc/scram.d/root.xml
160     <tool name="root" version="%v">
161     <info url="http://root.cern.ch/root/"/>
162     <use name="rootphysics"/>
163     </tool>
164     EOF_TOOLFILE
165    
166     # roothistmatrix toolfile
167     cat << \EOF_TOOLFILE >%i/etc/scram.d/roothistmatrix.xml
168     <tool name="roothistmatrix" version="%v">
169     <info url="http://root.cern.ch/root/"/>
170     <lib name="Hist"/>
171     <lib name="Matrix"/>
172     <use name="ROOTCore"/>
173     </tool>
174     EOF_TOOLFILE
175    
176     # rootgpad toolfile
177     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgpad.xml
178     <tool name="rootgpad" version="%v">
179     <info url="http://root.cern.ch/root/"/>
180     <lib name="Gpad"/>
181     <lib name="Graf"/>
182     <use name="roothistmatrix"/>
183     </tool>
184     EOF_TOOLFILE
185    
186     # rootphysics toolfile
187     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootphysics.xml
188     <tool name="rootphysics" version="%v">
189     <info url="http://root.cern.ch/root/"/>
190     <lib name="Physics"/>
191     <use name="roothistmatrix"/>
192     </tool>
193     EOF_TOOLFILE
194    
195     # rootgraphics toolfile, identical to old "root" toolfile
196     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgraphics.xml
197     <tool name="rootgraphics" version="%v">
198     <info url="http://root.cern.ch/root/"/>
199     <lib name="TreePlayer"/>
200     <lib name="Graf3d"/>
201     <lib name="Postscript"/>
202     <use name="rootgpad"/>
203     </tool>
204     EOF_TOOLFILE
205    
206     # rootcintex toolfile
207     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcintex.xml
208     <tool name="rootcintex" version="%v">
209     <info url="http://root.cern.ch/root/"/>
210     <lib name="Cintex"/>
211     <use name="ROOTRflx"/>
212     <use name="ROOTCore"/>
213     </tool>
214     EOF_TOOLFILE
215    
216     # rootinteractive toolfile (GQt/qt lib dependencies
217     # have been moved to rootqt.xml)
218     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootinteractive.xml
219     <tool name="rootinteractive" version="%v">
220     <info url="http://root.cern.ch/root/"/>
221     <lib name="Rint"/>
222     <lib name="Gui"/>
223     <use name="libjpg"/>
224     <use name="libpng"/>
225     <use name="rootgpad"/>
226     </tool>
227     EOF_TOOLFILE
228    
229     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootqt.xml
230     <tool name="rootqt" version="%v">
231     <info url="http://root.cern.ch/root/"/>
232     <lib name="GQt"/>
233     <use name="qt"/>
234     </tool>
235     EOF_TOOLFILE
236    
237     # rootmath toolfile
238     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmath.xml
239     <tool name="rootmath" version="%v">
240     <info url="http://root.cern.ch/root/"/>
241     <lib name="GenVector"/>
242     <lib name="MathMore"/>
243     <use name="ROOTCore"/>
244     <use name="gsl"/>
245     </tool>
246     EOF_TOOLFILE
247    
248     # rootminuit toolfile
249     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit.xml
250     <tool name="rootminuit" version="%v">
251     <info url="http://root.cern.ch/root/"/>
252     <lib name="Minuit"/>
253     <use name="rootgpad"/>
254     </tool>
255     EOF_TOOLFILE
256    
257     # rootminuit2 toolfile
258     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit2.xml
259     <tool name="rootminuit2" version="%v">
260     <info url="http://root.cern.ch/root/"/>
261     <lib name="Minuit2"/>
262     <use name="rootgpad"/>
263     </tool>
264     EOF_TOOLFILE
265    
266     # rootrflx toolfile
267     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrflx.xml
268     <tool name="rootrflx" version="%v">
269     <info url="http://root.cern.ch/root/"/>
270     <lib name="Reflex"/>
271     <client>
272     <environment name="ROOTRFLX_BASE" default="%i"/>
273     <environment name="LIBDIR" default="$ROOTRFLX_BASE/lib"/>
274     <environment name="INCLUDE" default="$ROOTRFLX_BASE/include"/>
275     </client>
276     <runtime name="PATH" value="$ROOTRFLX_BASE/bin" type="path"/>
277     <runtime name="ROOTSYS" value="$ROOTRFLX_BASE/"/>
278     <runtime name="GENREFLEX" value="$ROOTRFLX_BASE/bin/genreflex"/>
279     <use name="sockets"/>
280     <use name="gccxml"/>
281     </tool>
282     EOF_TOOLFILE
283    
284     # roothtml toolfile
285     cat << \EOF_TOOLFILE >%i/etc/scram.d/roothtml.xml
286     <tool name="roothtml" version="%v">
287     <info url="http://root.cern.ch/root/"/>
288     <lib name="Html"/>
289     <use name="rootgpad"/>
290     </tool>
291     EOF_TOOLFILE
292    
293     # rootmlp toolfile
294     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmlp.xml
295     <tool name="rootmlp" version="%v">
296     <info url="http://root.cern.ch/root/"/>
297     <lib name="MLP"/>
298     <use name="RootGraphics"/>
299     </tool>
300     EOF_TOOLFILE
301    
302     # roottmva toolfile
303     cat << \EOF_TOOLFILE >%i/etc/scram.d/roottmva.xml
304     <tool name="roottmva" version="%v">
305     <info url="http://root.cern.ch/root/"/>
306     <lib name="TMVA"/>
307     <use name="ROOTMLP"/>
308     <use name="rootminuit"/>
309     </tool>
310     EOF_TOOLFILE
311    
312     # rootthread toolfile
313     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootthread.xml
314     <tool name="rootthread" version="%v">
315     <info url="http://root.cern.ch/root/"/>
316     <use name="ROOTCore"/>
317     </tool>
318     EOF_TOOLFILE
319    
320     %post
321     perl -p -i -e "s|%{instroot}|$RPM_INSTALL_PREFIX|g" $(find $RPM_INSTALL_PREFIX/%pkgrel/etc/scram.d -type f)
322