ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.235
Committed: Fri Jan 21 12:31:46 2011 UTC (14 years, 3 months ago) by fwyzard
Branch: MAIN
Changes since 1.234: +53 -86 lines
Log Message:
based on r1.233 - do not link oracle/occi

File Contents

# User Rev Content
1 fwyzard 1.235 ### RPM lcg root 5.27.06b
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.198 ## INITENV SET ROOTSYS %i
4 ratnik 1.106 #Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz
5 elmer 1.144 Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
6 muzaffar 1.165 %define closingbrace )
7 elmer 1.179 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
8 fwyzard 1.235 %define ismac %(case %cmsplatf in osx*%closingbrace echo true;; *%closingbrace e
9     cho false;; esac)
10 elmer 1.96
11 fwyzard 1.235 Patch0: root-5.27-06-externals
12     Patch1: root-5.27-04-CINT-maxlongline-maxtypedef
13     Patch2: root-5.22-00a-roofit-silence-static-printout
14     Patch3: root-5.22-00d-linker-gnu-hash-style
15     Patch4: root-5.22-00d-TBranchElement-dropped-data-member
16     Patch5: root-5.27-06-fireworks9
17     Patch6: root-5.27-06b-gdb-backtrace
18     Patch7: root-5.27-06-tmva-DecisionTreeNode
19     Patch8: root-5.27-06b-r36567
20     Patch9: root-5.27-06b-r36572
21     Patch10: root-5.27-06b-r36707
22     Patch11: root-5.27-06b-r36594
23     Patch12: root-5.27-06b-tmva-MethodBase-initvar
24     Patch13: root-5.27-06b-tmva_Event_dynamic_hack
25 elmer 1.98
26     %define cpu %(echo %cmsplatf | cut -d_ -f2)
27    
28 fwyzard 1.229 Requires: gccxml gsl libjpg libpng libtiff libungif pcre python fftw3
29 elmer 1.228
30 fwyzard 1.235 %if "%ismac" != "true"
31 elmer 1.228 Requires: castor dcap
32     %endif
33    
34 fwyzard 1.235 %if "%online" != "true"
35     Requires: openssl zlib xrootd
36 elmer 1.228 %endif
37    
38 fwyzard 1.235 %if "%ismac" == "true"
39     Requires: gfortran-macosx
40     %endif
41    
42     %if "%online" != "true"
43     %if "%ismac" != "true"
44     Requires: qt
45     %endif
46 elmer 1.98 %endif
47 eulisse 1.25
48 eulisse 1.1 %prep
49     %setup -n root
50 ratnik 1.106 %patch0 -p1
51     %patch1 -p1
52 elmer 1.205 %patch2 -p1
53 fwyzard 1.235 # patch3 is OS version dependent, see below
54 elmer 1.205 %patch4 -p1
55 elmer 1.149 %patch5 -p1
56 gowdy 1.219 %patch6 -p1
57     %patch7 -p1
58     %patch8 -p1
59     %patch9 -p1
60 fwyzard 1.235 %patch10 -p1
61 gowdy 1.219 %patch11 -p1
62 elmer 1.222 %patch12 -p1
63 elmer 1.228 %patch13 -p1
64    
65 fwyzard 1.235 # The following patch can only be applied on SLC5 or later (extra linker
66 elmer 1.198 # options only available with the SLC5 binutils)
67     case %cmsplatf in
68     slc5_* | slc5onl_* )
69 fwyzard 1.235 %patch3 -p1
70 elmer 1.198 ;;
71     esac
72 eulisse 1.190
73 fwyzard 1.235 # Delete these (irrelevant) files as the fits appear to confuse rpm on OSX
74     # (It tries to run install_name_tool on them.)
75     rm -fR tutorials/fitsio
76    
77 eulisse 1.1 %build
78 andreasp 1.163
79 eulisse 1.1 mkdir -p %i
80 elmer 1.221 export LIBJPG_ROOT
81 elmer 1.14 export ROOTSYS=%_builddir/root
82 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
83 dlange 1.103
84 muzaffar 1.164 %if "%online" == "true"
85 elmer 1.181 # Use system qt. Also skip xrootd and odbc for online case:
86 ratnik 1.111
87 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
88 ratnik 1.111 --disable-odbc
89 fwyzard 1.235 --disable-qt --disable-qtgsi --disable-astiff"
90 dlange 1.103 %else
91 elmer 1.221 export LIBPNG_ROOT ZLIB_ROOT LIBTIFF_ROOT LIBUNGIF_ROOT
92 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
93 ratnik 1.106 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
94     --with-ssl-incdir=${OPENSSL_ROOT}/include
95 muzaffar 1.164 --with-ssl-libdir=${OPENSSL_ROOT}/lib
96     --enable-qtgsi"
97 dlange 1.103 %endif
98    
99 muzaffar 1.164 CONFIG_ARGS="--enable-table
100 eulisse 1.20 --disable-builtin-pcre
101     --disable-builtin-freetype
102     --disable-builtin-zlib
103 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
104 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
105 eulisse 1.2 --enable-explicitlink
106 eulisse 1.20 --enable-mathmore
107 eulisse 1.2 --enable-reflex
108     --enable-cintex
109     --enable-minuit2
110 elmer 1.221 --enable-fftw3
111     --with-fftw3-incdir=${FFTW3_ROOT}/include
112     --with-fftw3-libdir=${FFTW3_ROOT}/lib
113 elmer 1.98 --disable-ldap
114 gowdy 1.143 --disable-krb5
115 fwyzard 1.235 --with-xrootd=${XROOTD_ROOT}
116 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
117     --with-gsl-libdir=${GSL_ROOT}/lib
118 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
119 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
120     --disable-pgsql
121 elmer 1.181 --disable-mysql
122 fwyzard 1.234 --disable-oracle
123 elmer 1.187 --disable-xml ${EXTRA_CONFIG_ARGS}"
124 elmer 1.98
125 elmer 1.183 case $(uname)-$(uname -m) in
126 eulisse 1.2 Linux-x86_64)
127 fwyzard 1.235 ./configure linuxx8664gcc $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
128 elmer 1.54 Linux-i*86)
129 fwyzard 1.235 ./configure linux $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
130 elmer 1.11 Darwin*)
131 elmer 1.198 case %cmsplatf in
132     *_ia32_* )
133 fwyzard 1.235 comparch=i386
134     macconfig=macosx
135     ;;
136 elmer 1.198 *_amd64_* )
137 fwyzard 1.235 comparch=x86_64
138     macconfig=macosx64
139     ;;
140 elmer 1.198 * )
141 fwyzard 1.235 comparch=ppc
142     macconfig=macosx
143     ;;
144 elmer 1.198 esac
145     export CC="gcc -arch $comparch" CXX="g++ -arch $comparch"
146 fwyzard 1.235 ./configure $macconfig $CONFIG_ARGS --with-cc="$CC" --with-cxx="$CXX" --disable-rfio --disable-builtin_afterimage ;;
147 elmer 1.54 Linux-ppc64*)
148 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
149 eulisse 1.1 esac
150 eulisse 1.2
151 eulisse 1.147 case %cmsplatf in
152     osx*)
153     makeopts=
154     ;;
155     *)
156     makeopts="%makeprocesses"
157     ;;
158     esac
159    
160     make $makeopts
161 eulisse 1.20 make cintdlls
162 eulisse 1.147
163 eulisse 1.1 %install
164     # Override installers if we are using GNU fileutils cp. On OS X
165     # ROOT's INSTALL is defined to "cp -pPR", which only works with
166     # the system cp (/bin/cp). If you have fileutils on fink, you
167     # lose. Check which one is getting picked up and select syntax
168     # accordingly. (FIXME: do we need to check that -P is accepted?)
169     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
170     cp="cp -dpR"
171     else
172     cp="cp -pPR"
173     fi
174    
175 dlange 1.57 export ROOTSYS=%i
176 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
177 dlange 1.57 mkdir -p $ROOTSYS/lib/python
178 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python
179 elmer 1.204
180     # SCRAM ToolBox toolfile
181     mkdir -p %i/etc/scram.d
182     # rootcore toolfile
183     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcore.xml
184     <tool name="rootcore" version="%v">
185     <info url="http://root.cern.ch/root/"/>
186     <lib name="Tree"/>
187     <lib name="Net"/>
188     <lib name="Thread"/>
189     <lib name="MathCore"/>
190     <lib name="RIO"/>
191     <lib name="Core"/>
192     <lib name="Cint"/>
193     <client>
194     <environment name="ROOTCORE_BASE" default="%i"/>
195     <environment name="LIBDIR" default="$ROOTCORE_BASE/lib"/>
196     <environment name="INCLUDE" default="$ROOTCORE_BASE/include"/>
197     <environment name="INCLUDE" default="$ROOTCORE_BASE/cint"/>
198     </client>
199     <runtime name="PATH" value="$ROOTCORE_BASE/bin" type="path"/>
200     <runtime name="ROOTSYS" value="$ROOTCORE_BASE/"/>
201     <runtime name="PYTHONPATH" value="$ROOTCORE_BASE/lib" type="path"/>
202     <use name="sockets"/>
203     <use name="pcre"/>
204     <use name="zlib"/>
205     </tool>
206     EOF_TOOLFILE
207    
208     # root toolfile, alias for rootphysics. Using rootphysics is preferred.
209     cat << \EOF_TOOLFILE >%i/etc/scram.d/root.xml
210     <tool name="root" version="%v">
211     <info url="http://root.cern.ch/root/"/>
212     <use name="rootphysics"/>
213     </tool>
214     EOF_TOOLFILE
215    
216     # roothistmatrix toolfile
217     cat << \EOF_TOOLFILE >%i/etc/scram.d/roothistmatrix.xml
218 fwyzard 1.235 <tool name="roothistmatrix" version="%v">
219 elmer 1.204 <info url="http://root.cern.ch/root/"/>
220     <lib name="Hist"/>
221     <lib name="Matrix"/>
222     <use name="ROOTCore"/>
223     </tool>
224     EOF_TOOLFILE
225    
226     # rootgpad toolfile
227     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgpad.xml
228 fwyzard 1.235 <tool name="rootgpad" version="%v">
229 elmer 1.204 <info url="http://root.cern.ch/root/"/>
230     <lib name="Gpad"/>
231     <lib name="Graf"/>
232     <use name="roothistmatrix"/>
233     </tool>
234     EOF_TOOLFILE
235    
236     # rootphysics toolfile
237     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootphysics.xml
238     <tool name="rootphysics" version="%v">
239     <info url="http://root.cern.ch/root/"/>
240     <lib name="Physics"/>
241     <use name="roothistmatrix"/>
242     </tool>
243     EOF_TOOLFILE
244    
245     # rootgraphics toolfile, identical to old "root" toolfile
246     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootgraphics.xml
247     <tool name="rootgraphics" version="%v">
248     <info url="http://root.cern.ch/root/"/>
249     <lib name="TreePlayer"/>
250     <lib name="Graf3d"/>
251     <lib name="Postscript"/>
252     <use name="rootgpad"/>
253     </tool>
254     EOF_TOOLFILE
255    
256     # rootcintex toolfile
257     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcintex.xml
258     <tool name="rootcintex" version="%v">
259     <info url="http://root.cern.ch/root/"/>
260     <lib name="Cintex"/>
261     <use name="ROOTRflx"/>
262     <use name="ROOTCore"/>
263     </tool>
264     EOF_TOOLFILE
265    
266     # rootinteractive toolfile (GQt/qt lib dependencies
267     # have been moved to rootqt.xml)
268     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootinteractive.xml
269     <tool name="rootinteractive" version="%v">
270     <info url="http://root.cern.ch/root/"/>
271     <lib name="Rint"/>
272     <lib name="Gui"/>
273     <use name="libjpg"/>
274     <use name="libpng"/>
275     <use name="rootgpad"/>
276     </tool>
277     EOF_TOOLFILE
278    
279     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootqt.xml
280     <tool name="rootqt" version="%v">
281     <info url="http://root.cern.ch/root/"/>
282     <lib name="GQt"/>
283     <use name="qt"/>
284     </tool>
285     EOF_TOOLFILE
286    
287     # rootmath toolfile
288     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmath.xml
289     <tool name="rootmath" version="%v">
290     <info url="http://root.cern.ch/root/"/>
291     <lib name="GenVector"/>
292     <lib name="MathMore"/>
293     <use name="ROOTCore"/>
294     <use name="gsl"/>
295     </tool>
296     EOF_TOOLFILE
297    
298     # rootminuit toolfile
299     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit.xml
300     <tool name="rootminuit" version="%v">
301     <info url="http://root.cern.ch/root/"/>
302     <lib name="Minuit"/>
303     <use name="rootgpad"/>
304     </tool>
305     EOF_TOOLFILE
306    
307     # rootminuit2 toolfile
308     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit2.xml
309     <tool name="rootminuit2" version="%v">
310     <info url="http://root.cern.ch/root/"/>
311     <lib name="Minuit2"/>
312     <use name="rootgpad"/>
313     </tool>
314     EOF_TOOLFILE
315    
316     # rootrflx toolfile
317     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrflx.xml
318     <tool name="rootrflx" version="%v">
319     <info url="http://root.cern.ch/root/"/>
320     <lib name="Reflex"/>
321     <client>
322     <environment name="ROOTRFLX_BASE" default="%i"/>
323     <environment name="LIBDIR" default="$ROOTRFLX_BASE/lib"/>
324     <environment name="INCLUDE" default="$ROOTRFLX_BASE/include"/>
325     </client>
326     <runtime name="PATH" value="$ROOTRFLX_BASE/bin" type="path"/>
327     <runtime name="ROOTSYS" value="$ROOTRFLX_BASE/"/>
328     <runtime name="GENREFLEX" value="$ROOTRFLX_BASE/bin/genreflex"/>
329     <use name="sockets"/>
330     <use name="gccxml"/>
331     </tool>
332     EOF_TOOLFILE
333    
334     # roothtml toolfile
335     cat << \EOF_TOOLFILE >%i/etc/scram.d/roothtml.xml
336     <tool name="roothtml" version="%v">
337     <info url="http://root.cern.ch/root/"/>
338     <lib name="Html"/>
339     <use name="rootgpad"/>
340     </tool>
341     EOF_TOOLFILE
342    
343     # rootmlp toolfile
344     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmlp.xml
345     <tool name="rootmlp" version="%v">
346     <info url="http://root.cern.ch/root/"/>
347     <lib name="MLP"/>
348     <use name="RootGraphics"/>
349     </tool>
350     EOF_TOOLFILE
351    
352     # roottmva toolfile
353     cat << \EOF_TOOLFILE >%i/etc/scram.d/roottmva.xml
354     <tool name="roottmva" version="%v">
355     <info url="http://root.cern.ch/root/"/>
356     <lib name="TMVA"/>
357     <use name="ROOTMLP"/>
358     <use name="rootminuit"/>
359     </tool>
360     EOF_TOOLFILE
361    
362     # rootthread toolfile
363     cat << \EOF_TOOLFILE >%i/etc/scram.d/rootthread.xml
364     <tool name="rootthread" version="%v">
365     <info url="http://root.cern.ch/root/"/>
366     <use name="ROOTCore"/>
367     </tool>
368     EOF_TOOLFILE
369    
370     %post
371     perl -p -i -e "s|%{instroot}|$RPM_INSTALL_PREFIX|g" $(find $RPM_INSTALL_PREFIX/%pkgrel/etc/scram.d -type f)
372 fwyzard 1.235