ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.267
Committed: Fri Jun 10 15:44:32 2011 UTC (13 years, 10 months ago) by muzaffar
Branch: MAIN
CVS Tags: sm20110614b-44X-ports, sm20110614b-44X, sm20110614a-44X-ports, sm20110614a-44X, sm20110614-44X-ports, sm20110614-44X, sm20110610-44X-ports, sm20110610-44X
Changes since 1.266: +4 -0 lines
Log Message:
added buffer management and virtual function out of line patch

File Contents

# User Rev Content
1 muzaffar 1.266 ### RPM lcg root 5.28.00d
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.198 ## INITENV SET ROOTSYS %i
4 ratnik 1.106 #Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz
5 elmer 1.144 Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
6 muzaffar 1.165 %define closingbrace )
7 elmer 1.179 %define online %(case %cmsplatf in *onl_*_*%closingbrace echo true;; *%closingbrace echo false;; esac)
8 elmer 1.251 %define ismac %(case %cmsplatf in osx*%closingbrace echo true;; *%closingbrace echo false;; esac)
9 elmer 1.96
10 muzaffar 1.266 Patch0: root-5.28-00d-externals
11     Patch1: root-5.28-00d-CINT-maxlongline-maxtypedef
12     Patch2: root-5.28-00d-roofit-silence-static-printout
13     Patch3: root-5.28-00d-linker-gnu-hash-style
14     Patch4: root-5.28-00d-TBranchElement-dropped-data-member
15     Patch5: root-5.28-00d-r37582-tmva
16     Patch6: root-5.28-00d-TTreeCache-r37919
17     Patch7: root-5.28-00d-r38248-r38259-r38264-r38265-r38267
18     Patch8: root-5.28-00d-fireworks1
19     Patch9: root-5.28-00d-r39155
20 muzaffar 1.267 Patch10: root-5.28-00d-r39525
21     Patch11: root-5.28-00d-r39657
22 elmer 1.239
23 elmer 1.98 %define cpu %(echo %cmsplatf | cut -d_ -f2)
24    
25 fwyzard 1.229 Requires: gccxml gsl libjpg libpng libtiff libungif pcre python fftw3
26 elmer 1.228
27 fwyzard 1.235 %if "%ismac" != "true"
28 elmer 1.228 Requires: castor dcap
29     %endif
30    
31 fwyzard 1.235 %if "%online" != "true"
32     Requires: openssl zlib xrootd
33 elmer 1.228 %endif
34    
35 fwyzard 1.235 %if "%ismac" == "true"
36     Requires: gfortran-macosx
37     %endif
38    
39 eulisse 1.1 %prep
40     %setup -n root
41 ratnik 1.106 %patch0 -p1
42     %patch1 -p1
43 elmer 1.205 %patch2 -p1
44 fwyzard 1.235 # patch3 is OS version dependent, see below
45 elmer 1.205 %patch4 -p1
46 elmer 1.149 %patch5 -p1
47 gowdy 1.219 %patch6 -p1
48     %patch7 -p1
49     %patch8 -p1
50     %patch9 -p1
51 muzaffar 1.267 %patch10 -p1
52     %patch11 -p0
53 elmer 1.228
54 fwyzard 1.235 # The following patch can only be applied on SLC5 or later (extra linker
55 elmer 1.198 # options only available with the SLC5 binutils)
56     case %cmsplatf in
57     slc5_* | slc5onl_* )
58 fwyzard 1.235 %patch3 -p1
59 elmer 1.198 ;;
60     esac
61 eulisse 1.190
62 fwyzard 1.235 # Delete these (irrelevant) files as the fits appear to confuse rpm on OSX
63     # (It tries to run install_name_tool on them.)
64     rm -fR tutorials/fitsio
65    
66 eulisse 1.1 %build
67 andreasp 1.163
68 eulisse 1.1 mkdir -p %i
69 elmer 1.221 export LIBJPG_ROOT
70 elmer 1.14 export ROOTSYS=%_builddir/root
71 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
72 dlange 1.103
73 muzaffar 1.164 %if "%online" == "true"
74 elmer 1.256 # Also skip xrootd and odbc for online case:
75 ratnik 1.111
76 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
77 elmer 1.256 --disable-odbc --disable-astiff"
78 dlange 1.103 %else
79 elmer 1.221 export LIBPNG_ROOT ZLIB_ROOT LIBTIFF_ROOT LIBUNGIF_ROOT
80 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
81 ratnik 1.106 --with-ssl-incdir=${OPENSSL_ROOT}/include
82 elmer 1.256 --with-ssl-libdir=${OPENSSL_ROOT}/lib"
83 dlange 1.103 %endif
84    
85 muzaffar 1.164 CONFIG_ARGS="--enable-table
86 eulisse 1.20 --disable-builtin-pcre
87     --disable-builtin-freetype
88     --disable-builtin-zlib
89 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
90 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
91 eulisse 1.2 --enable-explicitlink
92 eulisse 1.20 --enable-mathmore
93 eulisse 1.2 --enable-reflex
94     --enable-cintex
95     --enable-minuit2
96 elmer 1.221 --enable-fftw3
97     --with-fftw3-incdir=${FFTW3_ROOT}/include
98     --with-fftw3-libdir=${FFTW3_ROOT}/lib
99 elmer 1.98 --disable-ldap
100 gowdy 1.143 --disable-krb5
101 fwyzard 1.235 --with-xrootd=${XROOTD_ROOT}
102 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
103     --with-gsl-libdir=${GSL_ROOT}/lib
104 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
105 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
106     --disable-pgsql
107 elmer 1.181 --disable-mysql
108 elmer 1.256 --disable-qt --disable-qtgsi
109 elmer 1.242 --disable-oracle ${EXTRA_CONFIG_ARGS}"
110 elmer 1.98
111 eulisse 1.236 case %cmsos in
112     slc*_amd64)
113 fwyzard 1.235 ./configure linuxx8664gcc $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
114 eulisse 1.236 slc*_ia32)
115 fwyzard 1.235 ./configure linux $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
116 eulisse 1.236 osx*)
117 elmer 1.198 case %cmsplatf in
118     *_ia32_* )
119 fwyzard 1.235 comparch=i386
120     macconfig=macosx
121     ;;
122 elmer 1.198 *_amd64_* )
123 fwyzard 1.235 comparch=x86_64
124     macconfig=macosx64
125     ;;
126 elmer 1.198 * )
127 fwyzard 1.235 comparch=ppc
128     macconfig=macosx
129     ;;
130 elmer 1.198 esac
131 eulisse 1.236 export CC=`which gcc` CXX=`which g++`
132     ./configure $arch $CONFIG_ARGS --with-cc="$CC" --with-cxx="$CXX" --disable-rfio --disable-builtin_afterimage ;;
133     slc*_ppc64*)
134 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
135 eulisse 1.1 esac
136 eulisse 1.2
137 elmer 1.243 makeopts="%makeprocesses"
138 eulisse 1.236
139     make $makeopts
140 eulisse 1.147
141 eulisse 1.1 %install
142     # Override installers if we are using GNU fileutils cp. On OS X
143     # ROOT's INSTALL is defined to "cp -pPR", which only works with
144     # the system cp (/bin/cp). If you have fileutils on fink, you
145     # lose. Check which one is getting picked up and select syntax
146     # accordingly. (FIXME: do we need to check that -P is accepted?)
147     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
148     cp="cp -dpR"
149     else
150     cp="cp -pPR"
151     fi
152    
153 dlange 1.57 export ROOTSYS=%i
154 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
155 dlange 1.57 mkdir -p $ROOTSYS/lib/python
156 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python
157 eulisse 1.236 # This file confuses rpm's find-requires because it starts with
158     # a """ and it thinks is the shebang.
159     rm -f %i/tutorials/pyroot/mrt.py
160 elmer 1.204
161 fwyzard 1.235