ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.273
Committed: Thu Jun 23 21:53:57 2011 UTC (13 years, 10 months ago) by fwyzard
Branch: MAIN
Changes since 1.272: +34 -80 lines
Log Message:
revert to 1.271; add xroot asdependency also for online builds

File Contents

# User Rev Content
1 fwyzard 1.273 ### RPM lcg root 5.30.00-rc2
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.198 ## INITENV SET ROOTSYS %i
4 fwyzard 1.273 #Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
5     %define svntag %(echo %realversion | tr . -)
6     Source: svn://root.cern.ch/svn/root/tags/v%{svntag}/?scheme=http&strategy=export&module=%n-%{realversion}&output=/%n-%{realversion}.tgz
7     %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
8     %define ismac %(case %cmsplatf in (osx*) echo true;; (*) echo false;; esac)
9    
10     Patch0: root-5.28-00d-externals
11     Patch1: root-5.28-00d-CINT-maxlongline-maxtypedef
12     Patch2: root-5.28-00d-roofit-silence-static-printout
13     Patch3: root-5.28-00d-linker-gnu-hash-style
14     Patch4: root-5.28-00d-TBranchElement-dropped-data-member
15     Patch5: root-5.28-00d-r37582-tmva
16     #Patch6: root-5.28-00d-TTreeCache-r37919
17     #Patch7: root-5.28-00d-r38248-r38259-r38264-r38265-r38267
18     #Patch8: root-5.28-00d-fireworks1
19     #Patch9: root-5.28-00d-r39155
20     #Patch10: root-5.28-00d-r39525
21     #Patch11: root-5.28-00d-r39657
22     #Patch12: root-5.28-00d-r39759
23     Patch13: root-5.28-00d-fix-tsystem-load-macosx
24 elmer 1.239
25 elmer 1.98 %define cpu %(echo %cmsplatf | cut -d_ -f2)
26    
27 fwyzard 1.273 Requires: gccxml gsl libjpg libpng libtiff libungif pcre python fftw3 xz xrootd
28 elmer 1.228
29 fwyzard 1.235 %if "%ismac" != "true"
30 elmer 1.228 Requires: castor dcap
31     %endif
32    
33 fwyzard 1.235 %if "%online" != "true"
34 fwyzard 1.272 Requires: openssl zlib
35 elmer 1.228 %endif
36    
37 fwyzard 1.235 %if "%ismac" == "true"
38     Requires: gfortran-macosx
39     %endif
40    
41 eulisse 1.1 %prep
42 fwyzard 1.273 %setup -n root-%realversion
43 ratnik 1.106 %patch0 -p1
44     %patch1 -p1
45 elmer 1.205 %patch2 -p1
46 fwyzard 1.235 # patch3 is OS version dependent, see below
47 elmer 1.205 %patch4 -p1
48 elmer 1.149 %patch5 -p1
49 fwyzard 1.273 # patch6 -p1
50     # patch7 -p1
51     # patch8 -p1
52     # patch9 -p1
53     # patch10 -p1 TRY AGAIN!
54     # patch11 -p0
55     # patch12 -p2
56 gowdy 1.269 %patch13 -p1
57 elmer 1.228
58 fwyzard 1.235 # The following patch can only be applied on SLC5 or later (extra linker
59 elmer 1.198 # options only available with the SLC5 binutils)
60     case %cmsplatf in
61     slc5_* | slc5onl_* )
62 fwyzard 1.235 %patch3 -p1
63 elmer 1.198 ;;
64     esac
65 eulisse 1.190
66 fwyzard 1.235 # Delete these (irrelevant) files as the fits appear to confuse rpm on OSX
67     # (It tries to run install_name_tool on them.)
68     rm -fR tutorials/fitsio
69    
70 eulisse 1.1 %build
71 andreasp 1.163
72 eulisse 1.1 mkdir -p %i
73 elmer 1.221 export LIBJPG_ROOT
74 elmer 1.14 export ROOTSYS=%_builddir/root
75 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
76 dlange 1.103
77 muzaffar 1.164 %if "%online" == "true"
78 elmer 1.256 # Also skip xrootd and odbc for online case:
79 ratnik 1.111
80 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
81 elmer 1.256 --disable-odbc --disable-astiff"
82 dlange 1.103 %else
83 elmer 1.221 export LIBPNG_ROOT ZLIB_ROOT LIBTIFF_ROOT LIBUNGIF_ROOT
84 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
85 ratnik 1.106 --with-ssl-incdir=${OPENSSL_ROOT}/include
86 elmer 1.256 --with-ssl-libdir=${OPENSSL_ROOT}/lib"
87 dlange 1.103 %endif
88    
89 muzaffar 1.164 CONFIG_ARGS="--enable-table
90 eulisse 1.20 --disable-builtin-pcre
91     --disable-builtin-freetype
92     --disable-builtin-zlib
93 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
94 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
95 eulisse 1.2 --enable-explicitlink
96 eulisse 1.20 --enable-mathmore
97 eulisse 1.2 --enable-reflex
98     --enable-cintex
99 fwyzard 1.273 --enable-minuit2
100     --enable-lzma
101     --with-lzma-incdir=${XZ_ROOT}/include
102     --with-lzma-libdir=${XZ_ROOT}/lib
103 elmer 1.221 --enable-fftw3
104     --with-fftw3-incdir=${FFTW3_ROOT}/include
105     --with-fftw3-libdir=${FFTW3_ROOT}/lib
106 elmer 1.98 --disable-ldap
107 gowdy 1.143 --disable-krb5
108 fwyzard 1.235 --with-xrootd=${XROOTD_ROOT}
109 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
110     --with-gsl-libdir=${GSL_ROOT}/lib
111 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
112 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
113     --disable-pgsql
114 elmer 1.181 --disable-mysql
115 elmer 1.256 --disable-qt --disable-qtgsi
116 elmer 1.242 --disable-oracle ${EXTRA_CONFIG_ARGS}"
117 elmer 1.98
118 eulisse 1.236 case %cmsos in
119     slc*_amd64)
120 fwyzard 1.235 ./configure linuxx8664gcc $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
121 eulisse 1.236 slc*_ia32)
122 fwyzard 1.235 ./configure linux $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
123 eulisse 1.236 osx*)
124 elmer 1.198 case %cmsplatf in
125     *_ia32_* )
126 fwyzard 1.235 comparch=i386
127     macconfig=macosx
128     ;;
129 elmer 1.198 *_amd64_* )
130 fwyzard 1.235 comparch=x86_64
131     macconfig=macosx64
132     ;;
133 elmer 1.198 * )
134 fwyzard 1.235 comparch=ppc
135     macconfig=macosx
136     ;;
137 elmer 1.198 esac
138 eulisse 1.236 export CC=`which gcc` CXX=`which g++`
139     ./configure $arch $CONFIG_ARGS --with-cc="$CC" --with-cxx="$CXX" --disable-rfio --disable-builtin_afterimage ;;
140     slc*_ppc64*)
141 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
142 eulisse 1.1 esac
143 eulisse 1.2
144 elmer 1.243 makeopts="%makeprocesses"
145 eulisse 1.236
146     make $makeopts
147 eulisse 1.147
148 eulisse 1.1 %install
149     # Override installers if we are using GNU fileutils cp. On OS X
150     # ROOT's INSTALL is defined to "cp -pPR", which only works with
151     # the system cp (/bin/cp). If you have fileutils on fink, you
152     # lose. Check which one is getting picked up and select syntax
153     # accordingly. (FIXME: do we need to check that -P is accepted?)
154     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
155     cp="cp -dpR"
156     else
157     cp="cp -pPR"
158     fi
159    
160 dlange 1.57 export ROOTSYS=%i
161 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
162 dlange 1.57 mkdir -p $ROOTSYS/lib/python
163 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python
164 eulisse 1.236 # This file confuses rpm's find-requires because it starts with
165     # a """ and it thinks is the shebang.
166     rm -f %i/tutorials/pyroot/mrt.py
167 elmer 1.204
168 fwyzard 1.235