ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.3
Committed: Wed Apr 5 10:23:27 2006 UTC (19 years ago) by eulisse
Branch: MAIN
Changes since 1.2: +1 -1 lines
Log Message:
On par with LCG_42a

File Contents

# User Rev Content
1 eulisse 1.3 ### RPM lcg root 5.10.00b
2 eulisse 1.1 # Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %v | tr . -)&module=root&output=/%{n}_v%{v}.source.tar.gz
3     Source: ftp://root.cern.ch/%n/%{n}_v%{v}.source.tar.gz
4 eulisse 1.2 Requires: gccxml python qt gsl
5 eulisse 1.1 %prep
6     %setup -n root
7    
8     %build
9     mkdir -p %i
10     export ROOTSYS=%i
11 eulisse 1.2 CONFIG_ARGS="--enable-table
12     --with-gccxml=${GCCXML_ROOT}
13     --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include
14     --enable-explicitlink
15     --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
16     --enable-mathcore
17     --enable-reflex
18     --enable-cintex
19     --enable-minuit2
20     --enable-roofit"
21    
22     case $(uname)-$(uname -m) in
23     Linux-x86_64)
24     ./configure linuxx8664gcc $CONFIG_ARGS;;
25     Linux*)
26     ./configure linux $CONFIG_ARGS;;
27 eulisse 1.1 Darwin)
28 eulisse 1.2 ./configure macosx $CONFIG_ARGS;;
29 eulisse 1.1 esac
30 eulisse 1.2
31     make %makeprocesses
32 eulisse 1.1
33     %install
34     # Override installers if we are using GNU fileutils cp. On OS X
35     # ROOT's INSTALL is defined to "cp -pPR", which only works with
36     # the system cp (/bin/cp). If you have fileutils on fink, you
37     # lose. Check which one is getting picked up and select syntax
38     # accordingly. (FIXME: do we need to check that -P is accepted?)
39     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
40     cp="cp -dpR"
41     else
42     cp="cp -pPR"
43     fi
44    
45     export ROOTSYS=%i
46     make INSTALL="$cp" INSTALLDATA="$cp" install