ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.4
Committed: Thu Apr 6 22:46:49 2006 UTC (19 years ago) by eulisse
Branch: MAIN
Changes since 1.3: +3 -1 lines
Log Message:
Uses stefan patch to correctly install reflex.

File Contents

# User Rev Content
1 eulisse 1.3 ### RPM lcg root 5.10.00b
2 eulisse 1.1 # Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %v | tr . -)&module=root&output=/%{n}_v%{v}.source.tar.gz
3     Source: ftp://root.cern.ch/%n/%{n}_v%{v}.source.tar.gz
4 eulisse 1.2 Requires: gccxml python qt gsl
5 eulisse 1.4 Patch0: root
6 eulisse 1.1 %prep
7     %setup -n root
8 eulisse 1.4 %patch0
9 eulisse 1.1
10     %build
11     mkdir -p %i
12     export ROOTSYS=%i
13 eulisse 1.2 CONFIG_ARGS="--enable-table
14     --with-gccxml=${GCCXML_ROOT}
15     --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include
16     --enable-explicitlink
17     --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
18     --enable-mathcore
19     --enable-reflex
20     --enable-cintex
21     --enable-minuit2
22     --enable-roofit"
23    
24     case $(uname)-$(uname -m) in
25     Linux-x86_64)
26     ./configure linuxx8664gcc $CONFIG_ARGS;;
27     Linux*)
28     ./configure linux $CONFIG_ARGS;;
29 eulisse 1.1 Darwin)
30 eulisse 1.2 ./configure macosx $CONFIG_ARGS;;
31 eulisse 1.1 esac
32 eulisse 1.2
33     make %makeprocesses
34 eulisse 1.1
35     %install
36     # Override installers if we are using GNU fileutils cp. On OS X
37     # ROOT's INSTALL is defined to "cp -pPR", which only works with
38     # the system cp (/bin/cp). If you have fileutils on fink, you
39     # lose. Check which one is getting picked up and select syntax
40     # accordingly. (FIXME: do we need to check that -P is accepted?)
41     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
42     cp="cp -dpR"
43     else
44     cp="cp -pPR"
45     fi
46    
47     export ROOTSYS=%i
48 eulisse 1.4 make INSTALL="$cp" INSTALLDATA="$cp" install