ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.49
Committed: Thu Dec 14 10:59:06 2006 UTC (18 years, 4 months ago) by sashby
Branch: MAIN
CVS Tags: CMSSW_1_2_6, CMSSW_1_2_5, CMSSW_1_2_4, CMSSW_1_2_3, for120_g4821, forCMSSW120g482, pe20070208, GE20070207, pe20070205b, pe20070205a, pe20070205, forCMSSW121-slc3, forCMSSW122-slc3, CMSSW_1_3_0_SLC4_pre1, CMSSW_1_3_0_pre1, for143hsv1-slc3-p5, for143hsv1-slc4-p5, for143hsv1-slc3-p4, for143hsv1-slc4-p4, for143hsv1-slc4-p3, for143hsv1-slc3-p3, for143hsv1-slc4-p2, for143hsv1-slc3-p2, for143hsv1-slc3-p1, for143hsv1-slc4, for143hsv1-slc3, for143hsv1, test143f_sv1-slc4, forCMSSW120-slc4, forCMSSW120g481, forCMSSW120-slc3, forCMS143f-slc4, forCMS143f-slc3
Changes since 1.48: +1 -5 lines
Log Message:
ROOT 5.13.04e and new configuration CMS_143f

File Contents

# User Rev Content
1 sashby 1.49 ### RPM lcg root 5.13.04e
2 eulisse 1.5 # INITENV +PATH PYTHONPATH %i/lib/python
3 eulisse 1.29 %define realVersion %(echo %v | cut -d- -f1)
4     Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realVersion | tr . -)&module=root&output=/%{n}_v%{realVersion}.source.tar.gz
5     #Source: ftp://root.cern.ch/%n/%{n}_v%{realVersion}.source.tar.gz
6 eulisse 1.25 %define cpu %(echo %cmsplatf | cut -d_ -f2)
7 eulisse 1.27 %define pythonv %(echo $PYTHON_VERSION | cut -d. -f1,2)
8 sashby 1.43 Requires: gccxml python qt gsl castor openssl mysql libpng libjpg dcap pcre zlib oracle
9 eulisse 1.25
10     %if "%cpu" != "amd64"
11     Requires: libtiff
12     %endif
13    
14 eulisse 1.1 %prep
15     %setup -n root
16     %build
17     mkdir -p %i
18 elmer 1.14 export ROOTSYS=%_builddir/root
19 eulisse 1.25 CONFIG_ARGS="--enable-table
20 eulisse 1.20 --disable-builtin-pcre
21     --disable-builtin-freetype
22     --disable-builtin-zlib
23 eulisse 1.2 --with-gccxml=${GCCXML_ROOT}
24 eulisse 1.28 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python2.4
25 eulisse 1.12 --enable-mysql --with-mysql-libdir=${MYSQL_ROOT}/lib --with-mysql-incdir=${MYSQL_ROOT}/include
26 eulisse 1.24 --enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include
27 eulisse 1.2 --enable-explicitlink
28 eulisse 1.20 --enable-qtgsi
29 eulisse 1.2 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
30     --enable-mathcore
31 eulisse 1.20 --enable-mathmore
32 eulisse 1.2 --enable-reflex
33     --enable-cintex
34     --enable-minuit2
35 eulisse 1.7 --enable-roofit
36     --disable-ldap
37     --disable-krb5
38 sashby 1.43 --with-dcap-libdir=${DCAP_ROOT}/lib
39     --with-dcap-incdir=${DCAP_ROOT}/include
40 eulisse 1.7 --with-ssl-incdir=${OPENSSL_ROOT}/include
41     --with-ssl-libdir=${OPENSSL_ROOT}/lib
42 elmer 1.26 --with-shift-incdir=${CASTOR_ROOT}/include/shift
43 eulisse 1.16 --with-shift-libdir=${CASTOR_ROOT}/lib
44 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
45     --with-gsl-libdir=${GSL_ROOT}/lib
46 eulisse 1.7 --disable-pgsql
47     --disable-xml"
48 eulisse 1.2
49     case $(uname)-$(uname -m) in
50     Linux-x86_64)
51 eulisse 1.25 ./configure linuxx8664gcc $CONFIG_ARGS --disable-astiff;;
52 eulisse 1.2 Linux*)
53     ./configure linux $CONFIG_ARGS;;
54 elmer 1.11 Darwin*)
55 eulisse 1.2 ./configure macosx $CONFIG_ARGS;;
56 eulisse 1.1 esac
57 eulisse 1.2
58 eulisse 1.21 make
59 eulisse 1.20 make cintdlls
60 eulisse 1.1 %install
61     # Override installers if we are using GNU fileutils cp. On OS X
62     # ROOT's INSTALL is defined to "cp -pPR", which only works with
63     # the system cp (/bin/cp). If you have fileutils on fink, you
64     # lose. Check which one is getting picked up and select syntax
65     # accordingly. (FIXME: do we need to check that -P is accepted?)
66     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
67     cp="cp -dpR"
68     else
69     cp="cp -pPR"
70     fi
71    
72 eulisse 1.23 export ROOTSYS=%i/root
73 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
74 eulisse 1.8 mkdir -p %i/root/lib/python
75 eulisse 1.6 cp -r reflex/python/genreflex %i/root/lib/python
76 eulisse 1.35 #