ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.5
Committed: Tue Apr 11 14:52:58 2006 UTC (19 years ago) by eulisse
Branch: MAIN
Changes since 1.4: +4 -1 lines
Log Message:
Copies by hand the reflex/python directory.

File Contents

# User Rev Content
1 eulisse 1.3 ### RPM lcg root 5.10.00b
2 eulisse 1.5 # INITENV +PATH PYTHONPATH %i/lib/python
3 eulisse 1.1 # Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %v | tr . -)&module=root&output=/%{n}_v%{v}.source.tar.gz
4     Source: ftp://root.cern.ch/%n/%{n}_v%{v}.source.tar.gz
5 eulisse 1.2 Requires: gccxml python qt gsl
6 eulisse 1.4 Patch0: root
7 eulisse 1.1 %prep
8     %setup -n root
9 eulisse 1.4 %patch0
10 eulisse 1.1
11     %build
12     mkdir -p %i
13     export ROOTSYS=%i
14 eulisse 1.2 CONFIG_ARGS="--enable-table
15     --with-gccxml=${GCCXML_ROOT}
16     --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include
17     --enable-explicitlink
18     --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
19     --enable-mathcore
20     --enable-reflex
21     --enable-cintex
22     --enable-minuit2
23     --enable-roofit"
24    
25     case $(uname)-$(uname -m) in
26     Linux-x86_64)
27     ./configure linuxx8664gcc $CONFIG_ARGS;;
28     Linux*)
29     ./configure linux $CONFIG_ARGS;;
30 eulisse 1.1 Darwin)
31 eulisse 1.2 ./configure macosx $CONFIG_ARGS;;
32 eulisse 1.1 esac
33 eulisse 1.2
34     make %makeprocesses
35 eulisse 1.1
36     %install
37     # Override installers if we are using GNU fileutils cp. On OS X
38     # ROOT's INSTALL is defined to "cp -pPR", which only works with
39     # the system cp (/bin/cp). If you have fileutils on fink, you
40     # lose. Check which one is getting picked up and select syntax
41     # accordingly. (FIXME: do we need to check that -P is accepted?)
42     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
43     cp="cp -dpR"
44     else
45     cp="cp -pPR"
46     fi
47    
48     export ROOTSYS=%i
49 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
50     mkdir -p %i/lib/python
51     cp -r reflex/python/genreflex %i/lib/python