1 |
dlange |
1.73 |
### RPM lcg root 5.14.00g-CMS11
|
2 |
dlange |
1.57 |
## INITENV +PATH PYTHONPATH %i/lib/python
|
3 |
|
|
## INITENV SET ROOTSYS %i
|
4 |
elmer |
1.59 |
Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz
|
5 |
|
|
#Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
|
6 |
sashby |
1.51 |
|
7 |
dlange |
1.58 |
Patch: root-CINT-maxlongline
|
8 |
dlange |
1.62 |
Patch1: root_libpng
|
9 |
dlange |
1.67 |
Patch2: root_PositionVector
|
10 |
|
|
Patch3: root-fastmerge-ttree
|
11 |
|
|
Patch4: root_TXMLSetup
|
12 |
|
|
Patch5: root-Cintex
|
13 |
dlange |
1.71 |
Patch6: root_Reflex_Cintex
|
14 |
dlange |
1.70 |
Patch7: root_CallFunc
|
15 |
elmer |
1.72 |
Patch8: root-proofd
|
16 |
elmer |
1.63 |
|
17 |
eulisse |
1.25 |
%define cpu %(echo %cmsplatf | cut -d_ -f2)
|
18 |
eulisse |
1.27 |
%define pythonv %(echo $PYTHON_VERSION | cut -d. -f1,2)
|
19 |
elmer |
1.72 |
Requires: gccxml python qt gsl castor openssl mysql libpng libjpg dcap pcre zlib oracle libungif xrootd
|
20 |
eulisse |
1.25 |
|
21 |
|
|
%if "%cpu" != "amd64"
|
22 |
|
|
Requires: libtiff
|
23 |
|
|
%endif
|
24 |
|
|
|
25 |
eulisse |
1.1 |
%prep
|
26 |
|
|
%setup -n root
|
27 |
dlange |
1.58 |
%patch -p0
|
28 |
dlange |
1.62 |
%patch1 -p2
|
29 |
dlange |
1.67 |
%patch2 -p2
|
30 |
|
|
%patch3 -p1
|
31 |
|
|
%patch4 -p0
|
32 |
|
|
%patch5 -p1
|
33 |
dlange |
1.71 |
%patch6 -p0
|
34 |
dlange |
1.70 |
%patch7 -p0
|
35 |
elmer |
1.72 |
%patch8 -p1
|
36 |
dlange |
1.69 |
|
37 |
eulisse |
1.1 |
%build
|
38 |
|
|
mkdir -p %i
|
39 |
elmer |
1.14 |
export ROOTSYS=%_builddir/root
|
40 |
eulisse |
1.25 |
CONFIG_ARGS="--enable-table
|
41 |
eulisse |
1.20 |
--disable-builtin-pcre
|
42 |
|
|
--disable-builtin-freetype
|
43 |
|
|
--disable-builtin-zlib
|
44 |
eulisse |
1.2 |
--with-gccxml=${GCCXML_ROOT}
|
45 |
eulisse |
1.28 |
--enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python2.4
|
46 |
eulisse |
1.12 |
--enable-mysql --with-mysql-libdir=${MYSQL_ROOT}/lib --with-mysql-incdir=${MYSQL_ROOT}/include
|
47 |
eulisse |
1.2 |
--enable-explicitlink
|
48 |
eulisse |
1.20 |
--enable-qtgsi
|
49 |
eulisse |
1.2 |
--enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
|
50 |
|
|
--enable-mathcore
|
51 |
eulisse |
1.20 |
--enable-mathmore
|
52 |
eulisse |
1.2 |
--enable-reflex
|
53 |
|
|
--enable-cintex
|
54 |
|
|
--enable-minuit2
|
55 |
eulisse |
1.7 |
--enable-roofit
|
56 |
|
|
--disable-ldap
|
57 |
|
|
--disable-krb5
|
58 |
|
|
--with-ssl-incdir=${OPENSSL_ROOT}/include
|
59 |
|
|
--with-ssl-libdir=${OPENSSL_ROOT}/lib
|
60 |
eulisse |
1.34 |
--with-gsl-incdir=${GSL_ROOT}/include
|
61 |
|
|
--with-gsl-libdir=${GSL_ROOT}/lib
|
62 |
elmer |
1.59 |
--with-dcap-libdir=${DCAP_ROOT}/lib
|
63 |
|
|
--with-dcap-incdir=${DCAP_ROOT}/include
|
64 |
elmer |
1.72 |
--with-xrootd=$XROOTD_ROOT
|
65 |
eulisse |
1.7 |
--disable-pgsql
|
66 |
|
|
--disable-xml"
|
67 |
eulisse |
1.2 |
|
68 |
elmer |
1.54 |
case $(uname)-$(uname -p) in
|
69 |
eulisse |
1.2 |
Linux-x86_64)
|
70 |
elmer |
1.61 |
./configure linuxx8664gcc $CONFIG_ARGS --enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift --disable-astiff --disable-cern;;
|
71 |
elmer |
1.54 |
Linux-i*86)
|
72 |
|
|
./configure linux $CONFIG_ARGS --enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift;;
|
73 |
elmer |
1.11 |
Darwin*)
|
74 |
elmer |
1.54 |
./configure macosx $CONFIG_ARGS --disable-rfio;;
|
75 |
|
|
Linux-ppc64*)
|
76 |
|
|
./configure linux $CONFIG_ARGS --disable-rfio;;
|
77 |
eulisse |
1.1 |
esac
|
78 |
eulisse |
1.2 |
|
79 |
dlange |
1.57 |
make %makeprocesses
|
80 |
eulisse |
1.20 |
make cintdlls
|
81 |
eulisse |
1.1 |
%install
|
82 |
|
|
# Override installers if we are using GNU fileutils cp. On OS X
|
83 |
|
|
# ROOT's INSTALL is defined to "cp -pPR", which only works with
|
84 |
|
|
# the system cp (/bin/cp). If you have fileutils on fink, you
|
85 |
|
|
# lose. Check which one is getting picked up and select syntax
|
86 |
|
|
# accordingly. (FIXME: do we need to check that -P is accepted?)
|
87 |
|
|
if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
|
88 |
|
|
cp="cp -dpR"
|
89 |
|
|
else
|
90 |
|
|
cp="cp -pPR"
|
91 |
|
|
fi
|
92 |
|
|
|
93 |
dlange |
1.57 |
export ROOTSYS=%i
|
94 |
eulisse |
1.5 |
make INSTALL="$cp" INSTALLDATA="$cp" install
|
95 |
dlange |
1.57 |
mkdir -p $ROOTSYS/lib/python
|
96 |
|
|
cp -r reflex/python/genreflex $ROOTSYS/lib/python
|
97 |
eulisse |
1.35 |
#
|
98 |
dlange |
1.67 |
|
99 |
|
|
# SCRAM ToolBox toolfile
|
100 |
|
|
mkdir -p %i/etc/scram.d
|
101 |
|
|
# rootcore toolfile
|
102 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcore
|
103 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
104 |
|
|
<Tool name=rootcore version=%v>
|
105 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
106 |
|
|
<lib name=Cint>
|
107 |
|
|
<lib name=Core>
|
108 |
|
|
<lib name=Tree>
|
109 |
|
|
<Client>
|
110 |
|
|
<Environment name=ROOTCORE_BASE default="%i"></Environment>
|
111 |
|
|
<Environment name=LIBDIR default="$ROOTCORE_BASE/lib"></Environment>
|
112 |
|
|
<Environment name=INCLUDE default="$ROOTCORE_BASE/include"></Environment>
|
113 |
|
|
<Environment name=INCLUDE default="$ROOTCORE_BASE/cint"></Environment>
|
114 |
|
|
</Client>
|
115 |
|
|
<use name=sockets>
|
116 |
|
|
<use name=pcre>
|
117 |
|
|
<use name=zlib>
|
118 |
|
|
<Runtime name=PATH value="$ROOTCORE_BASE/bin" type=path>
|
119 |
|
|
<Runtime name=ROOTSYS value="$ROOTCORE_BASE/">
|
120 |
|
|
<Runtime name=PYTHONPATH value="$ROOTCORE_BASE/lib" type=path>
|
121 |
|
|
</Tool>
|
122 |
|
|
EOF_TOOLFILE
|
123 |
|
|
|
124 |
|
|
# root toolfile
|
125 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/root
|
126 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
127 |
|
|
<Tool name=root version=%v>
|
128 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
129 |
|
|
<lib name=TreePlayer>
|
130 |
|
|
<lib name=Gpad>
|
131 |
|
|
<lib name=Graf3d>
|
132 |
|
|
<lib name=Graf>
|
133 |
|
|
<lib name=Hist>
|
134 |
|
|
<lib name=Matrix>
|
135 |
|
|
<lib name=Physics>
|
136 |
|
|
<lib name=Postscript>
|
137 |
|
|
<use name=ROOTCore>
|
138 |
|
|
</Tool>
|
139 |
|
|
EOF_TOOLFILE
|
140 |
|
|
|
141 |
|
|
# rootcintex toolfile
|
142 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootcintex
|
143 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
144 |
|
|
<Tool name=rootcintex version=%v>
|
145 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
146 |
|
|
<lib name=Cintex>
|
147 |
|
|
<use name=ROOTRflx>
|
148 |
|
|
<use name=ROOTCore>
|
149 |
|
|
</Tool>
|
150 |
|
|
EOF_TOOLFILE
|
151 |
|
|
|
152 |
|
|
# rootinteractive toolfile
|
153 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootinteractive
|
154 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
155 |
|
|
<Tool name=rootinteractive version=%v>
|
156 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
157 |
|
|
<lib name=Rint>
|
158 |
|
|
<lib name=GQt>
|
159 |
|
|
<use name=qt>
|
160 |
|
|
<use name=libjpg>
|
161 |
|
|
<use name=libpng>
|
162 |
|
|
<use name=ROOT>
|
163 |
|
|
</Tool>
|
164 |
|
|
EOF_TOOLFILE
|
165 |
|
|
|
166 |
|
|
# rootmath toolfile
|
167 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmath
|
168 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
169 |
|
|
<Tool name=rootmath version=%v>
|
170 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
171 |
|
|
<lib name=MathCore>
|
172 |
|
|
<lib name=MathMore>
|
173 |
|
|
<use name=ROOTCore>
|
174 |
|
|
<use name=gsl>
|
175 |
|
|
</Tool>
|
176 |
|
|
EOF_TOOLFILE
|
177 |
|
|
|
178 |
|
|
# rootminuit toolfile
|
179 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit
|
180 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
181 |
|
|
<Tool name=rootminuit version=%v>
|
182 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
183 |
|
|
<lib name=Minuit>
|
184 |
|
|
<use name=ROOT>
|
185 |
|
|
</Tool>
|
186 |
|
|
EOF_TOOLFILE
|
187 |
|
|
|
188 |
|
|
# rootminuit2 toolfile
|
189 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootminuit2
|
190 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
191 |
|
|
<Tool name=rootminuit2 version=%v>
|
192 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
193 |
|
|
<lib name=Minuit2>
|
194 |
|
|
<use name=ROOT>
|
195 |
|
|
</Tool>
|
196 |
|
|
EOF_TOOLFILE
|
197 |
|
|
|
198 |
|
|
# rootrflx toolfile
|
199 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootrflx
|
200 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
201 |
|
|
<Tool name=rootrflx version=%v>
|
202 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
203 |
|
|
<lib name=Reflex>
|
204 |
|
|
<Client>
|
205 |
|
|
<Environment name=ROOTRFLX_BASE default="%i"></Environment>
|
206 |
|
|
<Environment name=LIBDIR default="$ROOTRFLX_BASE/lib"></Environment>
|
207 |
|
|
<Environment name=INCLUDE default="$ROOTRFLX_BASE/include"></Environment>
|
208 |
|
|
</Client>
|
209 |
|
|
<use name=sockets>
|
210 |
|
|
<use name=gccxml>
|
211 |
|
|
<Runtime name=PATH value="$ROOTRFLX_BASE/bin" type=path>
|
212 |
|
|
<Runtime name=ROOTSYS value="$ROOTRFLX_BASE/">
|
213 |
|
|
<Runtime name=GENREFLEX value="$ROOTRFLX_BASE/bin/genreflex">
|
214 |
|
|
</Tool>
|
215 |
|
|
EOF_TOOLFILE
|
216 |
|
|
|
217 |
|
|
# roothtml toolfile
|
218 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/roothtml
|
219 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
220 |
|
|
<Tool name=roothtml version=%v>
|
221 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
222 |
|
|
<lib name=Html>
|
223 |
|
|
<use name=ROOT>
|
224 |
|
|
</Tool>
|
225 |
|
|
EOF_TOOLFILE
|
226 |
|
|
|
227 |
|
|
# rootroofit toolfile
|
228 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootroofit
|
229 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
230 |
|
|
<Tool name=rootroofit version=%v>
|
231 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
232 |
|
|
<lib name=RooFit>
|
233 |
|
|
<use name=ROOTMinuit>
|
234 |
|
|
<use name=ROOTHtml>
|
235 |
|
|
</Tool>
|
236 |
|
|
EOF_TOOLFILE
|
237 |
|
|
|
238 |
|
|
# rootmlp toolfile
|
239 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootmlp
|
240 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
241 |
|
|
<Tool name=rootmlp version=%v>
|
242 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
243 |
|
|
<lib name=MLP>
|
244 |
|
|
<use name=ROOT>
|
245 |
|
|
</Tool>
|
246 |
|
|
EOF_TOOLFILE
|
247 |
|
|
|
248 |
|
|
# roottmva toolfile
|
249 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/roottmva
|
250 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
251 |
|
|
<Tool name=roottmva version=%v>
|
252 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
253 |
|
|
<lib name=TMVA>
|
254 |
|
|
<use name=ROOTMLP>
|
255 |
|
|
</Tool>
|
256 |
|
|
EOF_TOOLFILE
|
257 |
|
|
|
258 |
|
|
# rootthread toolfile
|
259 |
|
|
cat << \EOF_TOOLFILE >%i/etc/scram.d/rootthread
|
260 |
|
|
<doc type=BuildSystem::ToolDoc version=1.0>
|
261 |
|
|
<Tool name=rootthread version=%v>
|
262 |
|
|
<info url="http://root.cern.ch/root/"></info>
|
263 |
|
|
<lib name=Thread>
|
264 |
|
|
<use name=ROOTCore>
|
265 |
|
|
</Tool>
|
266 |
|
|
EOF_TOOLFILE
|
267 |
|
|
|
268 |
|
|
%post
|
269 |
|
|
%{relocateConfig}etc/scram.d/root
|
270 |
|
|
%{relocateConfig}etc/scram.d/rootcore
|
271 |
|
|
%{relocateConfig}etc/scram.d/rootcintex
|
272 |
|
|
%{relocateConfig}etc/scram.d/rootinteractive
|
273 |
|
|
%{relocateConfig}etc/scram.d/rootmath
|
274 |
|
|
%{relocateConfig}etc/scram.d/rootminuit
|
275 |
|
|
%{relocateConfig}etc/scram.d/rootminuit2
|
276 |
|
|
%{relocateConfig}etc/scram.d/rootrflx
|
277 |
|
|
%{relocateConfig}etc/scram.d/roothtml
|
278 |
|
|
%{relocateConfig}etc/scram.d/rootroofit
|
279 |
|
|
%{relocateConfig}etc/scram.d/rootmlp
|
280 |
|
|
%{relocateConfig}etc/scram.d/roottmva
|
281 |
|
|
%{relocateConfig}etc/scram.d/rootthread
|