Revision: | 1.66 |
Committed: | Sat Sep 22 08:41:44 2007 UTC (17 years, 7 months ago) by elmer |
Branch: | MAIN |
CVS Tags: | nr080626_for1612flt, CMSSW_1_6_12, apFor1612v0, apFor1612p3v0, CMSSW_1_6_12_pre2, apFor1612p2v1, apFor1612p2v0, CMSSW_1_6_12_pre1, apFor1612p1v1, apFor1612p1v0, CMSSW_1_6_11, apFor1611v0, apFor1611p1v1, apFor1611p1v0, CMSSW_1_6_10, apFor1610v0, CMSSW_1_6_10_pre2, CMSSW_1_6_10_pre1, apFor1610p2v0, apFor1610p1v2, apFor1610p1v1, CMSSW_1_6_9, apFor169v1, CMSSW_1_6_9_pre2, apFor169p2v2, apFor169p2v1, apFor169p2v0, ap20080116d, ap20080116c, ap20080116b, ap20080116a, ap20080115d, ap20080115c, ap20080115b, ap20080115a, ap20080114b, ap20080114a, CMSSW_1_6_9_pre1, apFor169p1, apFor169p1v5, apFor169p1v4, apFor169p1v3, apFor169p1v2, apFor169p1v1, apFor169p1v0, apFor169v0, CMSSW_1_6_8, apFor168, CMSSW_1_6_8_pre2, apFor168p2, CMSSW_1_6_8_pre1, apFor168p1, CMSSW_1_6_7_FWLITE, nr071026_fwlite167, nr071025_fwlite167, CMSSW_1_6_7, pe20071019a-for167, CMSSW_1_6_6, pe20071013a-for166p2, pe20071011a-for166, pe20071009a-for166p1, CMSSW_1_6_5, pe20071006a-for165, CMSSW_1_6_5_pre2, pe20071005a-for165p2, CMSSW_1_6_5_pre1, pe20070930b-for165p1, pe20070930a-for165p1, CMSSW_1_6_4, pe20070929a-for164, CMSSW_1_6_3, pe20070928a-for16Xdpm, pe20070926a-for163, CMSSW_1_6_2, pe20070925a-for162, CMSSW_1_6_2_pre1, pe20070922a-for162p1, pe20070922g-for161p2, pe20070922f-for161p2 |
Changes since 1.65: | +2 -0 lines |
Log Message: | Use root-Cintex patch (for 161p2) |
# | Content |
---|---|
1 | ### RPM lcg root 5.14.00f-CMS3q |
2 | ## INITENV +PATH PYTHONPATH %i/lib/python |
3 | ## INITENV SET ROOTSYS %i |
4 | Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz |
5 | #Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz |
6 | |
7 | Patch: root-CINT-maxlongline |
8 | Patch1: root_libpng |
9 | Patch2: root-Cintex |
10 | |
11 | %define cpu %(echo %cmsplatf | cut -d_ -f2) |
12 | %define pythonv %(echo $PYTHON_VERSION | cut -d. -f1,2) |
13 | Requires: gccxml python qt gsl castor openssl mysql libpng libjpg dcap pcre zlib oracle libungif |
14 | |
15 | %if "%cpu" != "amd64" |
16 | Requires: libtiff |
17 | %endif |
18 | |
19 | %prep |
20 | %setup -n root |
21 | %patch -p0 |
22 | %patch1 -p2 |
23 | %patch2 -p1 |
24 | |
25 | %build |
26 | mkdir -p %i |
27 | export ROOTSYS=%_builddir/root |
28 | CONFIG_ARGS="--enable-table |
29 | --disable-builtin-pcre |
30 | --disable-builtin-freetype |
31 | --disable-builtin-zlib |
32 | --with-gccxml=${GCCXML_ROOT} |
33 | --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python2.4 |
34 | --enable-mysql --with-mysql-libdir=${MYSQL_ROOT}/lib --with-mysql-incdir=${MYSQL_ROOT}/include |
35 | --enable-explicitlink |
36 | --enable-qtgsi |
37 | --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include |
38 | --enable-mathcore |
39 | --enable-mathmore |
40 | --enable-reflex |
41 | --enable-cintex |
42 | --enable-minuit2 |
43 | --enable-roofit |
44 | --disable-ldap |
45 | --disable-krb5 |
46 | --with-ssl-incdir=${OPENSSL_ROOT}/include |
47 | --with-ssl-libdir=${OPENSSL_ROOT}/lib |
48 | --with-gsl-incdir=${GSL_ROOT}/include |
49 | --with-gsl-libdir=${GSL_ROOT}/lib |
50 | --with-dcap-libdir=${DCAP_ROOT}/lib |
51 | --with-dcap-incdir=${DCAP_ROOT}/include |
52 | --disable-pgsql |
53 | --disable-xml" |
54 | |
55 | case $(uname)-$(uname -p) in |
56 | Linux-x86_64) |
57 | ./configure linuxx8664gcc $CONFIG_ARGS --enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift --disable-astiff --disable-cern;; |
58 | Linux-i*86) |
59 | ./configure linux $CONFIG_ARGS --enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift;; |
60 | Darwin*) |
61 | ./configure macosx $CONFIG_ARGS --disable-rfio;; |
62 | Linux-ppc64*) |
63 | ./configure linux $CONFIG_ARGS --disable-rfio;; |
64 | esac |
65 | |
66 | make %makeprocesses |
67 | make cintdlls |
68 | %install |
69 | # Override installers if we are using GNU fileutils cp. On OS X |
70 | # ROOT's INSTALL is defined to "cp -pPR", which only works with |
71 | # the system cp (/bin/cp). If you have fileutils on fink, you |
72 | # lose. Check which one is getting picked up and select syntax |
73 | # accordingly. (FIXME: do we need to check that -P is accepted?) |
74 | if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then |
75 | cp="cp -dpR" |
76 | else |
77 | cp="cp -pPR" |
78 | fi |
79 | |
80 | export ROOTSYS=%i |
81 | make INSTALL="$cp" INSTALLDATA="$cp" install |
82 | mkdir -p $ROOTSYS/lib/python |
83 | cp -r reflex/python/genreflex $ROOTSYS/lib/python |
84 | # |