1 |
ratnik |
1.53 |
### RPM lcg root 5.14.00d-pCMS1
|
2 |
eulisse |
1.5 |
# INITENV +PATH PYTHONPATH %i/lib/python
|
3 |
eulisse |
1.29 |
%define realVersion %(echo %v | cut -d- -f1)
|
4 |
|
|
Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realVersion | tr . -)&module=root&output=/%{n}_v%{realVersion}.source.tar.gz
|
5 |
|
|
#Source: ftp://root.cern.ch/%n/%{n}_v%{realVersion}.source.tar.gz
|
6 |
sashby |
1.51 |
|
7 |
|
|
Patch: root-CINT-maxtypedef
|
8 |
|
|
|
9 |
eulisse |
1.25 |
%define cpu %(echo %cmsplatf | cut -d_ -f2)
|
10 |
eulisse |
1.27 |
%define pythonv %(echo $PYTHON_VERSION | cut -d. -f1,2)
|
11 |
sashby |
1.50 |
Requires: gccxml python qt gsl castor openssl mysql libpng libjpg dcap pcre zlib oracle libungif
|
12 |
eulisse |
1.25 |
|
13 |
|
|
%if "%cpu" != "amd64"
|
14 |
|
|
Requires: libtiff
|
15 |
|
|
%endif
|
16 |
|
|
|
17 |
eulisse |
1.1 |
%prep
|
18 |
|
|
%setup -n root
|
19 |
sashby |
1.51 |
%patch -p0
|
20 |
|
|
|
21 |
eulisse |
1.1 |
%build
|
22 |
|
|
mkdir -p %i
|
23 |
elmer |
1.14 |
export ROOTSYS=%_builddir/root
|
24 |
eulisse |
1.25 |
CONFIG_ARGS="--enable-table
|
25 |
eulisse |
1.20 |
--disable-builtin-pcre
|
26 |
|
|
--disable-builtin-freetype
|
27 |
|
|
--disable-builtin-zlib
|
28 |
eulisse |
1.2 |
--with-gccxml=${GCCXML_ROOT}
|
29 |
eulisse |
1.28 |
--enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python2.4
|
30 |
eulisse |
1.12 |
--enable-mysql --with-mysql-libdir=${MYSQL_ROOT}/lib --with-mysql-incdir=${MYSQL_ROOT}/include
|
31 |
eulisse |
1.24 |
--enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include
|
32 |
eulisse |
1.2 |
--enable-explicitlink
|
33 |
eulisse |
1.20 |
--enable-qtgsi
|
34 |
eulisse |
1.2 |
--enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
|
35 |
|
|
--enable-mathcore
|
36 |
eulisse |
1.20 |
--enable-mathmore
|
37 |
eulisse |
1.2 |
--enable-reflex
|
38 |
|
|
--enable-cintex
|
39 |
|
|
--enable-minuit2
|
40 |
eulisse |
1.7 |
--enable-roofit
|
41 |
|
|
--disable-ldap
|
42 |
|
|
--disable-krb5
|
43 |
sashby |
1.43 |
--with-dcap-libdir=${DCAP_ROOT}/lib
|
44 |
|
|
--with-dcap-incdir=${DCAP_ROOT}/include
|
45 |
eulisse |
1.7 |
--with-ssl-incdir=${OPENSSL_ROOT}/include
|
46 |
|
|
--with-ssl-libdir=${OPENSSL_ROOT}/lib
|
47 |
elmer |
1.26 |
--with-shift-incdir=${CASTOR_ROOT}/include/shift
|
48 |
eulisse |
1.16 |
--with-shift-libdir=${CASTOR_ROOT}/lib
|
49 |
eulisse |
1.34 |
--with-gsl-incdir=${GSL_ROOT}/include
|
50 |
|
|
--with-gsl-libdir=${GSL_ROOT}/lib
|
51 |
eulisse |
1.7 |
--disable-pgsql
|
52 |
|
|
--disable-xml"
|
53 |
eulisse |
1.2 |
|
54 |
|
|
case $(uname)-$(uname -m) in
|
55 |
|
|
Linux-x86_64)
|
56 |
eulisse |
1.25 |
./configure linuxx8664gcc $CONFIG_ARGS --disable-astiff;;
|
57 |
eulisse |
1.2 |
Linux*)
|
58 |
|
|
./configure linux $CONFIG_ARGS;;
|
59 |
elmer |
1.11 |
Darwin*)
|
60 |
eulisse |
1.2 |
./configure macosx $CONFIG_ARGS;;
|
61 |
eulisse |
1.1 |
esac
|
62 |
eulisse |
1.2 |
|
63 |
eulisse |
1.21 |
make
|
64 |
eulisse |
1.20 |
make cintdlls
|
65 |
eulisse |
1.1 |
%install
|
66 |
|
|
# Override installers if we are using GNU fileutils cp. On OS X
|
67 |
|
|
# ROOT's INSTALL is defined to "cp -pPR", which only works with
|
68 |
|
|
# the system cp (/bin/cp). If you have fileutils on fink, you
|
69 |
|
|
# lose. Check which one is getting picked up and select syntax
|
70 |
|
|
# accordingly. (FIXME: do we need to check that -P is accepted?)
|
71 |
|
|
if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
|
72 |
|
|
cp="cp -dpR"
|
73 |
|
|
else
|
74 |
|
|
cp="cp -pPR"
|
75 |
|
|
fi
|
76 |
|
|
|
77 |
eulisse |
1.23 |
export ROOTSYS=%i/root
|
78 |
eulisse |
1.5 |
make INSTALL="$cp" INSTALLDATA="$cp" install
|
79 |
eulisse |
1.8 |
mkdir -p %i/root/lib/python
|
80 |
eulisse |
1.6 |
cp -r reflex/python/genreflex %i/root/lib/python
|
81 |
eulisse |
1.35 |
#
|