ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.28
Committed: Wed Jul 26 10:21:24 2006 UTC (18 years, 9 months ago) by eulisse
Branch: MAIN
CVS Tags: for082, CMSSW_0_8_1, nr_baran081_t1, for080_testfixes1, for080_testfixes
Changes since 1.27: +1 -1 lines
Log Message:
Forcing python 2.4

File Contents

# Content
1 ### RPM lcg root 5.12.00
2 # INITENV +PATH PYTHONPATH %i/lib/python
3 Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %v | tr . -)&module=root&output=/%{n}_v%{v}.source.tar.gz
4 #Source: ftp://root.cern.ch/%n/%{n}_v%{v}.source.tar.gz
5 %define cpu %(echo %cmsplatf | cut -d_ -f2)
6 %define pythonv %(echo $PYTHON_VERSION | cut -d. -f1,2)
7 Requires: gccxml python qt gsl castor openssl mysql libpng libjpg dcap pcre zlib oracle
8
9 %if "%cpu" != "amd64"
10 Requires: libtiff
11 %endif
12
13 Patch: root-cint-bug
14 %prep
15 %setup -n root
16 %build
17 mkdir -p %i
18 export ROOTSYS=%_builddir/root
19 CONFIG_ARGS="--enable-table
20 --disable-builtin-pcre
21 --disable-builtin-freetype
22 --disable-builtin-zlib
23 --with-gccxml=${GCCXML_ROOT}
24 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python2.4
25 --enable-mysql --with-mysql-libdir=${MYSQL_ROOT}/lib --with-mysql-incdir=${MYSQL_ROOT}/include
26 --enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include
27 --enable-explicitlink
28 --enable-qtgsi
29 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
30 --enable-mathcore
31 --enable-mathmore
32 --enable-reflex
33 --enable-cintex
34 --enable-minuit2
35 --enable-roofit
36 --disable-ldap
37 --disable-krb5
38 --with-dcap-libdir=${DCAP_ROOT}/lib
39 --with-dcap-incdir=${DCAP_ROOT}/include
40 --with-ssl-incdir=${OPENSSL_ROOT}/include
41 --with-ssl-libdir=${OPENSSL_ROOT}/lib
42 --with-shift-incdir=${CASTOR_ROOT}/include/shift
43 --with-shift-libdir=${CASTOR_ROOT}/lib
44 --disable-pgsql
45 --disable-xml"
46
47 case $(uname)-$(uname -m) in
48 Linux-x86_64)
49 ./configure linuxx8664gcc $CONFIG_ARGS --disable-astiff;;
50 Linux*)
51 ./configure linux $CONFIG_ARGS;;
52 Darwin*)
53 ./configure macosx $CONFIG_ARGS;;
54 esac
55
56 make
57 make cintdlls
58 %install
59 # Override installers if we are using GNU fileutils cp. On OS X
60 # ROOT's INSTALL is defined to "cp -pPR", which only works with
61 # the system cp (/bin/cp). If you have fileutils on fink, you
62 # lose. Check which one is getting picked up and select syntax
63 # accordingly. (FIXME: do we need to check that -P is accepted?)
64 if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
65 cp="cp -dpR"
66 else
67 cp="cp -pPR"
68 fi
69
70 export ROOTSYS=%i/root
71 make INSTALL="$cp" INSTALLDATA="$cp" install
72 mkdir -p %i/root/lib/python
73 cp -r reflex/python/genreflex %i/root/lib/python