Revision: | 1.10 |
Committed: | Mon May 15 18:33:01 2006 UTC (18 years, 11 months ago) by lat |
Branch: | MAIN |
CVS Tags: | CRABSERVER_TEST_BUILD_V4, CRABSERVER_TEST_BUILD_V3, CRABSERVER_TEST_BUILD_V2, CRABSERVER_TEST_BUILD_V1, forCRABSERVER104test, forCRABSERVER103, PRODAGENT_0_10_12_V10, PRODAGENT_0_10_12_V9, PRODAGENT_0_10_12_V8, PRODAGENT_0_10_12_V7, PRODAGENT_0_10_12_V6, PRODAGENT_0_10_12_V5, PRODAGENT_0_10_12_V4, forCS102pre4, PRODAGENT_0_10_12_V3, PRODAGENT_0_10_12_V2, PRODAGENT_0_10_12, PRODAGENT_0_10_3, PRODAGENT_0_10_3_20080521, PRODAGENT_0_8_3_SL4, forPA070pre3-slc3, forPA070pre3-slc4, forPA070pre3-slc, forPA061, forPA060pre7-slc4, forPA060pre3, forDBS106, forPA050pre3, WEBTOOLS_CONFIG_1_pre2, WEBTOOLS_CONFIG_1_pre1, forPA030, forPA020, PR_0_5_4, PR_0_5_0, PR_0_4_21, PRODREQUEST_0_4_0, PR0_3_13, PR0_3_12, PR0-3-11, forPR034, forPR033, forPIL116, forPR032, forPR030, forPR020, forPA011, forPR010, forPA010, af20060928, ProdAgent_pa17, phedex_2_3_series, V00-00-09, V00-00-08, V00-00-07, V00-00-06, V00-00-05 |
Changes since 1.9: | +1 -1 lines |
Log Message: | Don't require any packages seeded from the system. |
# | User | Rev | Content |
---|---|---|---|
1 | eulisse | 1.6 | ### RPM lcg root 5.10.00c |
2 | eulisse | 1.5 | # INITENV +PATH PYTHONPATH %i/lib/python |
3 | eulisse | 1.1 | # Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %v | tr . -)&module=root&output=/%{n}_v%{v}.source.tar.gz |
4 | Source: ftp://root.cern.ch/%n/%{n}_v%{v}.source.tar.gz | ||
5 | lat | 1.10 | Requires: gccxml python qt gsl rfio openssl |
6 | eulisse | 1.4 | Patch0: root |
7 | eulisse | 1.1 | %prep |
8 | %setup -n root | ||
9 | eulisse | 1.4 | %patch0 |
10 | eulisse | 1.1 | |
11 | %build | ||
12 | mkdir -p %i | ||
13 | export ROOTSYS=%i | ||
14 | eulisse | 1.2 | CONFIG_ARGS="--enable-table |
15 | --with-gccxml=${GCCXML_ROOT} | ||
16 | --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include | ||
17 | --enable-explicitlink | ||
18 | --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include | ||
19 | --enable-mathcore | ||
20 | --enable-reflex | ||
21 | --enable-cintex | ||
22 | --enable-minuit2 | ||
23 | eulisse | 1.7 | --enable-roofit |
24 | --disable-ldap | ||
25 | --disable-krb5 | ||
26 | --with-ssl-incdir=${OPENSSL_ROOT}/include | ||
27 | --with-ssl-libdir=${OPENSSL_ROOT}/lib | ||
28 | --with-shift-incdir=${RFIO_ROOT}/include | ||
29 | --with-shift-libdir=${RFIO_ROOT}/lib | ||
30 | --disable-pgsql | ||
31 | --disable-xml" | ||
32 | eulisse | 1.2 | |
33 | case $(uname)-$(uname -m) in | ||
34 | Linux-x86_64) | ||
35 | ./configure linuxx8664gcc $CONFIG_ARGS;; | ||
36 | Linux*) | ||
37 | ./configure linux $CONFIG_ARGS;; | ||
38 | eulisse | 1.1 | Darwin) |
39 | eulisse | 1.2 | ./configure macosx $CONFIG_ARGS;; |
40 | eulisse | 1.1 | esac |
41 | eulisse | 1.2 | |
42 | make %makeprocesses | ||
43 | eulisse | 1.1 | |
44 | %install | ||
45 | # Override installers if we are using GNU fileutils cp. On OS X | ||
46 | # ROOT's INSTALL is defined to "cp -pPR", which only works with | ||
47 | # the system cp (/bin/cp). If you have fileutils on fink, you | ||
48 | # lose. Check which one is getting picked up and select syntax | ||
49 | # accordingly. (FIXME: do we need to check that -P is accepted?) | ||
50 | if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then | ||
51 | cp="cp -dpR" | ||
52 | else | ||
53 | cp="cp -pPR" | ||
54 | fi | ||
55 | |||
56 | eulisse | 1.6 | export ROOTSYS=%i/root |
57 | eulisse | 1.5 | make INSTALL="$cp" INSTALLDATA="$cp" install |
58 | eulisse | 1.8 | mkdir -p %i/root/lib/python |
59 | eulisse | 1.6 | cp -r reflex/python/genreflex %i/root/lib/python |