ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.61
Committed: Thu Jun 28 22:13:05 2007 UTC (17 years, 10 months ago) by elmer
Branch: MAIN
CVS Tags: nr20071011-bootstrap, nr20070926-bootstrap, ap-20070925, pe20070830a-160p14, CMSSW_1_6_0_DAQ3, CMSSW_1_6_0_pre13, dl070827, dl070826, pe20070826a-160p13, CMSSW_1_6_0_pre12, dl070824, pe20070824b-160p12, pe20070824-160p12, pe20070823-160p12, CMSSW_1_6_0_pre11, CMSSW_1_6_0_pre10, ge20070810-ptc, CMSSW_1_6_0_pre9, CMSSW_1_6_0_pre8, CMSSW_1_6_0_pre7, dl070730, cms160daq1_zhen2, cms160daq1_zhen1, ge20070730-cmsbuild, ge20070729-amd64, CMSSW_1_6_0_pre6, pe20070727-160p6, CMSSW_1_6_0_DAQ1, ge20070726, ge20070724-slc3, nr20070723_fwlite160p5, ap20070723, CMSSW_1_6_0_pre5, dl070721, dl070720_160daq1_1, pe20070720-160daq1, pe20070720-160p5, ge20070718, ge20070717, ap20070717, ge20070713-macosx, ap20070712, ge20070712-migration, ge20070712, ge20070711-prodcommon, CMSSW_1_6_0_pre4, ge20070710-formencode, ge20070709-slc3, ge20070709-macosx, ge20070709a-macosx, ge20070706-macosx, ap20070706, CMSSW_1_6_0_pre3, pe20070705a-160p3, CMSSW_1_6_0_pre2, ge20070705, ge20070704, ge20070703b, pe20070702b-160p3, pe20070702b-160p2, ge20070702-rpm-webtools, CMSSW_1_6_0_pre1, pe20070729b-160p2, pe20070729b-160p1, pe20070729a-160p2, pe20070729a-160p1
Changes since 1.60: +1 -1 lines
Log Message:
Disable h2root and the other cernlib linking things for the 64-bit build

File Contents

# User Rev Content
1 elmer 1.60 ### RPM lcg root 5.14.00f-CMS1
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3     ## INITENV SET ROOTSYS %i
4 elmer 1.59 Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realversion | tr . -)&module=root&output=/%{n}_v%{realversion}.source.tar.gz
5     #Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
6 sashby 1.51
7 dlange 1.58 Patch: root-CINT-maxlongline
8    
9 eulisse 1.25 %define cpu %(echo %cmsplatf | cut -d_ -f2)
10 eulisse 1.27 %define pythonv %(echo $PYTHON_VERSION | cut -d. -f1,2)
11 sashby 1.50 Requires: gccxml python qt gsl castor openssl mysql libpng libjpg dcap pcre zlib oracle libungif
12 eulisse 1.25
13     %if "%cpu" != "amd64"
14     Requires: libtiff
15     %endif
16    
17 eulisse 1.1 %prep
18     %setup -n root
19 dlange 1.58 %patch -p0
20 sashby 1.51
21 eulisse 1.1 %build
22     mkdir -p %i
23 elmer 1.14 export ROOTSYS=%_builddir/root
24 eulisse 1.25 CONFIG_ARGS="--enable-table
25 eulisse 1.20 --disable-builtin-pcre
26     --disable-builtin-freetype
27     --disable-builtin-zlib
28 eulisse 1.2 --with-gccxml=${GCCXML_ROOT}
29 eulisse 1.28 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python2.4
30 eulisse 1.12 --enable-mysql --with-mysql-libdir=${MYSQL_ROOT}/lib --with-mysql-incdir=${MYSQL_ROOT}/include
31 eulisse 1.2 --enable-explicitlink
32 eulisse 1.20 --enable-qtgsi
33 eulisse 1.2 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
34     --enable-mathcore
35 eulisse 1.20 --enable-mathmore
36 eulisse 1.2 --enable-reflex
37     --enable-cintex
38     --enable-minuit2
39 eulisse 1.7 --enable-roofit
40     --disable-ldap
41     --disable-krb5
42     --with-ssl-incdir=${OPENSSL_ROOT}/include
43     --with-ssl-libdir=${OPENSSL_ROOT}/lib
44 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
45     --with-gsl-libdir=${GSL_ROOT}/lib
46 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
47     --with-dcap-incdir=${DCAP_ROOT}/include
48 eulisse 1.7 --disable-pgsql
49     --disable-xml"
50 eulisse 1.2
51 elmer 1.54 case $(uname)-$(uname -p) in
52 eulisse 1.2 Linux-x86_64)
53 elmer 1.61 ./configure linuxx8664gcc $CONFIG_ARGS --enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift --disable-astiff --disable-cern;;
54 elmer 1.54 Linux-i*86)
55     ./configure linux $CONFIG_ARGS --enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include --with-shift-libdir=${CASTOR_ROOT}/lib --with-shift-incdir=${CASTOR_ROOT}/include/shift;;
56 elmer 1.11 Darwin*)
57 elmer 1.54 ./configure macosx $CONFIG_ARGS --disable-rfio;;
58     Linux-ppc64*)
59     ./configure linux $CONFIG_ARGS --disable-rfio;;
60 eulisse 1.1 esac
61 eulisse 1.2
62 dlange 1.57 make %makeprocesses
63 eulisse 1.20 make cintdlls
64 eulisse 1.1 %install
65     # Override installers if we are using GNU fileutils cp. On OS X
66     # ROOT's INSTALL is defined to "cp -pPR", which only works with
67     # the system cp (/bin/cp). If you have fileutils on fink, you
68     # lose. Check which one is getting picked up and select syntax
69     # accordingly. (FIXME: do we need to check that -P is accepted?)
70     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
71     cp="cp -dpR"
72     else
73     cp="cp -pPR"
74     fi
75    
76 dlange 1.57 export ROOTSYS=%i
77 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
78 dlange 1.57 mkdir -p $ROOTSYS/lib/python
79     cp -r reflex/python/genreflex $ROOTSYS/lib/python
80 eulisse 1.35 #