ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.48
Committed: Fri Dec 1 13:09:56 2006 UTC (18 years, 4 months ago) by elmer
Branch: MAIN
CVS Tags: for120p9, pe20061201c, pe20061201b, pe20061201a
Changes since 1.47: +1 -1 lines
Log Message:
Update to 5.13.04c-for120p9

File Contents

# User Rev Content
1 elmer 1.48 ### RPM lcg root 5.13.04c-for120p9
2 eulisse 1.5 # INITENV +PATH PYTHONPATH %i/lib/python
3 eulisse 1.29 %define realVersion %(echo %v | cut -d- -f1)
4     Source: cvs://:pserver:cvs@root.cern.ch:2401/user/cvs?passwd=Ah<Z&tag=-rv%(echo %realVersion | tr . -)&module=root&output=/%{n}_v%{realVersion}.source.tar.gz
5     #Source: ftp://root.cern.ch/%n/%{n}_v%{realVersion}.source.tar.gz
6 eulisse 1.25 %define cpu %(echo %cmsplatf | cut -d_ -f2)
7 eulisse 1.27 %define pythonv %(echo $PYTHON_VERSION | cut -d. -f1,2)
8 sashby 1.43 Requires: gccxml python qt gsl castor openssl mysql libpng libjpg dcap pcre zlib oracle
9 eulisse 1.25
10     %if "%cpu" != "amd64"
11     Requires: libtiff
12     %endif
13    
14 sashby 1.46 Patch: cintex_5.13.04e
15 eulisse 1.47 Patch1: reflex
16 eulisse 1.1 %prep
17     %setup -n root
18 sashby 1.46 %patch0 -p0
19 eulisse 1.47 %patch1 -p0
20 eulisse 1.1 %build
21     mkdir -p %i
22 elmer 1.14 export ROOTSYS=%_builddir/root
23 eulisse 1.25 CONFIG_ARGS="--enable-table
24 eulisse 1.20 --disable-builtin-pcre
25     --disable-builtin-freetype
26     --disable-builtin-zlib
27 eulisse 1.2 --with-gccxml=${GCCXML_ROOT}
28 eulisse 1.28 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python2.4
29 eulisse 1.12 --enable-mysql --with-mysql-libdir=${MYSQL_ROOT}/lib --with-mysql-incdir=${MYSQL_ROOT}/include
30 eulisse 1.24 --enable-oracle --with-oracle-libdir=${ORACLE_ROOT}/lib --with-oracle-incdir=${ORACLE_ROOT}/include
31 eulisse 1.2 --enable-explicitlink
32 eulisse 1.20 --enable-qtgsi
33 eulisse 1.2 --enable-qt --with-qt-libdir=${QT_ROOT}/lib --with-qt-incdir=${QT_ROOT}/include
34     --enable-mathcore
35 eulisse 1.20 --enable-mathmore
36 eulisse 1.2 --enable-reflex
37     --enable-cintex
38     --enable-minuit2
39 eulisse 1.7 --enable-roofit
40     --disable-ldap
41     --disable-krb5
42 sashby 1.43 --with-dcap-libdir=${DCAP_ROOT}/lib
43     --with-dcap-incdir=${DCAP_ROOT}/include
44 eulisse 1.7 --with-ssl-incdir=${OPENSSL_ROOT}/include
45     --with-ssl-libdir=${OPENSSL_ROOT}/lib
46 elmer 1.26 --with-shift-incdir=${CASTOR_ROOT}/include/shift
47 eulisse 1.16 --with-shift-libdir=${CASTOR_ROOT}/lib
48 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
49     --with-gsl-libdir=${GSL_ROOT}/lib
50 eulisse 1.7 --disable-pgsql
51     --disable-xml"
52 eulisse 1.2
53     case $(uname)-$(uname -m) in
54     Linux-x86_64)
55 eulisse 1.25 ./configure linuxx8664gcc $CONFIG_ARGS --disable-astiff;;
56 eulisse 1.2 Linux*)
57     ./configure linux $CONFIG_ARGS;;
58 elmer 1.11 Darwin*)
59 eulisse 1.2 ./configure macosx $CONFIG_ARGS;;
60 eulisse 1.1 esac
61 eulisse 1.2
62 eulisse 1.21 make
63 eulisse 1.20 make cintdlls
64 eulisse 1.1 %install
65     # Override installers if we are using GNU fileutils cp. On OS X
66     # ROOT's INSTALL is defined to "cp -pPR", which only works with
67     # the system cp (/bin/cp). If you have fileutils on fink, you
68     # lose. Check which one is getting picked up and select syntax
69     # accordingly. (FIXME: do we need to check that -P is accepted?)
70     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
71     cp="cp -dpR"
72     else
73     cp="cp -pPR"
74     fi
75    
76 eulisse 1.23 export ROOTSYS=%i/root
77 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
78 eulisse 1.8 mkdir -p %i/root/lib/python
79 eulisse 1.6 cp -r reflex/python/genreflex %i/root/lib/python
80 eulisse 1.35 #