ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.296
Committed: Thu Sep 22 15:16:37 2011 UTC (13 years, 7 months ago) by zafar
Branch: MAIN
CVS Tags: CMSSW_5_0_0_pre3, sjgFor500pre3, az20111014-50X, az20111012-50X, az20111011b-50X, az20111011a-50X, CMSSW_5_0_0_pre2, sjgFor500pre2, az20111007-50X, az20110928a-50X, az20110928-50X, CMSSW_5_0_0_pre1, sjgFor500pre1b, sjgFor500pre1, az20110922c-50X, az20110922b-50X-ports, az20110922b-50X
Changes since 1.295: +3 -3 lines
Log Message:
adding back an overridden stuff while moving to version 5.30.02

File Contents

# User Rev Content
1 zafar 1.295 ### RPM lcg root 5.30.02
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.198 ## INITENV SET ROOTSYS %i
4 fwyzard 1.291 #Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
5     %define svntag %(echo %realversion | tr . -)
6     Source: svn://root.cern.ch/svn/root/tags/v%{svntag}/?scheme=http&strategy=export&module=%n-%{realversion}&output=/%n-%{realversion}.tgz
7     %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
8     %define ismac %(case %cmsplatf in (osx*) echo true;; (*) echo false;; esac)
9    
10     Patch0: root-5.28-00d-externals
11     Patch1: root-5.28-00d-CINT-maxlongline-maxtypedef
12     Patch2: root-5.28-00d-roofit-silence-static-printout
13     Patch3: root-5.28-00d-linker-gnu-hash-style
14 zafar 1.295 #Patch4: root-5.28-00d-TBranchElement-dropped-data-member
15     #Patch5: root-5.30-00-TSchemaRuleProcessor-nested-space
16 fwyzard 1.291 #Patch5: root-5.28-00d-r37582-tmva
17     #Patch6: root-5.28-00d-TTreeCache-r37919
18     #Patch7: root-5.28-00d-r38248-r38259-r38264-r38265-r38267
19     #Patch8: root-5.28-00d-fireworks1
20     #Patch9: root-5.28-00d-r39155
21     #Patch10: root-5.28-00d-r39525
22     #Patch11: root-5.28-00d-r39657
23     #Patch12: root-5.28-00d-r39759
24     #Patch13: root-5.28-00d-fix-tsystem-load-macosx
25    
26 elmer 1.98 %define cpu %(echo %cmsplatf | cut -d_ -f2)
27    
28 fwyzard 1.291 Requires: gccxml gsl libjpg libpng libtiff libungif pcre python fftw3 xz xrootd
29 elmer 1.228
30 fwyzard 1.235 %if "%ismac" != "true"
31 elmer 1.228 Requires: castor dcap
32     %endif
33    
34 fwyzard 1.235 %if "%online" != "true"
35 eulisse 1.288 Requires: openssl zlib
36 elmer 1.228 %endif
37    
38 zafar 1.296 %if "%(case %cmsplatf in (osx*_*_gcc421) echo true ;; (*) echo false ;; esac)" == "true"
39 fwyzard 1.235 Requires: gfortran-macosx
40     %endif
41    
42 eulisse 1.1 %prep
43 fwyzard 1.291 %setup -n root-%realversion
44 ratnik 1.106 %patch0 -p1
45     %patch1 -p1
46 elmer 1.205 %patch2 -p1
47 fwyzard 1.235 # patch3 is OS version dependent, see below
48 zafar 1.296 # patch4 -p1
49     # patch5 -p2
50 fwyzard 1.291 # patch5 -p1
51     # patch6 -p1
52     # patch7 -p1
53     # patch8 -p1
54     # patch9 -p1
55     # patch10 -p1 TRY AGAIN!
56     # patch11 -p0
57     # patch12 -p2
58     # patch13 -p1
59 eulisse 1.279
60 fwyzard 1.235 # The following patch can only be applied on SLC5 or later (extra linker
61 elmer 1.198 # options only available with the SLC5 binutils)
62     case %cmsplatf in
63     slc5_* | slc5onl_* )
64 fwyzard 1.235 %patch3 -p1
65 elmer 1.198 ;;
66     esac
67 eulisse 1.190
68 fwyzard 1.235 # Delete these (irrelevant) files as the fits appear to confuse rpm on OSX
69     # (It tries to run install_name_tool on them.)
70     rm -fR tutorials/fitsio
71    
72 eulisse 1.1 %build
73 andreasp 1.163
74 eulisse 1.1 mkdir -p %i
75 elmer 1.221 export LIBJPG_ROOT
76 elmer 1.14 export ROOTSYS=%_builddir/root
77 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
78 dlange 1.103
79 muzaffar 1.164 %if "%online" == "true"
80 elmer 1.256 # Also skip xrootd and odbc for online case:
81 ratnik 1.111
82 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
83 elmer 1.256 --disable-odbc --disable-astiff"
84 dlange 1.103 %else
85 elmer 1.221 export LIBPNG_ROOT ZLIB_ROOT LIBTIFF_ROOT LIBUNGIF_ROOT
86 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
87 ratnik 1.106 --with-ssl-incdir=${OPENSSL_ROOT}/include
88 elmer 1.256 --with-ssl-libdir=${OPENSSL_ROOT}/lib"
89 dlange 1.103 %endif
90 fwyzard 1.291 LZMA=${XZ_ROOT}
91     export LZMA
92 muzaffar 1.164 CONFIG_ARGS="--enable-table
93 eulisse 1.20 --disable-builtin-pcre
94     --disable-builtin-freetype
95     --disable-builtin-zlib
96 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
97 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
98 eulisse 1.2 --enable-explicitlink
99 eulisse 1.20 --enable-mathmore
100 eulisse 1.2 --enable-reflex
101     --enable-cintex
102 fwyzard 1.291 --enable-minuit2
103     --disable-builtin-lzma
104 elmer 1.221 --enable-fftw3
105     --with-fftw3-incdir=${FFTW3_ROOT}/include
106     --with-fftw3-libdir=${FFTW3_ROOT}/lib
107 elmer 1.98 --disable-ldap
108 gowdy 1.143 --disable-krb5
109 fwyzard 1.235 --with-xrootd=${XROOTD_ROOT}
110 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
111     --with-gsl-libdir=${GSL_ROOT}/lib
112 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
113 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
114     --disable-pgsql
115 elmer 1.181 --disable-mysql
116 elmer 1.256 --disable-qt --disable-qtgsi
117 elmer 1.242 --disable-oracle ${EXTRA_CONFIG_ARGS}"
118 elmer 1.98
119 eulisse 1.236 case %cmsos in
120     slc*_amd64)
121 fwyzard 1.235 ./configure linuxx8664gcc $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
122 eulisse 1.236 slc*_ia32)
123 fwyzard 1.235 ./configure linux $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
124 eulisse 1.236 osx*)
125 elmer 1.198 case %cmsplatf in
126     *_ia32_* )
127 fwyzard 1.235 comparch=i386
128     macconfig=macosx
129     ;;
130 elmer 1.198 *_amd64_* )
131 fwyzard 1.235 comparch=x86_64
132     macconfig=macosx64
133     ;;
134 elmer 1.198 * )
135 fwyzard 1.235 comparch=ppc
136     macconfig=macosx
137     ;;
138 elmer 1.198 esac
139 eulisse 1.236 export CC=`which gcc` CXX=`which g++`
140     ./configure $arch $CONFIG_ARGS --with-cc="$CC" --with-cxx="$CXX" --disable-rfio --disable-builtin_afterimage ;;
141     slc*_ppc64*)
142 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
143 eulisse 1.1 esac
144 eulisse 1.2
145 elmer 1.243 makeopts="%makeprocesses"
146 eulisse 1.236
147     make $makeopts
148 eulisse 1.147
149 eulisse 1.1 %install
150     # Override installers if we are using GNU fileutils cp. On OS X
151     # ROOT's INSTALL is defined to "cp -pPR", which only works with
152     # the system cp (/bin/cp). If you have fileutils on fink, you
153     # lose. Check which one is getting picked up and select syntax
154     # accordingly. (FIXME: do we need to check that -P is accepted?)
155     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
156     cp="cp -dpR"
157     else
158     cp="cp -pPR"
159     fi
160    
161 dlange 1.57 export ROOTSYS=%i
162 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
163 dlange 1.57 mkdir -p $ROOTSYS/lib/python
164 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python
165 eulisse 1.236 # This file confuses rpm's find-requires because it starts with
166     # a """ and it thinks is the shebang.
167     rm -f %i/tutorials/pyroot/mrt.py
168 eulisse 1.289
169