ViewVC Help
View File | Revision Log | Show Annotations | Root Listing
root/cvsroot/COMP/CMSDIST/root.spec
Revision: 1.307
Committed: Fri Oct 21 08:30:16 2011 UTC (13 years, 6 months ago) by gowdy
Branch: MAIN
CVS Tags: fwFor500pre4-online, CMSSW_5_0_0_pre4-ports, CMSSW_5_0_0_pre4, az20111027-50X-ports, az20111027-50X, sjgFor500pre4-ports, sjgFor500pre4, az20111026-50X-ports, az20111026-50X, az20111025-50X-ports, az20111025-50X, sm20111025-50X-ports, sm20111025-50X, az20111024-50X-ports, az20111024-50X, az20111022-50X, sjg111021b-50X-ports, sjg111021b-50X-gcc461-ports, sjg111021d-50X
Changes since 1.306: +1 -1 lines
Log Message:
get patch to apply

File Contents

# User Rev Content
1 eulisse 1.300 ### RPM lcg root 5.30.02
2 dlange 1.57 ## INITENV +PATH PYTHONPATH %i/lib/python
3 elmer 1.198 ## INITENV SET ROOTSYS %i
4 fwyzard 1.291 #Source: ftp://root.cern.ch/%n/%{n}_v%{realversion}.source.tar.gz
5     %define svntag %(echo %realversion | tr . -)
6     Source: svn://root.cern.ch/svn/root/tags/v%{svntag}/?scheme=http&strategy=export&module=%n-%{realversion}&output=/%n-%{realversion}.tgz
7     %define online %(case %cmsplatf in (*onl_*_*) echo true;; (*) echo false;; esac)
8     %define ismac %(case %cmsplatf in (osx*) echo true;; (*) echo false;; esac)
9    
10     Patch0: root-5.28-00d-externals
11     Patch1: root-5.28-00d-CINT-maxlongline-maxtypedef
12     Patch2: root-5.28-00d-roofit-silence-static-printout
13     Patch3: root-5.28-00d-linker-gnu-hash-style
14 eulisse 1.300 #Patch4: root-5.28-00d-TBranchElement-dropped-data-member
15     #Patch5: root-5.30-00-TSchemaRuleProcessor-nested-space
16 fwyzard 1.291 #Patch5: root-5.28-00d-r37582-tmva
17     #Patch6: root-5.28-00d-TTreeCache-r37919
18     #Patch7: root-5.28-00d-r38248-r38259-r38264-r38265-r38267
19     #Patch8: root-5.28-00d-fireworks1
20     #Patch9: root-5.28-00d-r39155
21     #Patch10: root-5.28-00d-r39525
22     #Patch11: root-5.28-00d-r39657
23     #Patch12: root-5.28-00d-r39759
24     #Patch13: root-5.28-00d-fix-tsystem-load-macosx
25 eulisse 1.300 Patch14: root-5.30.02-detect-arch
26 eulisse 1.304 #Patch15: root-5.30.02-fix-isnan
27 eulisse 1.303 Patch16: root-5.30.02-fix-gcc46
28 eulisse 1.304 Patch17: root-5.30.02-r41453
29 gowdy 1.305 Patch18: root-5.30.02-r41523
30 fwyzard 1.291
31 elmer 1.98 %define cpu %(echo %cmsplatf | cut -d_ -f2)
32    
33 fwyzard 1.291 Requires: gccxml gsl libjpg libpng libtiff libungif pcre python fftw3 xz xrootd
34 elmer 1.228
35 fwyzard 1.235 %if "%ismac" != "true"
36 elmer 1.228 Requires: castor dcap
37     %endif
38    
39 fwyzard 1.235 %if "%online" != "true"
40 eulisse 1.288 Requires: openssl zlib
41 elmer 1.228 %endif
42    
43 zafar 1.299 %define keep_archives true
44 zafar 1.296 %if "%(case %cmsplatf in (osx*_*_gcc421) echo true ;; (*) echo false ;; esac)" == "true"
45 fwyzard 1.235 Requires: gfortran-macosx
46     %endif
47    
48 eulisse 1.1 %prep
49 fwyzard 1.291 %setup -n root-%realversion
50 ratnik 1.106 %patch0 -p1
51     %patch1 -p1
52 elmer 1.205 %patch2 -p1
53 fwyzard 1.235 # patch3 is OS version dependent, see below
54 eulisse 1.300 # patch4 -p1
55     # patch5 -p2
56 fwyzard 1.291 # patch5 -p1
57     # patch6 -p1
58     # patch7 -p1
59     # patch8 -p1
60     # patch9 -p1
61     # patch10 -p1 TRY AGAIN!
62     # patch11 -p0
63     # patch12 -p2
64     # patch13 -p1
65 eulisse 1.300 %patch14 -p0
66 eulisse 1.304 # patch15 -p1
67 eulisse 1.303 %patch16 -p1
68 eulisse 1.304 %patch17 -p1
69 gowdy 1.307 %patch18 -p2
70 eulisse 1.279
71 fwyzard 1.235 # The following patch can only be applied on SLC5 or later (extra linker
72 elmer 1.198 # options only available with the SLC5 binutils)
73     case %cmsplatf in
74 lat 1.302 slc[56]_* | slc5onl_* )
75 fwyzard 1.235 %patch3 -p1
76 elmer 1.198 ;;
77     esac
78 eulisse 1.190
79 fwyzard 1.235 # Delete these (irrelevant) files as the fits appear to confuse rpm on OSX
80     # (It tries to run install_name_tool on them.)
81     rm -fR tutorials/fitsio
82    
83 eulisse 1.1 %build
84 andreasp 1.163
85 eulisse 1.1 mkdir -p %i
86 elmer 1.221 export LIBJPG_ROOT
87 elmer 1.14 export ROOTSYS=%_builddir/root
88 elmer 1.180 export PYTHONV=$(echo $PYTHON_VERSION | cut -f1,2 -d.)
89 dlange 1.103
90 muzaffar 1.164 %if "%online" == "true"
91 elmer 1.256 # Also skip xrootd and odbc for online case:
92 ratnik 1.111
93 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=/usr
94 elmer 1.256 --disable-odbc --disable-astiff"
95 dlange 1.103 %else
96 elmer 1.221 export LIBPNG_ROOT ZLIB_ROOT LIBTIFF_ROOT LIBUNGIF_ROOT
97 muzaffar 1.164 EXTRA_CONFIG_ARGS="--with-f77=${GCC_ROOT}
98 ratnik 1.106 --with-ssl-incdir=${OPENSSL_ROOT}/include
99 elmer 1.256 --with-ssl-libdir=${OPENSSL_ROOT}/lib"
100 dlange 1.103 %endif
101 fwyzard 1.291 LZMA=${XZ_ROOT}
102     export LZMA
103 muzaffar 1.164 CONFIG_ARGS="--enable-table
104 eulisse 1.20 --disable-builtin-pcre
105     --disable-builtin-freetype
106     --disable-builtin-zlib
107 elmer 1.98 --with-gccxml=${GCCXML_ROOT}
108 elmer 1.180 --enable-python --with-python-libdir=${PYTHON_ROOT}/lib --with-python-incdir=${PYTHON_ROOT}/include/python${PYTHONV}
109 eulisse 1.2 --enable-explicitlink
110 eulisse 1.20 --enable-mathmore
111 eulisse 1.2 --enable-reflex
112     --enable-cintex
113 fwyzard 1.291 --enable-minuit2
114     --disable-builtin-lzma
115 elmer 1.221 --enable-fftw3
116     --with-fftw3-incdir=${FFTW3_ROOT}/include
117     --with-fftw3-libdir=${FFTW3_ROOT}/lib
118 elmer 1.98 --disable-ldap
119 gowdy 1.143 --disable-krb5
120 fwyzard 1.235 --with-xrootd=${XROOTD_ROOT}
121 eulisse 1.34 --with-gsl-incdir=${GSL_ROOT}/include
122     --with-gsl-libdir=${GSL_ROOT}/lib
123 elmer 1.59 --with-dcap-libdir=${DCAP_ROOT}/lib
124 elmer 1.98 --with-dcap-incdir=${DCAP_ROOT}/include
125     --disable-pgsql
126 elmer 1.181 --disable-mysql
127 elmer 1.256 --disable-qt --disable-qtgsi
128 elmer 1.242 --disable-oracle ${EXTRA_CONFIG_ARGS}"
129 elmer 1.98
130 eulisse 1.236 case %cmsos in
131     slc*_amd64)
132 fwyzard 1.235 ./configure linuxx8664gcc $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
133 eulisse 1.236 slc*_ia32)
134 fwyzard 1.235 ./configure linux $CONFIG_ARGS --with-rfio-libdir=${CASTOR_ROOT}/lib --with-rfio-incdir=${CASTOR_ROOT}/include/shift --with-castor-libdir=${CASTOR_ROOT}/lib --with-castor-incdir=${CASTOR_ROOT}/include/shift ;;
135 eulisse 1.236 osx*)
136 elmer 1.198 case %cmsplatf in
137     *_amd64_* )
138 fwyzard 1.235 comparch=x86_64
139     macconfig=macosx64
140     ;;
141 elmer 1.198 esac
142 eulisse 1.236 export CC=`which gcc` CXX=`which g++`
143     ./configure $arch $CONFIG_ARGS --with-cc="$CC" --with-cxx="$CXX" --disable-rfio --disable-builtin_afterimage ;;
144     slc*_ppc64*)
145 elmer 1.98 ./configure linux $CONFIG_ARGS --disable-rfio;;
146 eulisse 1.1 esac
147 eulisse 1.2
148 elmer 1.243 makeopts="%makeprocesses"
149 eulisse 1.236
150     make $makeopts
151 eulisse 1.147
152 eulisse 1.1 %install
153     # Override installers if we are using GNU fileutils cp. On OS X
154     # ROOT's INSTALL is defined to "cp -pPR", which only works with
155     # the system cp (/bin/cp). If you have fileutils on fink, you
156     # lose. Check which one is getting picked up and select syntax
157     # accordingly. (FIXME: do we need to check that -P is accepted?)
158     if (cp --help | grep -e '-P.*--parents') >/dev/null 2>&1; then
159     cp="cp -dpR"
160     else
161     cp="cp -pPR"
162     fi
163    
164 dlange 1.57 export ROOTSYS=%i
165 eulisse 1.5 make INSTALL="$cp" INSTALLDATA="$cp" install
166 dlange 1.57 mkdir -p $ROOTSYS/lib/python
167 elmer 1.141 cp -r cint/reflex/python/genreflex $ROOTSYS/lib/python
168 eulisse 1.236 # This file confuses rpm's find-requires because it starts with
169     # a """ and it thinks is the shebang.
170     rm -f %i/tutorials/pyroot/mrt.py
171 eulisse 1.289
172