Revision: | 1.2 |
Committed: | Thu Oct 15 18:08:19 2009 UTC (15 years, 6 months ago) by diego |
Branch: | MAIN |
CVS Tags: | DAS_20100302_slc5_amd64_gcc434, DBS_20100226_slc5_amd64_gcc434, DBS_20100217_slc5_amd64_gcc434, FILEMOVER_20100217_slc5_amd64_gcc434, DAS_20100217_slc5_amd64_gcc434, DAS_20100216b_slc5_amd64_gcc434, DAS_20100216_slc5_amd64_gcc434, dg20100201-dbs3, FILEMOVER_20100201_slc5_amd64_gcc434, FILEMOVER_20100128b_slc5_amd64_gcc434, dg20100129-dbs3, dg20100128-dbs3, FILEMOVER_20100128_slc5_amd64_gcc434, DAS_20100127_slc5_amd64_gcc434, DAS_20100126_slc5_amd64_gcc434, FILEMOVER_20100122_slc5_amd64_gcc434, DAS_20100119_slc5_amd64_gcc434, DAS_20100115_slc5_amd64_gcc434, DBS_20100115_slc5_amd64_gcc434, DBS_20100112_slc5_amd64_gcc434, DBS_20100111_slc5_amd64_gcc434, dg20100107b-wmcore, dg20100107-wmcore, DAS_20100105_slc5_amd64_gcc434, DAS_20091221_slc5_amd64_gcc434, DAS_20091214_slc5_amd64_gcc434, dg20091211-couchdb, dg20091210-phedex, dg20091203c-comp-base, DD_20091208_slc5_amd64_gcc434, DAS_20091208_slc5_amd64_gcc434, FILEMOVER_20091208_slc5_amd64_gcc434, DBS_20091208_slc5_amd64_gcc434, dg20091203b-comp-base, dg20091203-comp-base, DQMCATTEST_0_0_1, DAS_20091117, BUILDBOT_01, CERNOIDv02, CouchDB_0_10_0, CERNOIDv01 |
Changes since 1.1: | +27 -1 lines |
Log Message: | Fixed wmcore-webtools spec. Ported the security-module.spec to use it |
# | User | Rev | Content |
---|---|---|---|
1 | diego | 1.1 | ### RPM cms security-module CERNOIDv01 |
2 | |||
3 | %define pythonv %(echo $PYTHON_VERSION | cut -d. -f 1,2) | ||
4 | |||
5 | # Needs python >= 2.6 | ||
6 | diego | 1.2 | Requires: wmcore-webtools |
7 | diego | 1.1 | Source: cvs://:pserver:anonymous@cmscvs.cern.ch:2401/cvs_server/repositories/CMSSW?passwd=AA_:yZZ3e&strategy=export&nocache=true&module=WEBTOOLS/Applications/Security&export=%{n}&tag=-r%{v}&output=/%{n}.tar.gz |
8 | |||
9 | |||
10 | %prep | ||
11 | %setup -n %{n} | ||
12 | |||
13 | %build | ||
14 | |||
15 | %install | ||
16 | cp -p %_builddir/%{n}/Applications/Security/* %i/ | ||
17 | #python setup.py install --prefix=%i # Not yet available for the OpenID server... | ||
18 | |||
19 | # Perhaps the following is needed to fix python source headers | ||
20 | perl -p -i -e "s|^#!.*python(.*)|#!/usr/bin/env python$1|" `grep -r -e "^#\!.*python.*" %i | cut -d: -f1` | ||
21 | |||
22 | diego | 1.2 | # Code to source the dependencies init.sh|csh scripts |
23 | rm -rf %i/etc/profile.d | ||
24 | mkdir -p %i/etc/profile.d | ||
25 | echo '#!/bin/sh' > %{i}/etc/profile.d/dependencies-setup.sh | ||
26 | echo '#!/bin/tcsh' > %{i}/etc/profile.d/dependencies-setup.csh | ||
27 | echo requiredtools `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'` | ||
28 | for tool in `echo %{requiredtools} | sed -e's|\s+| |;s|^\s+||'` | ||
29 | do | ||
30 | case X$tool in | ||
31 | Xdistcc|Xccache ) | ||
32 | ;; | ||
33 | * ) | ||
34 | toolcap=`echo $tool | tr a-z- A-Z_` | ||
35 | eval echo ". $`echo ${toolcap}_ROOT`/etc/profile.d/init.sh" >> %{i}/etc/profile.d/dependencies-setup.sh | ||
36 | eval echo "source $`echo ${toolcap}_ROOT`/etc/profile.d/init.csh" >> %{i}/etc/profile.d/dependencies-setup.csh | ||
37 | ;; | ||
38 | esac | ||
39 | done | ||
40 | |||
41 | perl -p -i -e 's|\. /etc/profile\.d/init\.sh||' %{i}/etc/profile.d/dependencies-setup.sh | ||
42 | perl -p -i -e 's|source /etc/profile\.d/init\.csh||' %{i}/etc/profile.d/dependencies-setup.csh | ||
43 | |||
44 | %post | ||
45 | %{relocateConfig}etc/profile.d/dependencies-setup.sh | ||
46 | %{relocateConfig}etc/profile.d/dependencies-setup.csh | ||
47 | |||
48 | diego | 1.1 | # The following lines are not necessary because they are assumed by default |
49 | #%files | ||
50 | #%i/ | ||
51 |